Showing results for 
Search instead for 
Did you mean: 

Rogers Hitron CODA-4582 Hardware

I'm a reliable contributor
2,050 REPLIES 2,050

Re: Rogers Hitron CODA-4582 Hardware

I plan to stick around
Thanks for the info, I'll try running some more ping tests, but I did some testing last night, turned off the VPN entirely and disabled auto-start in windows, and still no success with the IPv6 after a few reboots and a factory reset. I've also noticed in both my previous modem and current modem, unless them modem does a physical reboot, the WAN UP Time counter doesnt reset when I loose connection, even tho I could be on hold trying to reach the call center for almost 10min with no internet, and then suddenly it will come back online, and act fine....

I've checked all my cables, and they are all fine, I made them myself, so they should be, bought and wired over 1000ft of cat6e cable, and 100 connectors last year and never had an issue with any of my connections, and on each device using them I've plugged my laptop in, which is brand new, not even 1 year old, and each wire give a 1.0Gbps connection, but no IPv6 address on the LAN card; my devices connected to my switch, get a "Temporary IPv6" address from my network switch which supports IPv6, and most of my network devices, but its not reciving IPv6 from the CODA modem.

I even did a second factory reset with nothing connected, just the incomming cable line, and after the firmware update and itself self reset, I used a LAN cable to my laptop with no VPN at all, and tried using it this morning to download a 4.06GB file from Microsoft Windows for an update that keeps failing on my computer, and I couldnt get over 30kbps on average, and then it failed after about 25%... did this about 4 times before i gave up.....

Here are the specs im seeing, if anything looks odd, please et me know, but by all accounts, it should all be working fine, and I should have an IPv6 address coming in, and I sure as heck shouldnt be getting that slow on a download, or having lag and freeze issues using Netflix on only one device with nothing else even connected to the network.... which was my whole afternoon yesterday.....

Hardware Version 1A
Software Version
Gateway Serial Number ************
HFC MAC Address ************
System Time Thu, 11 May 2017 11:03:31
Time Zone UTC-05:00 Colombia, Eastern Time, Indiana(East)
LAN Up Time 000 days 10h:52m:19s

WAN IP Address 99.225.**.***, none
WAN Receiving 9.14G Bytes
WAN Sending 255.88M Bytes
Private LAN IP Address
LAN Receiving 52.37M Bytes
LAN Sending 141.08M Bytes
WAN Up Time 000 days 10h:50m:11s

HW init Success
Find Downstream Success
Ranging Success
DHCP Success
Time of Day Success
Download CM Config File Success
Registration Success
EAE status Disable
BPI status AUTH:authorized, TEK:operational

DOCSIS Overview

Network Access Permitted
IP Address 7.34.**.***
Subnet Mask
Gateway IP Address 7.34.**.***
DHCP Lease Time 😧 06 H: 23 M: 47 S: 44

Downstream Overview

Port ID Frequency (MHz) Modulation Signal strength (dBmV) Channel ID Signal noise ratio (dB)

1 591000000 256QAM -2.200 7 38.983
2 567000000 256QAM -1.800 3 38.605
3 573000000 256QAM -2.300 4 38.983
4 579000000 256QAM -2.700 5 38.983
5 585000000 256QAM -2.000 6 38.605
6 561000000 256QAM -2.600 2 38.983
7 597000000 256QAM -2.700 8 38.605
8 603000000 256QAM -2.300 9 38.605
9 609000000 256QAM -2.200 10 38.983
10 615000000 256QAM -2.300 11 38.983
11 621000000 256QAM -1.900 12 40.366
12 633000000 256QAM -2.600 13 38.605
13 639000000 256QAM -2.200 14 38.983
14 645000000 256QAM -1.700 15 40.366
15 651000000 256QAM -2.200 16 38.605
16 657000000 256QAM -2.000 17 40.366
17 663000000 256QAM -2.100 18 38.605
18 669000000 256QAM -2.300 19 38.983
19 675000000 256QAM -2.200 20 38.983
20 681000000 256QAM -2.700 21 38.983
21 687000000 256QAM -2.900 22 38.983
22 693000000 256QAM -3.200 23 38.605
23 699000000 256QAM -3.400 24 38.605
24 705000000 256QAM -3.300 25 38.983
25 711000000 256QAM -4.000 26 38.605
26 717000000 256QAM -4.600 27 38.605
27 723000000 256QAM -4.100 28 38.605
28 825000000 256QAM -9.500 29 35.780
29 831000000 256QAM -9.700 30 35.595
30 837000000 256QAM -10.300 31 35.084
31 843000000 256QAM -10.300 32 35.084
32 555000000 256QAM -2.100 1 38.605

OFDM Downstream Overview

Receiver FFT type Subcarr 0 Frequency(MHz) PLC locked NCP locked MDC1 locked PLC power(dBmv)

0 4K 275600000 YES YES YES -0.599998

Upstream Overview

Port ID Frequency (MHz) Modulation Signal strength (dBmV) Channel ID Bandwidth

1 38595727 ATDMA - 64QAM 35.500 3 3200000
2 30596000 ATDMA - 64QAM 31.750 1 6400000
3 23700000 ATDMA - 64QAM 31.500 2 6400000


Channel Index State lin Digital Att Digital Att BW (sc's*fft) Report Power Report Power1_6 FFT Size

0 DISABLED 0.5000 0.0000 0.0000 -inf -1.0000 4K
1 DISABLED 0.5000 0.0000 0.0000 -inf -1.0000 4K

Other than the signal being a bit low on the last channels, thats lower than usual, everything looks good to me.
And every time I call rogers about the low signal, they say its fine and passes the tests and blah blah.... and I have has a senior tech out twice and he has replaced, in front of my own eyes, every piece of cable from my modem all the way to the junction down the steet, but my last 4 channels or so are always about -9.5 or lower.....

Anyways, I'm hoping the VPN isnt the issue, like I said, I've done abit of playing, even over the last few months i've tried things like this, but never truley belived they could have been a factor, but its extremely frustating because i pay for services I cant even use, such as my Xbox one S, I havnt been able to play online since Feb, and I have an IP phone for work and programs such as the VPN, that require a constant and stable connection, all of which, including Rogers, I'm paying hefty monthly charges and not getting any real usage.

Do you know if rogers has any additional testing equipment? like long term kinds or things, that can be connected to monitor usage and line strangth at my acctual modem, either in real time or wat ever, because if their is some kind of program like that, like the Neilson Boxes, I would love to find out how to become part of that. I dont really feel like Rogers as a whole is doing much about the issues. I mean, people are, people like yourself and RogersDave and the Beta Testers.... but it just feel likes I get the run around every time I call and try to have the human to human conversation about the issues and get some infomation on whats acctually been done, or being done to resolve them, or what I can do to assist in the testing other than coming on the forums, and I call often, and more often than not, the representative i'm talking too will no NOTHING of these MASSIVE issues that have been going on, and even worse, will try to run only a few basic tests, and tell me everything is fine, and try to get me off the phone... basically treat me, or atleast make me feel like i'm imagining the issues.....

Re: Rogers Hitron CODA-4582 Hardware

I'm a reliable contributor
From what I'm seeing, the only option now is to exchange the modem for another one.

When was the last time you exchanged the modem?

Re: Rogers Hitron CODA-4582 Hardware

Exchanging the modem is one option at this point, but..... before you do that:


1.  Your posts don't show an IPV6 address in the modem.  Can you log into the modem and have a look at the WAN IP address block in the upper right hand corner of the STATUS page.  Does that show both IPV4 and IPV6 address, one after the other in that block space, or does it show an IPV4 address only.  With running it should show both as you can't disable IPV6 with 26T2 loaded.  With .27 you can disable IPV6 if that is desireable. 


2.  Have a look at the back of the modem.  Does that have one or two circular black stickers located close to the power cord plug in?


If there is no IPV6 address shown in the address block, that indicates that the CMTS is not assigning IPV6 addresses to its connected modems.  In that case run a trace to something like  That will run in IPV4 only but thats ok.  Take those results, and paste them into a private message to @RogersDave.  Include the modem MAC address and IPV4 IP address and, indicate to Dave that you're not receiving an IPV6 address from the CMTS.  Follow that link to get to Dave public page when you're logged into the forum.  On the right hand side is a link to "Send this user a private message".  Follow that link to get to the message composition page which will already be addressed.  Add the title and info and hit send.  Watch for a number overlaid on your avatar at the upper right hand corner when you're logged into the forum, indicating a response from Dave.  Follow the avatar link down to the message inbox.  


In terms of modem stability, I would consider running pingplotter to ping the CMTS, for the purpose of seeing what if anything is going on between the modem and the CMTS that might explain the modem's behaviour.  Have a look at the following link and if you decide to set that up, run pingplotter at 1 second intervals for a 24 to 48 hour stretch, looking for packet loss occurrences and possible modem reboots.



Re: Rogers Hitron CODA-4582 Hardware

I plan to stick around

@RyzenFX @Datalink

Yes, thats my main issue, no IPv6 coming thru.... I wont even start on the laundry list of issues thats started my ordeal since mid-January.

I JUST got this modem 2 days ago, on the advice of the call center, because the one I had was loosing connection almost every 10min, this one is the same really tho, no speed and drops out after anymore than about 60-120secs of sustained connection to any source.....

I had a 2 black dot modem, now this is a one black dot......

Its also, and @RogersDave can verify if he wants, lol, but I believe this current modem is my 7th this year!
As I mentioned in my previous post, I get the run arround from the call center and always told to get a new one...

My current advice was to put this one on the beta test, so I have, im just waiting on the push for v.27 to see if that corrects everything or nothing.....

But I mean.... I cant even get my windows updates done because its sooo messed up always.... Ive had the same update fail untold times and my computer restart 20 times a night, because it cant download the files it needs during restart because of the modem failure....
Microsoft sent me the link to download the file mannually and burn it to disc or what ever, but its 4.04GB and I cant even get that because the download fails at 25% or so every time.....

Its just getting kinda krazy ya know....
Paying all  kinds of money for somthing that doesnt work, and on top of it, my other subscription services cant be used because of this....

I think is pretty unfortunate that Rogers didnt do more extensive, long-term testing, on the modems, the network infrastructure, docsis 3.1, and what ever else may be causing everyones issues, but i know of atleast 30 separate homes across the GTA, from west-end mississauga right thru to Scarborugh and alll around; that are not receiving their paid-for service speeds, consistanly, or even a stable connection. Ad for everyone person online here, and that calls in, my guess they know atleast another 30 people like I do, that dont bother to say anything because they dont have the patience to get nowhere, they just suffer and accept it as a part of life. And thats a bad image for Rogers to put out there in my opinion.


As for pingplotter, that my next thing I think, ill see what happens from there, but I'm going to give v.27 a chance and hopfully it all works out.... if not, Ill try 1 las tmodem switch if I can get my hands back on a 2 dot modem; it lasted the longest without massive inturruption into my life, lol

Re: Rogers Hitron CODA-4582 Hardware

I plan to stick around

so I got v.27 pushed late last night,

and still no IPv6


@Datalink do u have any advice?

@RogersDave how about you? Ill PM you my device info if you're able to take a look at this


Re: Rogers Hitron CODA-4582 Hardware

@WestPoint, with .27 loaded, restart the modem or reboot it.  Pull the power and plug it back in again to force a restart.  If you run a factory reset it will revert back to 26T2 which you don't want to do.  


IPV6 - modem running in Gateway mode?  If there is no IPV6 address shown in the WAN IP address block on the Status page, thats a CMTS issue, not a modem issue.  Dave or another staff member will have to look at that problem.  


Modem stability -  The modem, no matter what model it is, should be rock solid.  It should remain running 24/7, interrupt free without you thinking about it.  From the sounds of it, you're not there, and you've had a visit from a senior tech.  So, time to move up from there.  This might take a maintenance crew  to sort out any issues.  Send a private message to @CommunityHelps requesting assistance to resolve the poor serviceability issues.  Send your modem MAC address and internet account number from your bill and outline the issues that you are having with the service dropouts.  Your signal levels are ok, but, I can't tell what the DOCSIS 3.1 levels are due to the erroneous data on the user interface.  However, with continuous dropouts, the signal levels are either where they are supposed to be, or there is no signal level to measure, so, there is some type of issue that isn't showing up in the data.  Running Pingplotter out to the CMTS would show those drop outs.  So, use this link to send @CommunityHelps a private message and keep following up with them to determine the timeline as to when the problems are being addressed.  This should generate a work order number that you should ask for so that you can reference it in future conversations.  


Along with the request, call Customer Support and ask for a rebate and reduction in your future internet rates until the serviceability rates arrive at where they should be.  Customer Support should be able to access the file and see any previous complaints that have been posted on file.   

Re: Rogers Hitron CODA-4582 Hardware

I'm a senior contributor

If there is a splitter on the line, can you check to see that it passes the high frequency channels. I had a friend who had weak signals and it turned out it was due to a no name splitter that capped frequencies at 600 MHz.

Sometimes replacing a splitter could be all that is needed.

Re: Rogers Hitron CODA-4582 Hardware

I plan to stick around
rogers senior tech has done that... he also replaced every single piece of cable from my modem right to the juction down the street....

Re: Rogers Hitron CODA-4582 Hardware

I plan to stick around



So managed to get the IPv6 to show up and that all seems to be going.... 


Took 3 hard boots without reset, like pull the power cord, wait 30secs, plug it in... all with no devices connected and then only connecting my one desktop to see what was going on....


After the third try, for what ever reason, it worked, but the third time I also left in plugged for more like 5min while I did somthing else.... only difference....


And I PM'd @RogersDave, never got a response, but its plausable he did smothignt o correct the issue....


Anyway, so now Im still back to my main issue that started all this back in Jan/Feb, I have everything, all looks great, and I consistly get great speed tests on and every other testing site I use, but yet, I cant seem to download anything at speeds grater than about 8Mbps, and my Xbox One S, on a cat6e cable, cant play online, i get kicked off trying to play basic games like Call of Duty Zombies and new games like Mass Effect Andromeda.....

Any ideas??? like I said the senior tech has done basically everything he can do, is there any one, or any testing program that can come out or i can join, that would allow for a more watched, and detailed analysis of the exact speeds im getting on my devices?

Re: Rogers Hitron CODA-4582 Hardware

I plan to stick around

I have read in another post that there is another Coda with 2 black dots available. Is this correct and does anyone know what the changes are?

Re: Rogers Hitron CODA-4582 Hardware

I plan to stick around

Any idea when the firmware newer than will be release? What if we want to revert to an older firmware? The current issue of not being able to use the Guest network is very annoying as now I'm left with using my primary network for guests. As well, is this issue fixed for modems that have the black dot since it does not work for mine? 

Re: Rogers Hitron CODA-4582 Hardware

I plan to stick around

One mroe question... If the next firmware resolves all my issues, can I remain on that firmware and opt out of future beta releases? It is great that the slow file browsing issue got resolved but now I'm dealing with no Guest network access and am tired of this firmware lottery.

Re: Rogers Hitron CODA-4582 Hardware

@Hucklebury wrote:

I have read in another post that there is another Coda with 2 black dots available. Is this correct and does anyone know what the changes are?

single black dot or 2 black dot there is no difference, it was just a logistics thing... The hardware is all the same. 


Re: Rogers Hitron CODA-4582 Hardware

@David161 you can go back to production firmware .26T2 by doing a factory reset on your CODA modem. 

Re: Rogers Hitron CODA-4582 Hardware

@David161 you can opt out of the Trial Firmware Program at any time, but, all that will happen is that your modem will update to the production firmware whenever that version is released.  That will continue in the future whenever there are updates of the production firmware. 

Re: Rogers Hitron CODA-4582 Hardware

I'm a reliable contributor

@David161 I have no idea when will be released, but it should be within the next 2-3 weeks. If you're on you cannot revert to an older firmware. HOWEVER, if you are on the trial version of and want to revert to the network version, you can reset the modem by pressing the reset pin at the back of the modem for 10 seconds and then release.


The issue with guest network does not effect if you have the black-dot modem. It is a firmware issue which means that users with and above will still experience the issue nontheless. 


If you don't have the black dot modem, I would take the time to switch it out for one of the black-dot ones just to ensure that you have the shielding in place. 

Re: Rogers Hitron CODA-4582 Hardware

I plan to stick around

Thanks guys for the quick answers.


I prefer to confirm myself and proceeded to downgrade to with the reset button at the back of the modem. Sure enough, the issue still persists.


So, I guess I'll have to try and find a modem with the black dot 😞

Re: Rogers Hitron CODA-4582 Hardware

I'm a reliable contributor

@David161 I'm pretty sure your local Rogers store has them in stock. If you have time, just pop into one for an exchange. You should be in and out of there in no time Smiley Happy

Re: Rogers Hitron CODA-4582 Hardware

I plan to stick around

So, silly question time..


I factory reset my modem because I saw I wasn't getting the IPv6 address, and saw some recommendations to do so. After the restart I see that I have one now but the issue became when I went to and it said that my IPv6 address was unreachable.


It may help knowing that on my Archer C3200 I have everything set to IPv6, and to automatically detect the IP, but I was reading somewhere that if the IPv6 gateway had the prefix fe80:... or so on, that it wouldn't be able to connect to anything which is what I have in this case. Should I give Rogers a call or is there something I can try doing?


I'm also on the if that's any help. 

- Hiitchy

Re: Rogers Hitron CODA-4582 Hardware

@Hiitchy, can you flip the modem into Gateway mode, log into the modem and check the STATUS page to determine if both IPV4 and IPV6 addresses are present in the upper right hand corner of the Status data which is the WAN IP address block.  If there is no IPV6 address present, that should be reported to @RogersDave so that he can pass this on to the network engineering staff to look at.  If that is the case, please send Dave a pm with your Modem's MAC address. 


If you have an IPV6 address present, run the same test at to see what turns up.  Then run an IPV6 trace to google:  tracert -6


That trace should run all the way to google.  If it hangs anywhere and times out, please send Dave your Modem's MAC address and the trace.  To copy the trace, right click on the Command box title bar and select .... Edit ... Select All.  Then right click again and select .... Edit .... Copy.  Then you can paste that into the message. 


When thats all done, flip the modem back into Bridge mode .... done.

Re: Rogers Hitron CODA-4582 Hardware

I plan to stick around

Alright, I've exchanged for a modem with the black dot. It says the hardware version is 1A and the firmware is So it should automatically update the firmware to soon and the issue with the Guest network will be resolved?