MyRogers & Rogers Apps
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Ignite TV App on Android Box

I am getting " This video stream is not playable on the current device"   I am getting this message on 3 different android boxes, these boxes I am able to watch netflix, amazon prime and utube.   This is included on live tv and recorded programs, the...

ve3tej by I'm Here A Lot
  • 13 replies

Ignite TV app on Ipad - In-Home wifi

Hello,  We just switched over to Rogers (wifi / TV and home phone). Everything works well, however, I downloaded the Ignite TV App on my Ipad as I often watch my shows on there before bed.  I cannot watch a lot of live TV on the app as it says : Due ...

JoseeG by I've Been Here Awhile
  • 7 replies

Rogers app usage

Ever since I added rogers internet about 4 months ago I haven't been able to check my data usage for my phone on the app. It always says next bill cycle but never works. I was told to make a post here so they could troubleshoot the issue and make a t...

Rcfox by I've Been Around
  • 1 replies

MyRogers App Does Not Find Linked Account

When I try accessing it thru the iOS myRogers app, I always get a popup stating "No Linked accounts" after logging in. However, when I login to MyRogers through, it finds my account without any issues. I tried unlinking and relinking my a...

MyRogers iPhone App

The last two days I have attempted to log in through the iPhone app and it continues to immediately sign me out saying my session expired. What’s going on?       ***Added Labels***

Resolved! Ignite TV App Keeps Cutting In and Out

hi,over the past week I am unable to cast to my nvidea shield android box. I have tried from my iPhone and my wife's Samsung S20. I am able to cast however as it is playing the video will cut in and out every few seconds. if I play it on my device wi...

alijaffer by I Plan to Stick Around
  • 7 replies

MyRogers app not working

I just did a transfer of ownership of my account and I set my password, I can login onto my account on the website but when I try on the app it says “An account is not linked to this profile” and directs me to I am also trying to link my ...

7shp by I've Been Around
  • 13 replies

Error code 20003 via Smart Home Monitoring App

For the past 6 months I haven’t been able to sign in to the smart home monitoring app and I am consistently receiving the error code 20003. I have been told by Rogers that the issue has been resolved on at least 3 separate occasions however the probl...

Milo88 by I've Been Around
  • 1 replies

Rogers App and Data Tracking

I was hoping to raise a concern regarding tracking data...It appears to be that once you add on a data pass to your account mid-cycle, you're no longer able to track your usage.The message displayed in my case is "Since you made a recent change, usag...

Chimdi by I've Been Here Awhile
  • 4 replies

Mobile App Error

Set up auto payment credit card and ensured I set it up a week before my internet bill was due but it didn't register and now I'm a week late for my internet bill.    I left a 1 star review and the developer responded agreeing with me and told me "He...

tokhan by I've Been Here Awhile
  • 2 replies

Resolved! Source cable customer switched over to ignite wifi

Having problems signing in to ignite wifi hub app. It responds with. It looks like you don’t have Ignite WiFi yet. The installer installed three modem and antenna however I cannot use the ignite wifi app because I am a cable source customer.   **Labe...

Wgushue by I've Been Around
  • 2 replies

Unable to use Ignite Wifi Android Application

I am using Google Pixel 4a with Android 13.I have installed this Ignite Wifi application from play store on 30 August 2022.When I open the app , it opens up a browser window to login with my Rogers portal credentials.After successful login, browser c...

Ignite Wi-Fi App Isn't Working (Failing to Login)

You take away the web app, after bricking the on modem features, and now your login services to get into the app are down.  How am I to manage my network when core management is so disconnected?Please just put everything back on the modem. Lastly whe...

MyRogers Site Issues

While using the MyRogers website on Google Chrome, I am unable to change my flex channels and I keep getting a message that reads: "Alert: Technical Error. Sorry, there's a problem on our end. Thanks for your patience while we work to fix it". This i...