MyRogers & Rogers Apps
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Rogers apps on Pixel 7 not working

The following apps do not work on Pixel 7. Rogers Home Connect, Rogers WiFi, Rogers Ignite TV. When you click on these apps, it takes prompts you for the userid and password, on entering the requisite information it defaults back to the sign in page,...

Home connect saying offline but i have wifi

I've been fighting tooth and nail with your tech customer service for over 2 weeks. I'm no longer able to log in to he home connect app also my setting that I had for parent control are not working. I've done everything that I've read online and been...

Can’t sign in to home connect app

Been trying to sign in to home connect app for days. Called tech support many times. Every time I type in my Roger’s credentials on home connect app it just loops back to the sign in screen as if I had never tried logging in at all. No error message ...

Jake44 by I've been here awhile
  • 1321 Views
  • 10 replies
  • 5 likes

Switching among accounts in HomeConnect App

I have 3 accounts under the same login, but I can't switch among them in the app. When I logged in after a while, it asked me which account to select, but when inside, there's no UI to switch to another one. Tried to Sign Out. But when I click "Sign ...

strannik by I've been here awhile
  • 247 Views
  • 2 replies
  • 0 likes

IP cameras hacked and Fing shows open ports

So my Rogers camera and Tapo cameras have been hacked. These ppl talk to me and harass me thru the 2 way I believe and have even started circling my house in 2 or 3 different cars while screaming into the cameras to let me know its them. Very immatur...

Cguyton by I've been here awhile
  • 532 Views
  • 8 replies
  • 0 likes

HomeConnect App Login Loop

We just recently switch over to rogers home services from Telus. We were told we needed the homeconnect App to setup our services. Downloaded the app, tried to login and continue to get the login loop. I've tried uninstalling, delete cache/data and w...

Mattman1991 by I've been here awhile
  • 723 Views
  • 8 replies
  • 1 likes

Resolved! Ignite Home connect app will not login

The Home Connect app will not log me in. It's just an infinite loop of entering my info and the code that is sent to me. Reinstalling doesn't work, changing the browser that opens to enter the info doesn't work, clearing the cache doesn't work. Very ...

Jimmy1313 by I'm here a lot
  • 7560 Views
  • 25 replies
  • 6 likes

Resolved! Ignite app won’t let me login

Hi,I have been a Roger’s mobile member for many years. I recently purchased ignite internet, and am scheduled to have it set up on May 2. I downloaded the ignite app to try to log in and get things ready, but it won’t let me log in with my Rogers cre...

eshrive2041 by I've been here awhile
  • 825 Views
  • 6 replies
  • 0 likes

Can't proceed with home connect app

I bought the Rogers self install modem, and upon downloading the app it keeps on redirecting me to the website over and over. Is this an issue with me alone or other users too? Devs should be on this matter.   **Labels Added**    

KMurreh by I've been around
  • 586 Views
  • 5 replies
  • 1 likes

Can't login in Ignite HomeConnect app

Hello, I just downloaded the HomeConnect app for wifi installation in my new rental. I open it. It automatically opens a web browser page and asks for login. I enter Username, I enter Password, and then I am back on the previous page where it asks fo...

Pebble9757 by I've been around
  • 1294 Views
  • 3 replies
  • 1 likes

Unknown devices accessing wifi

I had about 8 pop ups today at once of devices accessing my wifi. I paused them all (I can tell they are not mine ie. one was a smart doorbell). I changed my password and just got another one. What is happening and how can I make sure my connection i...

mikeandshan by I've been here awhile
  • 353 Views
  • 2 replies
  • 0 likes

Ignite HomeConnect App won't login.

HomeConnect app keeps looping back to the login screen (where you enter your email address) after typing in my password and attempting to log in. Any solutions?Password is correct, if I enter incorrect password I do get a message telling me so.     *...