MyRogers & Rogers Apps
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

How do I view my bill?

Ever since I got Connected for Success with Rogers, it’s proven to be the best service to my experience…at least by far. But I’m having a hard time viewing my bill as I really need to make some payment. I’m sorry for being late on my payments; didn’t...

Connected by I've Been Here Awhile
  • 295 Views
  • 1 replies
  • 0 likes

Special offer email - can't find offer

In the past couple of weeks, I have received two emails saying "Visit MyRogers to view your special offer and upgrade to an Ignite Bundle." The link opens My Rogers, but I see no offers. (Yes, I am logged in.) Would I do better phoning Rogers to see ...

jc277 by I Plan to Stick Around
  • 239 Views
  • 1 replies
  • 0 likes

Resolved! Add to cart - but where is cart?

I clicked "Add to cart" on something. Now I see no way to go to the cart to review it before I complete the purchase. This website is terrible! Hard to navigate. Mostly hype and advertising. Unclear information, possibly incomplete. **Labels Added**

jc277 by I Plan to Stick Around
  • 278 Views
  • 4 replies
  • 0 likes

Error when Swapping Flex Channels

A two and a half hour wait is NOT customer service, by the way ... I'm trying to change some of the Flex channels, in the first month of using Ignite, and when I try to deselect mostly the sports channels, I get this coming up: Removing 4K Channels? ...

Ian_J1 by I've Been Here Awhile
  • 362 Views
  • 5 replies
  • 0 likes

Many Options on My Rogers Account do not work

haven't been able to access My Rogers for more than a week now. Can see my amount owing but can't access anything else on My Rogers, including downloading my bill or looking at the bill. Just the amount owing when My Rogers page loads, nothing else w...

RyeEncoke by I Plan to Stick Around
  • 168 Views
  • 1 replies
  • 0 likes

How do i see my bill and what is "current balance"?

New to rogers. How do I see my bill from the app. I click billing and see "current balance" 0 (payment required by date X) . Then below that is "view bill" which shows a higher number. Which one here is the bill i have to pay. What does the current b...

lakooo by I've Been Around
  • 484 Views
  • 1 replies
  • 0 likes

Unable to use self serve options

Every time I want to make changes to my tv package, I get a message that states "Sorry, we are unable to load the data". It doesn't matter if I click add channels or change bonus channel. I have tried chrome, edge and firefox. Tried it from my phone ...

Mandatory MyRogers username change impossible

I have recently begun getting messages telling methat I have to change the email address I am usingas a user name to log in to MyRogers. But theemail address I am using is the ONLY email addressI have - my full rogers.com address. e.g. -fictitious_pe...

waking by I'm Here A Lot
  • 396 Views
  • 1 replies
  • 0 likes

MyRogers - Device Balance and Upgrade

I just got a new iphone on the 24 month plan. At one point I saw the breakdown of flebtab showing monthly amount, plus phone cost, and ending dates. Now that I've signed up, I'm not seeing this on 'my rogers' account. How do I bring this information ...

MyRogers saying account is cancelled

i just called rogers today and got a new account with them, and ordered a phone. i registered with myrogers, and everything was fine. when i noticed i hadn’t received a confirmation email, i check myrogers account and it is now saying it has been can...

kenzmc6 by I've Been Around
  • 1725 Views
  • 6 replies
  • 0 likes

Unable to make a payment via MyRogers app

I tried making a payment on my Rogers account using the Rogers app on my iPhone. Funny, the app won't accept my card info (CVC code specifically). I hop onto my desktop Windows machine, log into Rogers and try to make a payment with my Visa debit car...

Cannot View Data Usage on App or Browser

I am constantly getting this error on multiple browsers. You don't seem to have that product Close We’re sorry, we can’t give you the information you requested as it seems you are not currently enrolled in that product.If you would like to add produc...

jdf by I've Been Here Awhile
  • 1300 Views
  • 4 replies
  • 0 likes

Resolved! "Details not available"

Why am I getting this detail not available message on myrogers app? Is this a widespread problem, or is it just me with this problem? ***Added Labels***