Showing results for 
Search instead for 
Did you mean: 

CODA-4582 - Open Issues for Investigation

Retired Support

*** This post was last edited May 2, 2017 ***


Good morning Community,


As I mentioned in a post two days ago, we have received the next firmware from Hitron. We are currently running initial testing on this version and will push it out to participants in the firmware trial program as soon as it passes initial testing.


However, while running these tests, we discovered abnormal behavior with ICMP and are awaiting feedback from Hitron today to asses how this will be addressed. As soon as I this is confirmed, I’ll update the change log with the correct version information and start pushing it out.


In parallel, we are still working on the following high priority items. In some cases below, I requested affected customers to reach out to me via private message. If you do so, please include your modem MAC address in the subject line (even if we exchange messages daily) as there are a lot of you reaching out to me daily 🙂


UDP Packet Loss

The investigation for what has been reported as UDP packet loss is still ongoing. We have deployed a probe at one fellow forum member on both a CODA-4582 and a CGNM-3552 to collect additional data. We are actively working with Hitron and Intel on the results observed.


Based on what we know so far, in most instances UDP packet loss is coupled with higher uplink usage in the area. Although the impact is noticeable in specific logs (League of Legends), the root cause for the perceivable impact (while playing) is likely related to bufferbloat (see next issue).




When comparing the performance of a CODA-4582 to a CGNM-3552 in the same network conditions, the CODA-4582 consistently reports higher bufferbloat when tested on DSLReports.


Update April 12: The solution for this problem will come in two folds. It will require a change in software which will possibly be included in but more likely in and a change in network configuration.


The network configuration change is not compatible with the current firmware so this change will only come after a vast majority of the modems are running the new code. We are however looking at a way to make the change only for specific modems to support testing in the community.


Update April 22: This problem seems resolved in firmware



5 GHz WiFi Low range for channels 36 to 48

Lower WiFi channels on the modem have a much smaller range. This is due in part to the limit imposed by Industry Canada to maximum transmit power.


Furthermore, the current automatic channel selection (auto mode) tends to select the lower channels when in similar load conditions.


Workaround: manually select higher channels (149-153-157-161)


Update April 22: The channel selection algorithm has been improved in firmware



Loss of OFDM Channel Lock

Under some RF conditions, the modem fails to lock properly on the OFDM channel. This typically result in variable performance.


Update April 12: This problem is resolved in



List of connected device does not get fully populated

This is a known issue that has been tracked since firmware We are making improvements at every firmware but it is not a perfect system.


The situation is worst after a reboot or firmware upgrade as the list gets reset and must be repopulated as devices renew their DHCP lease.



NAT Loopback not working for wired clients

When setting up port forwarding to an internal server, it is possible for a client on WiFi to reach the server using the external IP/port. If the client is on a wired interface, it doesn't work.


Update April 12: This problem is resolved in (not confirmed)



LAN Counters not working

Some customers reported that LAN counters (especially in bridge mode) are reporting inaccurate values.


This problem has been reported to Hitron for investigation.



Unexpected modem reboot

Some customers reported their modem reboots unexpectedly. We have also seen this behavior in our lab.


Update April 12: This problem is resolved in



Missing SC-QAM Channels

After a reboot, some modems are missing SC-QAM channels. A fix has been implemented in to address this behavior but it has not corrected all scenarios.


Investigation continues with Hitron.



WiFi Survey

The WiFi Survey functionality in firmware (and possibly before) reports incorrect SSID names.



Guest Network

When connecting to the Guest Network, an error message is displayed "only allow DHCP client to use this wireless".  This has been reported in firmware


Update April 22: This issue has been resolved in firmware

Update May 2: It seems this issue is not fully resolved and still experienced by some users


Future Planned Improvements

The following are items that we are working on in parallel of the above.

  • Improvement in WiFi speeds
  • Improvement in latency / bufferbloat





*Edited Labels*

2,620 REPLIES 2,620

Re: CODA-4582 - Open Issues for Investigation

I've Been Here Awhile

Had a similar issue with a printer which wouldn't connect. Found out that it would connect without issue on the 2.4G band. Is your CODA setup to accept 2.4G connections? Have you allowed g/n mixed mode? Hope it works.....

Re: CODA-4582 - Open Issues for Investigation

I've Been Here Awhile

I've switched my modem 3 times already, spoken to technical support varies times. Even have an interaction number after I've escalated the issue, which I receive a call about every week. Technical Support and even the Hitron Engineer still cannot pin point the root cause. Hopefully you guys can give me some ideas, since this issues is almost at 3 months long.


Has anyone faced issues with not connecting to ipv4 sites (ipv6 sites work perfectly fine) on devices wired or wirelessly connected to the Hitron CODA-4582 Router (FW: 33T3)?


We've tried the following...

  1. Technician onsite to check signal
  2. Changed Router 3 times (issue first raised with AC Router) 
  3. Factory Reset several hundred times
  4. Upgraded Firmware to newer version and older version
  5. Disabled IPV6
  6. Re-allocated connected devices between 2.4 vs. 5
  7. Removed all wireless devices and test with wired devices (and vice versa)
  8. Tested with only 1 wired or wireless device

I've ran an test and its unable to connect to ipv4 "unsupported" on one device but successful on another device.  For any device that fails it states that the DNS6 + IP4 is unreachable.


Hope you guys have an insight to resolve this issue.

Re: CODA-4582 - Open Issues for Investigation

I Plan to Stick Around
Have you tried going back to a non CODA modem. I had VERY poor support from Rogers on the CODA, so went to an older modeland the problems went away

Re: CODA-4582 - Open Issues for Investigation

I Plan to Stick Around
So tried other wifi access points and get same error code. Guess it is going back to Samsung.

Re: CODA-4582 - Open Issues for Investigation

I've Been Here Awhile
The issue started with the older modem first Advanced Wi-Fi (black modem) which i had for 3 years, then I went to the CODA modem.