Showing results for 
Search instead for 
Did you mean: 

CODA-4582 - Open Issues for Investigation

Retired Support
Retired Support

*** This post was last edited May 2, 2017 ***


Good morning Community,


As I mentioned in a post two days ago, we have received the next firmware from Hitron. We are currently running initial testing on this version and will push it out to participants in the firmware trial program as soon as it passes initial testing.


However, while running these tests, we discovered abnormal behavior with ICMP and are awaiting feedback from Hitron today to asses how this will be addressed. As soon as I this is confirmed, I’ll update the change log with the correct version information and start pushing it out.


In parallel, we are still working on the following high priority items. In some cases below, I requested affected customers to reach out to me via private message. If you do so, please include your modem MAC address in the subject line (even if we exchange messages daily) as there are a lot of you reaching out to me daily 🙂


UDP Packet Loss

The investigation for what has been reported as UDP packet loss is still ongoing. We have deployed a probe at one fellow forum member on both a CODA-4582 and a CGNM-3552 to collect additional data. We are actively working with Hitron and Intel on the results observed.


Based on what we know so far, in most instances UDP packet loss is coupled with higher uplink usage in the area. Although the impact is noticeable in specific logs (League of Legends), the root cause for the perceivable impact (while playing) is likely related to bufferbloat (see next issue).




When comparing the performance of a CODA-4582 to a CGNM-3552 in the same network conditions, the CODA-4582 consistently reports higher bufferbloat when tested on DSLReports.


Update April 12: The solution for this problem will come in two folds. It will require a change in software which will possibly be included in but more likely in and a change in network configuration.


The network configuration change is not compatible with the current firmware so this change will only come after a vast majority of the modems are running the new code. We are however looking at a way to make the change only for specific modems to support testing in the community.


Update April 22: This problem seems resolved in firmware



5 GHz WiFi Low range for channels 36 to 48

Lower WiFi channels on the modem have a much smaller range. This is due in part to the limit imposed by Industry Canada to maximum transmit power.


Furthermore, the current automatic channel selection (auto mode) tends to select the lower channels when in similar load conditions.


Workaround: manually select higher channels (149-153-157-161)


Update April 22: The channel selection algorithm has been improved in firmware



Loss of OFDM Channel Lock

Under some RF conditions, the modem fails to lock properly on the OFDM channel. This typically result in variable performance.


Update April 12: This problem is resolved in



List of connected device does not get fully populated

This is a known issue that has been tracked since firmware We are making improvements at every firmware but it is not a perfect system.


The situation is worst after a reboot or firmware upgrade as the list gets reset and must be repopulated as devices renew their DHCP lease.



NAT Loopback not working for wired clients

When setting up port forwarding to an internal server, it is possible for a client on WiFi to reach the server using the external IP/port. If the client is on a wired interface, it doesn't work.


Update April 12: This problem is resolved in (not confirmed)



LAN Counters not working

Some customers reported that LAN counters (especially in bridge mode) are reporting inaccurate values.


This problem has been reported to Hitron for investigation.



Unexpected modem reboot

Some customers reported their modem reboots unexpectedly. We have also seen this behavior in our lab.


Update April 12: This problem is resolved in



Missing SC-QAM Channels

After a reboot, some modems are missing SC-QAM channels. A fix has been implemented in to address this behavior but it has not corrected all scenarios.


Investigation continues with Hitron.



WiFi Survey

The WiFi Survey functionality in firmware (and possibly before) reports incorrect SSID names.



Guest Network

When connecting to the Guest Network, an error message is displayed "only allow DHCP client to use this wireless".  This has been reported in firmware


Update April 22: This issue has been resolved in firmware

Update May 2: It seems this issue is not fully resolved and still experienced by some users


Future Planned Improvements

The following are items that we are working on in parallel of the above.

  • Improvement in WiFi speeds
  • Improvement in latency / bufferbloat





*Edited Labels*

2,620 REPLIES 2,620

Re: CODA-4582 - Open Issues for Investigation

I've been around

I’m having a hard time joining my friends in certain games. I have my PS4 hardwired to my coda modem. Games include diablo 3 and all of the call of duty franchise. I am by no means a tech expert, so ANY help would be appreciated!

Re: CODA-4582 - Open Issues for Investigation

I'm a reliable contributor



Same issues as others. CODA 4582, fw .33. Modem keeps rebooting 1-2 times a day since the fw upgrade. Becoming annoying... is this issue gonna be fixed soon (hopefully with next fw update)??

Re: CODA-4582 - Open Issues for Investigation

@pac_west227 wrote:



Same issues as others. CODA 4582, fw .33. Modem keeps rebooting 1-2 times a day since the fw upgrade. Becoming annoying... is this issue gonna be fixed soon (hopefully with next fw update)??

Hi @pac_west227, yes there was a reboot issue with firmware It is presumed to be fixed in firmware which should be fully deployed to firmware trial participants by 7AM this morning.



Re: CODA-4582 - Open Issues for Investigation

I plan to stick around
Seems like the reboot issue is fixed. Almost 2 days here with no reboot. Will continue to monitor

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

Got fw 33T3 yesterday and got I reboot today. Will continue to monitor.

Re: CODA-4582 - Open Issues for Investigation

I've been here awhile

Gigabit Internet - Wifi Speed Issues with CODA-4582


I just recently upgraded to the Gigabit internet from 100u with the CGN3 modem and I have been trying to trouble shoot my issues myself all day without any fixes.  


At first I was running the modem in bridge mode through my R7000 (upgraded firmware and factory reset), but that seemed to have brought my speeds down so I started running it just through the CODA-4582.  


My ethernet connection is solid at 700-950mbps so there are no issues there.  However my wireless speeds on my phone/tablet/laptops have dropped below 100mbps no matter where I am in the house.  Before on my 100u and my r7000 router, my speeds were consistently 140-200mbps on speedtests with 99% consistency.  Now I am pretty much stuck in the 50-70mbps, I would inconsistenly sometimes get a 100-120mbps test on my laptop here and there.


I've tried to optimize my wifi channels and to no avail, currently running on  Pretty sad that my Wifi performance has actually gotten worse for some reason....


Would signing up for the Beta firmware increase Wifi performance on the 4582?

Any help anyone could provide would be much appreciated.

Re: CODA-4582 - Open Issues for Investigation

@mcgrady01, when you had the modem in Bridge mode with the R7000 connected, what were you seeing for ethernet data rates thru the R7000.  There have been a couple of other complaints within the last week which are similar in nature, with the same type of configuration, modem in Bridge mode with a follow on router.  One other router was an Asus RT-AC68U, I'll have to look up the other modem.  But, in any case I believe that they're all Broadcom based routers.  Unfortunately I don't have any explanation that I can offer at this point in time.  All I can do is bring this to the attention of @RogersDave to have a look at.  I don't know if this is a modem issue or possibly a Cable Modem Termination System (CMTS) issue.  The modem connects to the CMTS, which then issues the modem, or router with its IP address.  


Did you consider turning off the wifi on the modem and running the router in Access Point mode for the time being.  That would let you use the wifi on the router for better wifi performance.  I don't believe that loading the trial firmware would give you better wifi performance from the modem.  Fwiw, Beamforming is not enabled on the modem. 


Are you running stock firmware on the router, or something else?

Re: CODA-4582 - Open Issues for Investigation

I've been here awhile

hey Datalink, thanks for your help/input. Its appreciated!

1. The performance I was getting with the R7000 in bridge mode on ethernet was degraded unfortunately, was getting results between 500-750mbps, not the 900+ I was getting with it directly connected into the Modem. So it might be the same thing where it might be an issue with broadcom and the modem possibly?

2. I'll take your advice and play around with having the wireless turn off and having the R7000 run as my wireless AP and see how that goes, hoping for some improvement. Is there anything else I should disable on the modem outside of the wireless if I am using the R7000 as an AP?


Yeah it is running stock firmware, I'm open to trying other ones if anyone else is having success with non stock.

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

Random disconnects with newly acquired  CODA 4582


Samsung S8 will will be working fine then without warning I will realize it has dropped the wifi in favour of LTE

All attempts to reconnect fail giving the message "cannot obtain IP address"

When the iPhone 7 does the same thing the message is "no internet connection available"

Lenovo Windows laptop seems impervious as does my iPad 3 

The laptop has a untion to operate as a hotspot and if we do that both devices will connect problem free/

The only action that resolves the issue it to reboot the router (unplug replug) the modem

Tech support chat has set up a tech to visit because "My tests are indicating that there are some possible signal issues coming into the modem." This does not give me confidence.

I hoping this is the best place to seek advice.



Re: CODA-4582 - Open Issues for Investigation

I've been around

Hi, I'm back on rogers with the Coda-4582 (, wifi off, non-bridged) on 1000/30 service. Is anyone else seeing issues downloading files from google drive via rclone?  I was downloading a 29GB file. The file transfer ramped up to 100MB/sec in the beginning but then tanks after a minute and will sit below 2MB/sec, sometimes it will ramp up again for a short period but then it's back down to like 1.5MB/sec. It's like a roller coaster lol I'm just not getting a consistent file transfer speed. Could this new modem be the cause? I still have my cannet 100/10 service with technicolor modem. I was getting a consistent 11-12MB from google drive on it.  I was going to cancel my cannet service but now after seeing these ridiculous transfer speeds I'm wondering if I should cancel the rogers service and stick with cannet instead. I never had this weirdness back when I had rogers on 250/20 (CGN3ACSMR). Any thoughts?

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

Nest thermostat keeps on disconnecting from Hitron CODA  4582


Hi I'm looking for some help please. I was able to control my Nest thermostat remotely over WiFi but recently my Nest thermostat is unreachable. Nest replaced the thermostat under warranty and I've replaced the Rogers router too. I tried adding a range extender even though Nest is only 20ft from the router. Has anyone experienced this? Nest is saying to call Rogers and Rogers says they only troubleshoot PC / Mac connectivity issues, and not appliances such as the Nest.


Re: CODA-4582 - Open Issues for Investigation

Hi @Doumat,


Welcome to the Community Forums, and thanks for your post!


I've been thinking about adding Nest to my setup at home as well, but have yet to pull the trigger. Having said that, I'm not super familiar with how it works just yet, but perhaps @Gdkitty's post in this thread might be able to offer some direction?  Keep us posted!



Re: CODA-4582 - Open Issues for Investigation

Resident Expert
Resident Expert

You have gone through from scratch, trying to connect it again to your wifi?

I am using the CODA modems with the nest smoke alarms with no issues.
(though i am using the coda in bridge now with my own router)

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

I’m hoping @RogersDave or someone can help me. I just got the CODA modem (f/w 28T2), and I would like to use it in bridge mode. Problem is, the modem comes up with a hard coded IP address ( This conflicts with my private network (, and means I can’t use it in bridge mode.

I have an ER-X EdgeRouter that I’m going to try blocking this address with, but is there any way to change this (seemingly) hard coded IP address?

im willing to try new firmware or different modem if necessary. I’m on the Gigabit package, getting 930/30 right now, so speed is good.



Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

UPDATE -  RESOLVED    Changed out :    CODA-4582 - Open Issues for Investigation 


Well the problem is fixed.   There is a problem with the CODA-4582 modem !    About six months ago Rogers upgraded me for free to the CODA 4582.   Since then my Nest Thermostat app has  not workeded reliably, it seems the Nest Thermostat is not communicating with the Nest Server fast enough so the Nest app on iPad, Android phone or my windows PC says the Nest thermostat is offline


Troubleshooting all without fixing the problem

- replaced the Nest thermostat

- replaced the CODA4582 modem

- Put on a range extender, even though the Nest was less than 15ft from the CODA and good signal 

- Put the CODA into bridge mode and added my own router, then a Google wifi router

All the same problem - problems with the Nest Thermostat access over Wi-Fi



- Tried setting up a wi-fi hotspot using my phone,  with my Nest thermostat and the app works, I change temperature on my phone and it changes the thermostat in about 2 seconds

- Configured my Nest thermostat to log into my neighbour's wi-fi (Bell) .    Nest works and app changes on my phone show up on Nest within 2 seconds



-  Took the drive to the Rogers store and said I would like to try a Rocket Modem (the old model modem I've had for a couple of years)    SUCCESS !    Changes in the Nest app show up within 1 second.


ROGERS:   You have a problem with the CODA modem and no matter how many times I chat or call into your support line, no one cares or shows any interest in fixing this.   Your technical reps will only support Mac or PC connectivity issues, not network appliances (or so they tell me) 

Re: CODA-4582 - Open Issues for Investigation

@Doumat, were you using the wifi on the 4582, or running the 4582 in Bridge mode with a follow-on router?  Thats an important distinction as it points to where the problem might be, on the wifi side, or protocol side. 

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around
Please see my follow on post for full details. NEST Enginnering is investigating adding the Coda router to their problematic list.

Yes I did bridge the router so it was running modem only to a Google WiFi router. No go, had to go back to the Rogers Rocket router, which works both bridged and as a router

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

I am currently on FW 33T3 and while it is stable I still keep on getting these events which seem to cause me to lose my wifi connectivity to the CODA and at times loses the connectivity to my other modem connected via ethernet to the CODA


1411/20/2017 00:36:4682000200criticalNo Ranging Response received - T3 time-out;CM-MAC=*****;CMTS-MAC=*****;CM-QOS=1.1;CM-VER=3.1;
1511/20/2017 13:53:3968010300errorDHCP RENEW WARNING - Field invalid in response v4 option;CM-MAC=*****;CMTS-MAC=*****;CM-QOS=1.1;CM-VER=3.1;
1611/20/2017 19:49:5382000200criticalNo Ranging Response received - T3 time-out;CM-MAC=*****;CMTS-MAC=*****;CM-QOS=1.1;CM-VER=3.1;
1711/21/2017 22:40:0890000000warningMIMO Event MIMO: Stored MIMO=1 post cfg file MIMO=-1;CM-MAC=*****;CMTS-MAC=*****;CM-QOS=1.1;CM-VER=3.1;
1811/22/2017 16:06:0782000200criticalNo Ranging Response received - T3 time-out;CM-MAC=*****;CMTS-MAC=*****;CM-QOS=1.1;CM-VER=3.1;
1911/22/2017 22:40:0468010300errorDHCP RENEW WARNING - Field invalid in response v4 option;CM-MAC=*****;CMTS-MAC=*****;CM-QOS=1.1;CM-VER=3.1;
2011/22/2017 22:43:0090000000warningMIMO Event MIMO: Stored MIMO=1 post cfg file MIMO=-1;CM-MAC=*****;CMTS-MAC=*****;CM-QOS=1.1;CM-VER=3.1;


First my setup:

I am using the Coda connected to my C7 Archer via LAN to WAN connection. The Coda IP is while the C7 is I had DHCP setup for the Coda at to while the C7 is setup from to

What I cannot seem to figure out is why my wifi from the Coda drops out from all my devices and a reboot is necessary to get the wifi connected again (but will drop out again after a few minutes). The wifi from the C7 is stable though except for the last few days which seem to correspond to the event log from the Coda.

I am also having these issues with FW 28T2 which was installed when I got the CODA (reboots have been stabilized with 33T3)

Hopefully somebody from the forum will be able to help me out. Thanks in advance.

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

Doumat, if your WiFi reception reaches your Nest thermostat...a reset of the unit usually establishes a connection, if you previously had a successful install. Had a Blackdot CODA since it came out, Bridged to a Linksys router on the second floor about 75 ft from the Nest Thermostat without any issues. The Linksys WiFi is connected to over 15 IOT devices (Nest, Netamo, Sonos, WEMO, etc) plus many Apple & Window based systems and have had no issues. For critical devices like the Thermostat, I assign a fixed IP address using DHCP reservation. I am also on the 4582 trial program and haven't had any issues connecting to any IOT devices. The only issues were related to Speed & Latency, which over the last 10 months have improved. So perhaps, do a WIFI speed test with a mobile device near your NEST Thermostat ....if you get reception and the speed is half decent then try the NEST reset. It's unlikely but possible that your NEST Thermostat is defective. Do you have other NEST devices (Smoke detector or Camera) and are they visible on your mobile device? If they are than you may have a Thermostat with a defective WiFi          

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around
Thanks. The NEST thermostat was replaced, and the NEST worked when connected via WiFi to my neighbours WiFi or to a WiFi hotspot on my phone. It absolutely would not work with the CODA. As soon as I went back to the Rocket modem, it worked flawlessly

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

Have to say the Nest issue is odd, as I have a Nest (V3), and it works perfectly. I use the CODA in bridge mode with my Ubiquiti EdgeRouter (ER-X which is awesome by the way), with three Netgear routers in AP mode. About 100 items on the net (a lot of IoT devices, of which the Nest is one).


Everything just works, and incredibly fast too. 950/30 is what I see everyday (hardwired, but I do get 600 on my laptop, depending on how close to a router I am).


im not convinced the CODA was responsible for your Nest issues.