Showing results for 
Search instead for 
Did you mean: 

CODA-4582 - Open Issues for Investigation

Retired Support
Retired Support

*** This post was last edited May 2, 2017 ***


Good morning Community,


As I mentioned in a post two days ago, we have received the next firmware from Hitron. We are currently running initial testing on this version and will push it out to participants in the firmware trial program as soon as it passes initial testing.


However, while running these tests, we discovered abnormal behavior with ICMP and are awaiting feedback from Hitron today to asses how this will be addressed. As soon as I this is confirmed, I’ll update the change log with the correct version information and start pushing it out.


In parallel, we are still working on the following high priority items. In some cases below, I requested affected customers to reach out to me via private message. If you do so, please include your modem MAC address in the subject line (even if we exchange messages daily) as there are a lot of you reaching out to me daily 🙂


UDP Packet Loss

The investigation for what has been reported as UDP packet loss is still ongoing. We have deployed a probe at one fellow forum member on both a CODA-4582 and a CGNM-3552 to collect additional data. We are actively working with Hitron and Intel on the results observed.


Based on what we know so far, in most instances UDP packet loss is coupled with higher uplink usage in the area. Although the impact is noticeable in specific logs (League of Legends), the root cause for the perceivable impact (while playing) is likely related to bufferbloat (see next issue).




When comparing the performance of a CODA-4582 to a CGNM-3552 in the same network conditions, the CODA-4582 consistently reports higher bufferbloat when tested on DSLReports.


Update April 12: The solution for this problem will come in two folds. It will require a change in software which will possibly be included in but more likely in and a change in network configuration.


The network configuration change is not compatible with the current firmware so this change will only come after a vast majority of the modems are running the new code. We are however looking at a way to make the change only for specific modems to support testing in the community.


Update April 22: This problem seems resolved in firmware



5 GHz WiFi Low range for channels 36 to 48

Lower WiFi channels on the modem have a much smaller range. This is due in part to the limit imposed by Industry Canada to maximum transmit power.


Furthermore, the current automatic channel selection (auto mode) tends to select the lower channels when in similar load conditions.


Workaround: manually select higher channels (149-153-157-161)


Update April 22: The channel selection algorithm has been improved in firmware



Loss of OFDM Channel Lock

Under some RF conditions, the modem fails to lock properly on the OFDM channel. This typically result in variable performance.


Update April 12: This problem is resolved in



List of connected device does not get fully populated

This is a known issue that has been tracked since firmware We are making improvements at every firmware but it is not a perfect system.


The situation is worst after a reboot or firmware upgrade as the list gets reset and must be repopulated as devices renew their DHCP lease.



NAT Loopback not working for wired clients

When setting up port forwarding to an internal server, it is possible for a client on WiFi to reach the server using the external IP/port. If the client is on a wired interface, it doesn't work.


Update April 12: This problem is resolved in (not confirmed)



LAN Counters not working

Some customers reported that LAN counters (especially in bridge mode) are reporting inaccurate values.


This problem has been reported to Hitron for investigation.



Unexpected modem reboot

Some customers reported their modem reboots unexpectedly. We have also seen this behavior in our lab.


Update April 12: This problem is resolved in



Missing SC-QAM Channels

After a reboot, some modems are missing SC-QAM channels. A fix has been implemented in to address this behavior but it has not corrected all scenarios.


Investigation continues with Hitron.



WiFi Survey

The WiFi Survey functionality in firmware (and possibly before) reports incorrect SSID names.



Guest Network

When connecting to the Guest Network, an error message is displayed "only allow DHCP client to use this wireless".  This has been reported in firmware


Update April 22: This issue has been resolved in firmware

Update May 2: It seems this issue is not fully resolved and still experienced by some users


Future Planned Improvements

The following are items that we are working on in parallel of the above.

  • Improvement in WiFi speeds
  • Improvement in latency / bufferbloat





*Edited Labels*

2,620 REPLIES 2,620

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around
Lagging badly during online games, web pages are slow to load and bufferbloat is abysmal. Hopefully sooner rather than later Roger's will just give up on this modem and put it out to pasture.

Re: CODA-4582 - Open Issues for Investigation

Hey @soundwave80!


Any form of latency can be incredibly trying to deal with to say the least. I'll be happy to assist and identify for you if the issue is network related. Can you PM me your MAC address? Also are you using your own router, and if so have you tested the connection wired directly to the modem with a single device?





Re: CODA-4582 - Open Issues for Investigation

"As I have previously indicated above, the Guest Wifi DHCP problem has been passed onto the engineering staff, who have  confirmed the issue.  So, the fix for this problem has been scheduled for a future release, but I don't know if that means that next firmware release."


6 month checkin... has there been ANY progress at all with this problem?  Will this get fixed at all?

Re: CODA-4582 - Open Issues for Investigation

Hi can you please enable or add 160Mhz to CODA-4582

Re: CODA-4582 - Open Issues for Investigation

I've been around
I have the same problem until now... what was the fix for this?

Re: CODA-4582 - Open Issues for Investigation

Welcome to the Rogers Community Forums @Fair,


Could you please elaborate a little on what issue are you referring to in your post? We would need more information to address your concern.






Re: CODA-4582 - Open Issues for Investigation

Plz let us know how to enable channels bandwidth of 160mhz on Rogers Hitron Gigabyte modem

Re: CODA-4582 - Open Issues for Investigation

I'm a reliable contributor

Hi @Lucky2050, the modem you are talking about (Hitron CODA4582) does have hardware support for channel bandwidth of 160MHz, but unfortunately you cannot enable it because the option is not  in the firmware at the moment. 


I'm not sure if it will be enabled in the future (I highly doubt it), because it's a feature nobody really uses, there is not much consumer hardware support for it (so the hardware you're using right now might not even support it), and the feature is really only available on high-end routers. Routers that are coming in the next few months, such as routers designated with an "AX/ WiFi-6" will have support for 160MHz, but it's very likely that the hardware you're using now will not have support for it. 

Re: CODA-4582 - Open Issues for Investigation

I got  Think pad X1 7th GEN with Wifi 6. Thats why i was looking to have that option on Rogers modem rather buying a wifi 6 router.


If its firmware then rogers should enable it as now more and more devices are coming with wifi 6 Iphone 11 and Samsung Galaxy 10 has wifi 6.


More over its not only speed its about quantity it can handle by having another channel.

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around


I have the same issue as well when I use my guest network.  I got the same error "Only allow DHCP clients to use this wireless".   Can you please help ?    Not sure where I can check the firmware version from my Rogers router. 

Re: CODA-4582 - Open Issues for Investigation

@kermit1 this is an ongoing problem thats been around for seemingly forever.  There are two firmware versions in use, V2.0.10.36T6 and V7.1.1.30.   The problem that you're referring to is definitely in  V7.1.1.30 is fairly new and is supposed to be replaced by the end of the month.  I don't know if the same problem as been carried over to and later versions.   


To find your firmware version, log into the modem and check the Software Version (firmware version) that is shown on the STATUS page.  That page is displayed when you log into the modem.  Please let me know what version you have loaded.  


Re: CODA-4582 - Open Issues for Investigation

I plan to stick around
Hello, I checked my Roger's router version and it is It looks like this is the same issue all along and Roger's hasn't update to the newer firmware that you mentioned. Any possibility that you can offer to fix this issue?

Re: CODA-4582 - Open Issues for Investigation

@kermit1 as far as is concerned, nope, sorry 😞  This is a firmware issue that only Intel and Hitron can fix.  I can probably have a look at at some point to see if the same problem has been dragged into this version as well, or if Intel and Hitron has finally fixed the problem.  Its difficult to test this as my 4582 is running in Bridge mode, so I'll have to find a point in time when no one else is using the internet so that I can swap over to Gateway mode.  Definitely not easy to do that these days.  Ask this again over the next couple of weeks, just to make sure that I don't forget about this.  

Re: CODA-4582 - Open Issues for Investigation

I've been here awhile



I have problem with my Rogers CODA modem and Orbi wifi router. I noticed that the internet is constantly dropped and I cannot do anything. I checked if I can ping google or any other sites, and that cannot be reached. Then I check if I can ping the Rogers Router. And I can. So I called Rogers support team and they checked the modem and said that everything is ok. Then I run traceroute cmd and find that my Rogers modem cannot be reached. after some time and retries of traceroute cmd the connection established and the internet is available in my home. So it seems to me that the problem is between connection of my Orbi and rogers.

Orbi router is connected to CODA via Ethernet and it runs on the latest firmware - V2.5.1.16 and hardware version - RBR50. The CODA modem has software version - v7.1.1.30.

Could you please help to solve this issue?

Re: CODA-4582 - Open Issues for Investigation

Hi @alduk,


Welcome to the Community!


Thank you for listing the troubleshooting steps you've tried so far. Is your modem in bridge mode?  Where is the Ethernet cable plugged into the Orbi router? Did you try a different Ethernet cable? Aside from the Orbi Router, do you also have an Orbi Satellite? 


Looking forward to hearing from you!




Re: CODA-4582 - Open Issues for Investigation

I've been here awhile

Hi @RogersZia 


No, my modem is not in a bridge mode. When I tried to switch it to the Bridge mode, I lost connectivity to it at all. I was not able to connect to it even if I used ethernet cable from my laptop. So I had to reset it to the factory defaults.


The Ethernet cable is connected to the Internet port on my Orbi router and to the 1st port on my Rogers modem.

I'm using the cable that was shipped with my Orbi. I can try another one.

I also have one Orbi Satellite.

Re: CODA-4582 - Open Issues for Investigation

Retired Moderator
Retired Moderator

Thanks so much for the additional information @alduk,


If the connection is working direct to the modem without the Orbi connected, then yeah it would be an Orbi connectivity concern. Have you gone through any of Netgear's troubleshooting steps here? I'm afraid our ability to assist outside of Rogers hardware specific concerns is rather limited.


Perhaps if other's within the community have the Orbi they can weigh in.