Showing results for 
Search instead for 
Did you mean: 

CODA-4582 - Open Issues for Investigation

Retired Support
Retired Support

*** This post was last edited May 2, 2017 ***


Good morning Community,


As I mentioned in a post two days ago, we have received the next firmware from Hitron. We are currently running initial testing on this version and will push it out to participants in the firmware trial program as soon as it passes initial testing.


However, while running these tests, we discovered abnormal behavior with ICMP and are awaiting feedback from Hitron today to asses how this will be addressed. As soon as I this is confirmed, I’ll update the change log with the correct version information and start pushing it out.


In parallel, we are still working on the following high priority items. In some cases below, I requested affected customers to reach out to me via private message. If you do so, please include your modem MAC address in the subject line (even if we exchange messages daily) as there are a lot of you reaching out to me daily 🙂


UDP Packet Loss

The investigation for what has been reported as UDP packet loss is still ongoing. We have deployed a probe at one fellow forum member on both a CODA-4582 and a CGNM-3552 to collect additional data. We are actively working with Hitron and Intel on the results observed.


Based on what we know so far, in most instances UDP packet loss is coupled with higher uplink usage in the area. Although the impact is noticeable in specific logs (League of Legends), the root cause for the perceivable impact (while playing) is likely related to bufferbloat (see next issue).




When comparing the performance of a CODA-4582 to a CGNM-3552 in the same network conditions, the CODA-4582 consistently reports higher bufferbloat when tested on DSLReports.


Update April 12: The solution for this problem will come in two folds. It will require a change in software which will possibly be included in but more likely in and a change in network configuration.


The network configuration change is not compatible with the current firmware so this change will only come after a vast majority of the modems are running the new code. We are however looking at a way to make the change only for specific modems to support testing in the community.


Update April 22: This problem seems resolved in firmware



5 GHz WiFi Low range for channels 36 to 48

Lower WiFi channels on the modem have a much smaller range. This is due in part to the limit imposed by Industry Canada to maximum transmit power.


Furthermore, the current automatic channel selection (auto mode) tends to select the lower channels when in similar load conditions.


Workaround: manually select higher channels (149-153-157-161)


Update April 22: The channel selection algorithm has been improved in firmware



Loss of OFDM Channel Lock

Under some RF conditions, the modem fails to lock properly on the OFDM channel. This typically result in variable performance.


Update April 12: This problem is resolved in



List of connected device does not get fully populated

This is a known issue that has been tracked since firmware We are making improvements at every firmware but it is not a perfect system.


The situation is worst after a reboot or firmware upgrade as the list gets reset and must be repopulated as devices renew their DHCP lease.



NAT Loopback not working for wired clients

When setting up port forwarding to an internal server, it is possible for a client on WiFi to reach the server using the external IP/port. If the client is on a wired interface, it doesn't work.


Update April 12: This problem is resolved in (not confirmed)



LAN Counters not working

Some customers reported that LAN counters (especially in bridge mode) are reporting inaccurate values.


This problem has been reported to Hitron for investigation.



Unexpected modem reboot

Some customers reported their modem reboots unexpectedly. We have also seen this behavior in our lab.


Update April 12: This problem is resolved in



Missing SC-QAM Channels

After a reboot, some modems are missing SC-QAM channels. A fix has been implemented in to address this behavior but it has not corrected all scenarios.


Investigation continues with Hitron.



WiFi Survey

The WiFi Survey functionality in firmware (and possibly before) reports incorrect SSID names.



Guest Network

When connecting to the Guest Network, an error message is displayed "only allow DHCP client to use this wireless".  This has been reported in firmware


Update April 22: This issue has been resolved in firmware

Update May 2: It seems this issue is not fully resolved and still experienced by some users


Future Planned Improvements

The following are items that we are working on in parallel of the above.

  • Improvement in WiFi speeds
  • Improvement in latency / bufferbloat





*Edited Labels*

2,620 REPLIES 2,620

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

I have another issue for investigation.  DHCP reservation table is not working anymore.


Old data entered from the past is correct and it works. All new entries are not working.

I added new device to DHCP table and it shows up with random number and note on the side "DHCP-Reserved" in active device list. Changes to the DHCP table are also causing hard reboot of the entire modem. I don't remember modem doing this in the past.

Re: CODA-4582 - Open Issues for Investigation

I'm here a lot

Word of warning to anyone using OOMA VOIP.


In working to track down my HTTPS issues, I re-enabled the gateway function of the modem and decided to use it for traffic routing instead of my Apple Time Capsule.


Everything went fine until I plugged my OOMA Telo station into the CODA-4582 (via ethernet). Within minutes, I could no longer access the CODA's GUI page, and my speeds had dropped to about 10Mbit. The gateway then started rebooting every hour or two.


Unplugging the Telo resulted in an *immediate* reboot of the CODA Gateway, then everything was back to normal.


Ironically, this device had been connected with the gateway functions disabled, in exactly the same way, without issue prior to this.


I decided to connect via Wi-Fi instead, in case this was some sort of ethernet issue. But the same thing happened.


Enabling SIP ALG, however, seems to have completely resolved the issue. If you *disable* SIP ALG, the gateway absolutely freaks out with the Telo connected.


I'm not sure if Ooma is doing something weird with the VOIP setup or not, but it's telling that the device connected to the CODA Gateway, with gateway functions disabled, works perfectly fine. It was literally the last thing I was expecting to cause the slowdown since it moves nearly no traffic when idle.


Also, as an update, this switch (removing the Time Capsule) *seems* to have resolved the HTTPS issues I was experiencing, but I need a few more days to confirm.


Just an FYI for both Rogers and anyone else with a similar setup on the Beta Firmware.

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

CODA modem and streaming issue


Hi all,


I just received a new CODA modem which I successfully put into bridge mode and is connected to my EERO mesh router system - via ethernet port.


Since getting the new modem, I have noticed that when I am streaming something on my android box, at times, it will buffer and then just stop ad not resume playing. I never had this issue before with previous modem.


It is not the router system as it is brand new, and the modem too was new. 


Can anyone offer me a simple solution to fix this?



Re: CODA-4582 - Open Issues for Investigation

Hello @dzygadlo,


Thank you for your post and welcome to the Rogers Community Forums!


I know how much of a pain it can be when your streaming devices are not working properly especially if it only happened after upgrading your modem. =(


You've definitely reached the right place to find a solution to this matter. We can start by answering the questions below:

  • Are you only noticing issues on your Android box or do you have issues with other devices as well?
  • Is it at all possible to connect the Android box via Ethernet to help rule out a Wi-Fi related issue?
  • Did you factory reset your modem before setting it up or was it already reset to factory? (You will know if it's been factory reset because there will be an EasyConnect Wi-Fi network available to connect to)

We have several Resident Experts that may be able to shine some light on this as well I will be sure to tag them to this post @Datalink@Gdkitty & @gp-se.


We look forward to hearing from you!



Re: CODA-4582 - Open Issues for Investigation

I plan to stick around



The android box is connected to the router directly by ethernet.


I have only noticed the issue when streaming on android box but speeds are good - approx 300 down 20up.


It came factory reset.


I have tried configuring a different DNS on router but that didn't help.


As I said I am only seeing the issue when streaming directly on the android box via ethernet which should have the strongest connection, via Wifi it's the same story.


Its almost like the ethernet port is shutting off mid stream. That possible?



Re: CODA-4582 - Open Issues for Investigation

@dzygadlo I wonder if you're getting momentary dropouts in the cable service?  Do you happen to run anything else like cable tv where you would notice the same issue?


To prove or disprove the point, you could run a ping test to the Cable Modem Termination System, which the modem connects to.  That would show if you're seeing any packet loss between the modem and the CMTS.  That packet loss should be down below 0.01 percent, so, anything much higher would probably point to a cable or connector issue.  If you happen to be on an unlimited plan try the following:


1.  with a pc connected to the modem via ethernet, run a trace to anywhere;



2.  The first IP address in the trace will be the modem, the second will be the CMTS.  If you happen to have the modem in Bridge mode with a follow on router, the first IP address will be the router, the next address will be the CMTS. 


3.  Ping the CMTS:   Ping -t


4.  Use Control^C to stop the test after several hours and have a look at the ping stats.  While the data is scrolling by, if there are timeouts you will be able to see them as they occur.  You shouldn't be seeing any timeouts.  I usually run this type of test for 24 hours when I test for ICMP, UDP or TCP/IP  response times. 


If you were to run Pingplotter, the dropouts, if there are any would be shown on the plot.  Pingplotter will run for 14 days in a freebie Pro mode before it kicks down to a limited free mode.  At that point its up to the end user to buy a pro or standard licence.  The standard licence is more than adequate, and, you don't have to buy a licence at all.  Its a matter of personal choice.


So, if you can, give the ping test a go to see what turns up, if anything. 

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

Sorry but I didn't quite understand what you wanted me to do. 


I understood using command prompt to ping and I tried and this is what I got

Pinging [] with 32 bytes of data:
Reply from bytes=32 time=14ms TTL=55
Reply from bytes=32 time=14ms TTL=55
Reply from bytes=32 time=11ms TTL=55
Reply from bytes=32 time=12ms TTL=55

Ping statistics for
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 11ms, Maximum = 14ms, Average = 12ms


Does this reveal anything or not? 


I am running pingplotter too

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

Just FYI too,

I went back to Rogers store and switched back to Rocket modem in case that was the issue.

It sadly wasn't.

Those results are from the Rocket modem not CODA.

Re: CODA-4582 - Open Issues for Investigation

@dzygadlo the ping results above don't tell me anything.  That test should be run for several hours, looking for dropouts, which will show up as packet loss stats.  When you add the   -t   to the ping command, it will continue to ping until you use Control C to abort the test. 


For pingplotter the same idea applies.  The default display is the target, so if you are pinging for example, your plot will show the return times and losses for the last hop.  What we need to see is the second hop.  If you click or double click on the second IP address in the IP address list, that will display the plot for the modem to CMTS hop.  Anything else beyond the second hop can be ignored.  To close a plot, right click on the the plot in question and select close.  


What you can do is use that second hop IP address and copy/type it into the address bar so that the only IP address that Pingplotter pings, is the CMTS itself.  That modem to CMTS path is usually the problem path.  Typically you will see cable and/or connector issues show up, resulting in packet loss.  There shouldn't be any packet loss.  


In terms of overall latency, you're better off with the CODA-4582 if you happen to be a gamer or run latency sensitive applications such as voip, video conferencing, etc, etc.


If you happen to be watching the display and see a time period where there is regular packet loss, as in every few seconds or every minute for example, call tech support and ask the CSR to ping the modem from the CMTS, or, ping the CMTS from the modem, either one will do.  Explain to the CSR that your experiencing packet loss problems and that your asking for the CSR to run a ping test in order for him or her to see the same occurrence.  When you see packet loss, the CSR should see packet loss as well.  Also ask the CSR to run a signal check on your modem, just to see if the current signal levels and signal to noise ratios are within spec.  Between the signal check and ping test, the CSR should be able to make some determination that a cable/connector issue is afoot and arrange for a tech visit at your convenience. 


Also, please have a look at the following post regarding your amplifier configuration:


Re: CODA-4582 - Open Issues for Investigation

I plan to stick around



Here are some results from pingplotter.


Does this reveal anything?!As0qWl7mmMDkwRKce7AkzqnptYJn

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

I have this problem.

I noticed that the solution was to be released April 2017. I received my modem in 2018, but alas, I don't have this fix possibly, because I was not on record to receive it.

Anyway, my wife wants to let her book club buddies log in to just the internet and not my LAN.

If firmware ( causes no other problems can it please be pushed to my modem.





Re: CODA-4582 - Open Issues for Investigation

I plan to stick around


This is still broken. I have software and guest login still does not work.

I get the hard-to-understand DHCP message.

Re: CODA-4582 - Open Issues for Investigation

Hello @holtzkener,


The guest network is definitely a great option to avoid giving out your actual Wi-Fi password. This specific issue should have been resolved quite a while ago regrettably, we are unable to revert your Firmware back to that specific version as it is quite dated (April 2017).


We would like to take a closer look at this for you to see what is going on and escalate this matter to our Network Engineers if we are unable to resolve via Troubleshooting. We'll need to pull up your modem info in order to take a look at the settings.


Please send us a Private Message to @CommunityHelps so we can gain access to your account info and get started. If you are not familiar with our Private Messaging system please Click Here.



Re: CODA-4582 - Open Issues for Investigation

I'm here a lot

As of today I have the latest CODA-4582 firmware but I was experiencing the problems noted when trying to sign into the guest network. Rogers tech. support changed the number of devices able to sign into the guest network to 10 from 5 and I was able to sign in. They thought it might be because that number may apply to the whole 2G environment or maybe the total 5G and 2G environments. They also mentioned that the modem could only handle 8 simultaneous internet connections (all bands combined) which is something I didn't know. I may have had more than 5 devices connected at the same time but I can't confirm that. Hopefully someone at Rogers can look at this information so the guest network will work. I've had nothing but grief trying to use it.

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

@JGCLGHRN wrote:

They also mentioned that the modem could only handle 8 simultaneous internet connections (all bands combined)

That's outrageous.  Is this documented?  Perhaps they just made it up.

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around
My web management page has stopped working since a couple patches ago. It'll work fine for a day after a reboot, but after that it's unpingable and unreachable. Anyone experiencing the same issue (bridged)?

Also, what happened to Dave?

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

Yes, and I've talked to senior support who have said the issue is escalated to Hitron, they have a reproduced device in this state and are currently investigating it.


Dave resigned and went to work for Hitron AFAIK

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around
I'm on latest firmware on CODA.
DHCP issues have not been addressed at all. Same as previous firmware. DHCP reservation table works up to 9 positions. The 10th device will get random number with the label  DHCP-Reserved in the connected devices list.
Second issue DHCP related is the hard reboot of the entire modem when saving any changes to DHCP reservation table.
I also noticed my phone adapter from NetTalk has a hard time trying to connecting to the server now. Enabled  SIP ALG and rebooted the modem. Still testing if this function is making it any better.

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around
@daveinsurgent wrote:

Yes, and I've talked to senior support who have said the issue is escalated to Hitron, they have a reproduced device in this state and are currently investigating it.


Dave resigned and went to work for Hitron AFAIK

Thanks for the info, Dave. 


That's too bad about RogersDave, he was a good guy and a real asset. Anyone taking over this position on the forums? (Sorry haven't been here in a while).

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

Been having issues where my connetion is really unstable over the weekend only. can only explain these pings to the modem?33.png

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

I fought the good fight in a valiant attempt to keep my CGN3552 modem when extending my promos, but Rogers was having none of that and forced me to switch to the Coda - they might as well have said "we are going to force you to exchange the rock solid 3552 which wasn't giving you a lick of trouble, for the new and improved Coda which will randomly drop its connection multiple times during the day and make your life miserable. Why? Because we can!"


I told him over and over again that there was zero reason to give up a perfectly working modem for the White Tower of Doom - but noooo, it's better, he said!


Well, it's NOT better.


I was on the firmware trial for the 3552 - not sure if that carried over to the Coda? Right now I have 34T6.

I'm using bridge mode, if that makes any difference. Sometimes, but not always, when the connection is dropped, the @ sign flashes.


What can I do? Other than hold my breath and turn blue in the face in an attempt to force them to give me back the 3552?