Showing results for 
Search instead for 
Did you mean: 

Rogers Ignite modem keeps disconnecting but only from my Acer laptop

I've been around

I just got the Ignite modem earlier this month and at first things went smoothly, then when a big internet outage happened about a week ago, I tried rebooting the modem using the laptop's diagnostics function as that had worked before. Only this time it seemingly wiped the personal info of the modem from the laptop and then did a forced restart after 2-3 minutes. I'm on Windows 10 by the way.


So since then, the modem now just shows it as a generic gigabit modem when looking at it in Network & Sharing Settings, and just as a "Network" instead of the name I picked for it. but worse is that it's been frequently disconnecting when trying to view video content most commonly like YouTube or Disney Plus, as if it disconnects if it's getting "too much" data at once.


My last resort is trying a system restore as I should have a restore point from before the modem installation still, but then I'd have to reinstall programs and system updates which I'm not exactly peachy on, nor is it a guarantee that it'll work.


Finally again this is JUST the laptop, all other devices work perfectly fine with this modem. Rogers customer service didn't really help. I just tried plugging the ethernet cable I'm using (Wi-Fi won't work on the laptop anymore for some reason) but so far it doesn't fix the naming issue. Only time will tell if it fixes the disconnecting. Oh and rebooting the computer does fix the connection... until it disconnects again, so there's that.


Can someone who knows what I'm going through help me fix this please? Thanks!



**Labels Added**


Re: Rogers Ignite modem keeps disconnecting but only from my Acer laptop


Hello, @GoldMetalSonic


Welcome to the Rogers Community Forums!


We are sad to hear about the issues you are experiencing with your Acer laptop. Have you tried deleting the saved network information for your modem in your laptop and then setting it up again?


This issue is not one that we've heard about before. Is there anyone else in the Community who has experienced a similar issues with Acer laptops? We would recommend rebooting the modem via the Ignite WiFi Hub app / website or by power cycling the modem to avoid this type of issue in the future.


I hope this helps!



Topic Stats
  • 1 reply
  • 2 in conversation