Internet
Got questions about your modem, router, speeds or WiFi?
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Download/Upload speed is dropping to 10mbps up/down daily

I am on the 500mbps internet service tier.  My internet connection was frequently dropping for 5-10 seconds, about 1-3 times a day. Download/Upload speed was also dropping down to 10mbps across all devices, with high latency.  I replaced the cable mo...

user-v5 by I'm Here A Lot
  • 152 Views
  • 2 replies
  • 1 likes

Internet Service Interruption

I set up my Rogers internet on July 7th and have not had stable connection since installation - internet would keep dropping and come back up. I've already called tech support multiple times and have had 3 visits from Rogers technicians (first one by...

AnnoyedUser by I've Been Here Awhile
  • 141 Views
  • 3 replies
  • 0 likes

Internet outage since this morning in Mississauga (L5M area code)

Anyone else experiencing an outage in Mississauga around Winston Churchill and Britannia?  We've been down since this morning, and just got confirmation this afternoon after finally connecting with rogers support.   How very inept to not provide proa...

imramugh by I've Been Here Awhile
  • 94 Views
  • 2 replies
  • 0 likes

Internet keeps disconnecting

I tried unplugging modem and 3rd party router.This problem seems to happen more frequently. I am now entering the info into my phone (notes) - time/day of disconnection and duration.It went down Tuesday and now today. I don't recall how long it was o...

Pguy by I Plan to Stick Around
  • 40902 Views
  • 1022 replies
  • 0 likes

Wifi issues with xb7 modem

Hi, I recently switched to Rogers 1gb plan and recieved a xb7 modem first day after install I have been getting speeds of 35mb they zapped my internet got speeds of 200mb and it has been fluctuating from 300-500 lately...I got a router and my speeds ...

Tomsaw by I've Been Here Awhile
  • 189 Views
  • 6 replies
  • 0 likes

Getting disconnect ms Team-work

Since the outwage, when working on laptop for work, i get disconnected and then trying to reconnect. Causing issues with my clients on Ms Team. I have Rogers ignite 150g unlimited .I really don't even know what is the issue...is it my internet, my ro...

doze by I've Been Around
  • 62 Views
  • 1 replies
  • 0 likes

No Service after interruption was resolved

Hello. Since the July 8th outage we were losing our internet connection frequently. Last Thursday a tech came out to try and find the issue. He attempted to install a new modem but gave up after being on hold for so long(even techs are on hold). He r...

CjT6 by I've Been Here Awhile
  • 302 Views
  • 8 replies
  • 0 likes

Replacing The Rogers Modem and Optical Node

Hi All,I am looking to replace my Rogers Modem and ideally, optical node with my Ubiquiti EdgeRouter 4.Presently I am unaware of what purpose the Optical Node provides and if it can be replaced by using a SFP directly into the ER4.  I am aware of the...

nettech by I've Been Here Awhile
  • 236 Views
  • 6 replies
  • 0 likes

Network Cable Unplugged Error on Ethernet Adapter

 Hello all, I am getting a "Network Cable Unplugged" error on my Ethernet adapter. I am trying to connect my Asus G11CD Desktop to Ignite WiFi Gateway XB7. I had this same issue years ago with an older modem and a gaming friend who was an ISP helped ...

Symphony50 by I Plan to Stick Around
  • 773 Views
  • 19 replies
  • 0 likes

Email Forwarding @rogers.com email address

Hi Everyone...   I am looking for the option to forward a @rogers.com email address, but to no avail. When I log into the rogers.yahoo.com web portal, the option to forward your email has disappeared.  Can someone confirm this?  I know if you had pre...

Vast majority???

Into day 3 now still no home service in Bowmanville. Yet they report the vast majority are restored. Still a three hour wait to speak to a rep. Not happy.     **Added Labels**

jeddddd by I've Been Here Awhile
  • 304 Views
  • 9 replies
  • 1 likes

Internet is still down

The service is not recovered yet for L3T 4Z3. It has been down over three days     **Added Labels**

trader1117 by I've Been Here Awhile
  • 189 Views
  • 5 replies
  • 0 likes

Ignite Went Out Yesterday. Service Tech Booked...

Ignite went out yesterday. Flashing Green light. Went through the troubleshooting with Anna and a 2 specialists but no luck. Service Tech coming in a couple days. When I check to see if there is an outage in my area today it still says there are no i...

Josh44 by I've Been Around
  • 103 Views
  • 2 replies
  • 0 likes

Internet is not working

My internet has been out for hours. Modem has a solid white light. When I reset (twice), it flashed green, then orange, then back to white. Please help.   ***Edited Labels***

acowie by I've Been Around
  • 103 Views
  • 1 replies
  • 0 likes

Connecting 'rogers.com' email to Outlook on Windows 10

 Hi Everyone, My friend has connected his rogers.com email address using Outlook on Windows 10.  Email flows perfectly fine, using IMAP.  Both the Inbox receives emails, and when we checked on the rogers.yahoo.com website, emails were all there, sent...

Can Rogers throttle speeds?

I ordered the 50Mbps speed from Rogers for my trailer. They moved heaven and earth to sort out the addressing in the trailer park and sent a tech out to connect everything. Works great.   I get my first bill and it's for a 1 GIG speed. This is overki...

CandJ by I'm Here A Lot
  • 221 Views
  • 8 replies
  • 0 likes

horrible speeds over VPN

Hi, I recently switched to Rogers gigabit from Bell. I have a CODA-4582 modem, firmware 2.0.10.34T6. I frequently work from home connecting to work over a Cisco VPN. Everything is much slower compared to when I was on Bell and compared to a friend us...

hoek by I Plan to Stick Around
  • 7456 Views
  • 63 replies
  • 0 likes