cancel
Showing results for 
Search instead for 
Did you mean: 

Rogers Email Inaccessible

DanielShortt
I'm Here A Lot

What has happened to my Rogers email account?  After 20 years of being a Rogers customer, I suddenly can't access my email.  Yesterday it was accessible, today it's not.  What is going on? 

 

 

***Added Labels***

146 REPLIES 146

Re: Rogers Email Inaccessible

I reported it about 6:30 pm and was sent a case number. The agent told me I didn’t have to change any password, it was an issue with Yahoo mail. My email hasn’t worked since 3:30 pm Nov 5. No Status Update from Rogers. They suck at customer service.

Re: Rogers Email Inaccessible

John-Paul
I Plan to Stick Around

Changing your password is the solution that Rogers is giving on Twitter (@RogersHelps).

 

I changed my password and my email started working again.

 

SOLUTION - Change your password

Re: Rogers Email Inaccessible

EmilyAnez
I've Been Around
Does anyone know how long this will last? We are going on to 24 hours. There is work to be done!

Re: Rogers Email Inaccessible

CanadianQT
I've Been Here Awhile

I contacted Rogers about this last night, and was sent an SMS this morning to tell me that the issue had been fixed; however, I am STILL having the same problem!!! Changing passwords is not an option, as two of my accounts won't even log in to the member site (they say, "Sorry, we can't find the username or password in our records. Please try again."). This is a bigger issue than just changing passwords!! Extremely frustrating and disruptive, as we all need access to our email!!

Re: Rogers Email Inaccessible

habsrule999
I Plan to Stick Around

SO... I broke down and went to the member website site and changed the password to use all 4 of the requirements. Then from IPAD outlook i tried to login and it took the new (4 requirements) password. so all good... Then i tried the phone but that still did not work no matter what i tried... Then i tried my IWN10 laptopp running Thunderbird email client and that did not work either. So i had to do , as someone else suggested, to generate an APP password. Then i put the generated app password into the thunderbird login and that worked too...I'll try the phone when my wife gets back at the end of the day..

So Rogers strikes again!!!. No updates, changing stuff without telling anyone and no help!!!......