Mobile devices not "connecting" to Rogers Wi-Fi

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I've Been Around
Posts: 1

Mobile devices not "connecting" to Rogers Wi-Fi

Issue started yesterday and persisted until I left for work today.

My laptop will connect and Is having no issues, however my cell, tablet and FireTV all are registering connection issues/ not connected.

I've brought my tablet and phone to work and connected no problem to Wi-Fi here, so it's not the devices.

Technician has done a remote restart to fix the issue, but won't know how it worked until I'm home, so will update then.

I've noticed a few other people seem to have had the same issue, just wondering if there was a positive resolution.

 

*** Edited Labels ***

Moderator
Moderator
Posts: 906

Re: Mobile devices not "connecting" to Rogers Wi-Fi

Good afternoon and welcome to the Rogers Community Forums @OttawaBrian,

 

I had this same issue with my iPhone X a few days ago. Rebooting my phone did not help, but "Forgetting the Network" and reconnecting to my Wi-Fi did fix the issue for me.

 

Please keep us posted on the outcome of the troubleshooting steps.

 

 

 

 

RogersZia

I've Been Around
Posts: 1

Re: Mobile devices not "connecting" to Rogers Wi-Fi

I also noticed such a problem, I hope it has already been fixed.

Moderator
Moderator
Posts: 1,558

Re: Mobile devices not "connecting" to Rogers Wi-Fi

Hello, @Parcifale.

 

Welcome to the Rogers Community Forums! 🙂

 

Thank you for joining this discussion. A laptop can connect to the WiFi network, but the other WiFi devices failed to connect is certainly strange. @OttawaBrian, were you able to resolve the issue?

 

Let's find a solution for you; please answer the following:

  • What's the model of the modem?
  • Are you using different SSID (network name) for 2.4 GHz and 5 GHz network?
  • Have you changed just the password for your network?

Also, let us know if any changes were made prior to experiencing the issue. 

 

Cheers,

RogersMoin
 

Highlighted
I've Been Here Awhile
Posts: 4

Re: Mobile devices not "connecting" to Rogers Wi-Fi

Any solution found to this issue?
My cell shows connected but no internet access. All other devices are ok.
Moderator
Moderator
Posts: 728

Re: Mobile devices not "connecting" to Rogers Wi-Fi

Hello, @sbown

 

I know how important it is to have all of your devices able to connect to WiFi especially your Mobile devices.

 

Can you let the Community know which modem you are using? Depending on the modem you are using there could be Settings on the modem that could be blocking specific devices. 

 

You can also perform a Factory Reset of the modem which would remove any custom settings including those that block specific devices.

 

I hope this helps!

 

RogersTony

I'm Here A Lot
Posts: 7

Re: Mobile devices not "connecting" to Rogers Wi-Fi

I have the same issue, my cell phone won't connect to my ignite router.  I've factory reset my Android (Pie OS) phone and changed WIFI setting on my phone with no solution.  I connect to my work, friends WIFI networks without any issues.  When I log into Ignite router settings and Press "Reset Wi-Fi Router" to restart Wi-Fi and Router modules my mobile phone connects.  Once I leave the network for the day and come back,  still won't auto connect and tried to force a connection still nothing.   I'm using an TP-link extender linked to my main router to connect to my network.  does anyone have a proper solution.?

Moderator
Moderator
Posts: 258

Re: Mobile devices not "connecting" to Rogers Wi-Fi

Hey @tombgoodu!

 

Sorry to hear you're having issues with your phone connecting to your WiFi at home! Knowing that the reboot allows you to connect again certainly does help though. 

Can you complete the following steps and let us know if the issue persists?

 - "Forget network" on your phone
 - Unplug your Extender (leave unplugged for the duration of testing)
 - Reboot the modem

 

Based on this you should be able to connect again, but let us know if you're unable upon returning home.

Thanks!

 

@RogersAndy

I'm Here A Lot
Posts: 7

Re: Mobile devices not "connecting" to Rogers Wi-Fi

Hello.  I am having the same issue with a Samsung S10+.  This problem started on Saturday Nov 23rd.  I will try this resolution tomorrow.

Moderator
Moderator
Posts: 258

Re: Mobile devices not "connecting" to Rogers Wi-Fi

Hey @phandlstewart!

 

How did the steps work out for you? Are you able to connect your S10+ now?

 

Keep us posted :).

 

@RogersAndy