CODA 4582U in bridge mode - can't access at

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
Showing results for 
Search instead for 
Did you mean: 
Resident Expert
Resident Expert
Posts: 7,064

Re: CODA 4582U in bridge mode - can't access at

@KamWest you have a number of no responses to Unicast Maintenance Ranging and No Ranging Response.  The modem requests maintenance periods from the Cable Modem Termination System (CMTS) on an ongoing basis.  This ensures that the modem time sync with the CMTS is correct and that the CMTS data that is required by the modem to operate correctly is in fact received by the modem.  If the modem doesn’t see a response to the maintenance period request, it logs that receive failure and carries on, only to request the maintenance period once again, very shortly down the road, so to speak.  So the fact that there are a number of these could either indicate that the CMTS is busy or that there is an issue with packet loss.  Its unfortunate that this is logged as a critical event, when in fact the modem simply carries on, requesting another maintenance period very shortly thereafter. 


The other events are the MDD IP Mode Overide (MIMO) and Lost MAC Domain Descriptor (MDD) event, which can be more problematic although their only marked as warnings.  For the MDD, the CMTS broadcasts channel data to the modem so that the modem knows exactly what channels are used to carry network operational data.  As in, for the modem to operate correctly, go to this channel to receive the data required to operate a network between the CMTS and modem, in a nutshell.  In this case, the modem has missed the MDD message and flags the occurrence.  I’ll refer you to the following web page for the MDD description.


For the MIMO event, I’ll refer you to the following page:


Basically, this comes up when there is a difference between what is contained in boot file versus what is contained in the MDD message.  Again, its only a warning.


So, there’s only one MDD timeout and two MIMO events spaced out over several hours, so, there nothing to really be concerned about.  If these were occurring continually over a short period of time, then its worth looking at. 


Don’t read too much into the events log.  You can drive yourself to distraction trying to figure it out and determine if there’s a problem.  In your case, I wouldn’t be too concerned over the contents of the event log.


The important data, personally speaking is the signal table and the ping test.  Is the modem operating within its specified signal parameters and even if it is, is there any packet loss which would be caused by external cable and connector issues, even if the signal levels look ok.  So, that’s why I’d like to see the signal levels and a ping test to see what if anything turns up.


So, you're having problems accessing which would normally be an issue with the follow on router or due to some strange incompatibility with the router.  Some users with follow-on routers have to define a route to the address from the LAN side of the router.  That is not a modem issue.


Are you seeing any other issue besides this and the disconnects?   For the disconnects, I'd like to see the result of a one hour ping test to the Rogers DNS, which should indicate what you're seeing in terms of packet loss and disconnects which would result from them. 


Please post the signal level table again.  Ignore the modem data that sits above that table as its specific to the modem.   


Edit:  *** the ping test should be done via ethernet, not wifi ***

I've Been Around
Posts: 1

Re: CODA 4582U in bridge mode - can't access at

I'm not a tech, but I've had similar issues with an older modem. Power fluctuations perhaps...

Perhaps Noise on the upload line.. replace coax and plug direct into wall (no power bar/UPS)

You've probably done these things though. Good luck.


I've Been Here Awhile
Posts: 4

Re: CODA 4582U in bridge mode - can't access at

It's a shame this issue hasn't been resolved. I have the exact problem as the OP where every 50th or so ping succeeds, I can't login to modem page at and every day the internet "restarts" at the most inconvenient time.


The user (OP) who changed modems several times stated that he has the same issue when connected directly to the modem so I don't know why you guys keep pointing out to the router being the issue. When getting a new modem it works for a while and than this issue happens with no changes to the network. It seems to me that the problem is the modem.


With the Pandemic and work from home situation we can't have the ISP's connection restarting at random. Just yesterday it cut out when my wife was presenting to 200+ people...


The OPs solution was to switch to Bell Fibre...

Resident Expert
Resident Expert
Posts: 7,064

Re: CODA 4582U in bridge mode - can't access at

@Gihad fwiw, the modems are far more reliable than customers and tech support believe.  The actual failure rates don't justify swapping modems out in an attempt to solve cable issues.  That just leads to aggravation on everyone's part.


There is no good reason for a modem to reboot randomly, except for:


1.  instances where the modem has lost communications with the Cable Modem Termination System (CMTS), usually caused by external cable failures; or


2.  overheating, if the modem isn't parked in a location with adequate ventilation. 


My bet is on an external cable fault, which might be intermittent at this point.  The external cable from the house to the local tap is the Achilles heal of cable networks, requiring routine replacement after it degrades beyond a certain point.  If it just failed once and for all, it would be much simpler to determine and replace.  Instead, it fails on an intermittent basis, until one day, it simply dies.  That intermittent failure phase can be hard to determine and very frustrating, to say the least.  


Ok, step one, logging into the modem.  With the modem in Gateway mode, use  With the modem in Bridge mode, use


If the modem doesn't respond to your login attempts, thats an indication that it has version 7.x loaded.  That version becomes unresponsive to user login attempts after a period of time, days, weeks, haven't tracked it down exactly.  Unplug the modem from the wall socket, wait for 10 to 15 seconds and then plug it back in again, forcing a modem reboot/restart.  


Unfortunately, that modem restart also resolves cable issues, at least on a temporary basis.  I'd like to see the modem's signal levels after a period of time has passed, but, for now:


1.  log into the modem and navigate to the STATUS .... DOCSIS WAN tab. 

2.  select the modem signal table, from the start of the "Downstream Overview" line, all the way to the bottom right hand corner of the bottom OFDM/OFDMA Overview.  Park the curser at the beginning of the Downstream Overview line, hold down the left mouse button and scroll down to the very bottom right hand corner of the table.  You can also use the arrow keys to move down and right, to do the same thing.  When that table is selected, copy it, right click .... Copy.  

3.  then in a new post, right click .... Paste.  The end result should look like the table from the modem's UI.  


As I indicated above, the modem reboot will cause the signal data to look pretty good, unless there is something really amiss with the external cable.  So, we'll see how it looks.  I like to see the same table after several hours have passed, maybe even after a day or to, just to compare the before and after levels.  The second login to do this should not require a modem restart.  In fact, I need to see those starts without a modem restart, just to see how they look after several hours or possibly days after a modem restart 


Next step.  Even with good signal levels, its possible to have cable problems that don't show up in the signal data.  If you're seeing service disruptions, that can happen fast enough that they won't show up in the signal data, or perhaps the event log.  You indicted that you were seeing only one in fifty pings actually succeed.  There's definitely a problem with that.  Are you running a ping test via wifi or ethernet, and what's the ping target?  


In order to look for an external cable problem, beyond the signal data, you need to run a ping test to the CMTS.  To do that, run a trace to anywhere.  On a windows pc or laptop, go Start and enter cmd in the Search box to bring up a command prompt.  Type in:


tracert -4


With the modem in Gateway mode, or a modem in Bridge mode with a router behind it, the first Hop IP address will be the modem (Gateway mode) or router (modem in Bridge mode).  The second Hop IP address is the CMTS.  Ping the CMTS for at least an hour using an ethernet connected pc or laptop.  


Ping -n 3600           where is the CMTS IP address (Hop #2 IP address)


That will run for one hour and then terminate.  Copy the bottom results and paste them into a post.  Left mouse button down, and scroll down from the first results line, to include all of the bottom results.  Use Ctrl c to copy the selected data to the clipboard and then paste them into a post. 


You shouldn't see anymore than a handful of packets lost for a 24 hour test, so for a short 1 hour test you should only see one or two packets lost.  


If you wanted to run a much longer ping test, then use:


ping -t           where is the CMTS IP address (Hop #2 IP address)


You would need to use Ctrl c to bail out of the test at any point.  



If you wanted to run a 24 hour test, use:


Ping -n 86400           where is the CMTS IP address (Hop #2 IP address)


Ok, with the signal data and ping test results, that will hopefully point out the problem.  


Just to note, I've had a 4582 running for almost four years now, without any problem.  If I do run into any issues, my first thoughts are to check the signal levels and ping results from the CMTS, looking for potential problems with the external cable.  That 4582 sits on the far edge of my desk, where there isn't any issue with ventilation for the modem.


One other thought, if you have IPV6 running, where the modem's router mode is set to Dual (IPV4 and IPV6), strongly consider setting the BASIC .... GATEWAY FUNCTION .... Router Mode to IPV4.  The modem will take a couple of minutes to sort itself out, but, I will usually run a modem reboot as well, which is located in ADMIN .... DEVICE RESET .... Reboot.  There are sporadic IPV6 issues with the CMTS which keep popping up from time to time, so, setting the modem to IPV4 only will avoid those issues.  Not saying that's the problem here, but, one way to avoid potential IPV6 issues is to simply disable it.  That's unfortunate given the growing use of IPV6, but, it is what it is.  


Fwiw, my better half gives presentations, participates in panel discussions and other group online meetings as required, all done via ethernet connected laptop, with the 4582 in Bridge mode and the router running IPV4 only.  That configuration has been rock solid, even with the pandemic loads at the neighbourhood node and CMTS.  


Is your wife connecting to the modem via ethernet or wifi?  If it's wifi, there are other suggestions for wifi settings that I can provide.


For now, assuming that there's a cable fault at hand, prior to starting something important such as an online conference, unplug the modem, wait for 10 to 15 seconds and then plug it back in, forcing a modem restart/reboot.  That should result in stable performance for the required time period, unless of course, there is something very wrong with the external cable and its connectors. 


Would you happen to know when the external cable was replaced, and, do you have underground cabling or an overhead cable running from a nearby utility pole.  Underground or overhead, the cable still requires replacement after a number of years.  That could range anywhere from after two years to somewhere around 10 to 15 years, perhaps longer.  

I Plan to Stick Around
Posts: 10

Re: CODA 4582U in bridge mode - can't access at

If it makes you feel any better, I too have this. I'm only on my second modem hoping it was an issue due to a faulty modem. I specifically asked for a new modem on my swap, but clearly got another refurb from someone else.


I started using it as a normal router, but the DHCP server doesn't serve IPv6 internally and my internal firewall system was having issues because it kept asking for an IPv6 address. I figured I would try bridged mode again.


Sure enough, I tried today and got no response... same issue as before. If I reboot the modem, it comes back, only to die about a day later. It's absolutely either a hardware or firmware issue with the modem, NOT our own devices.


If the modem would serve IPv6 on the internal LAN via DHCP when not in bridged mode, I'd try that with WiFi disabled and see if the GUI dies after a while (it seemed to be OK for about a week... way more reliable than when in bridged mode).


I'm convinced it's an issue with the firmware and setting it in bridged mode.

I Plan to Stick Around
Posts: 10

Re: CODA 4582U in bridge mode - can't access at

@Datalink wrote:


If the modem doesn't respond to your login attempts, thats an indication that it has version 7.x loaded.  That version becomes unresponsive to user login attempts after a period of time, days, weeks, haven't tracked it down exactly.  Unplug the modem from the wall socket, wait for 10 to 15 seconds and then plug it back in again, forcing a modem reboot/restart.  

BTW, this is the exact issue being reported by the OP. The CODA's GUI is non responsive after a while and requires a reboot to be accessible. If this is an indication of a firmware version, why would this issue not go corrected for years. You also state the modems are very stable, yet this statement completely contradicts this.

I Plan to Stick Around
Posts: 72

Re: CODA 4582U in bridge mode - can't access at

I can confirm I have had this issue on every CODA 4582U I have had so far I am also running pfSense and I find the issue usually resolves itself after rebooting the modem however I usually loose it after a couple of days, it seems to have no impact on my internet speeds, however it has been annoying as over the last couple of months we have been having severe signal issues and I usually have to reboot the modem to login and check signal

Posts: 512

Re: CODA 4582U in bridge mode - can't access at

Hey @Eli_Sand!


Thanks so much for sharing your concern with the inability to access the modem's GUI without a reboot after some time. I've experienced this myself though it's important to note that the MyWiFi app is available and is available for use in lieu of the modem GUI. I do appreciate the preference here and the necessity of logging in to validate your signal levels. 


There's quite a few things to validate to ensure we can narrow down what's causing it for anyone experiencing this issue and is able to complete the steps. I understand it's not possible for all.


 - Ensure the WiFi app has not been connected. Factory Restore the modem if it has. Do no reconnect the app.

 - Connect a single wired device to the modem, with no 3rd party equipment.

 - Ensure the modem is in Gateway mode, not Bridge mode

 - Test the GUI log in 24 hours after a modem reboot/restore.


If the issue persists than this narrows down the issue considerably. Thank you so much.



I Plan to Stick Around
Posts: 10

Re: CODA 4582U in bridge mode - can't access at

Hi @RogersAndy - I can confirm the issue is in bridge mode only; in Gateway mode, the GUI seems to work several days later.


I've never used (or heard of) the MyWiFi app, so no concern there with it causing issues, and the only device I have plugged in is a Ubiquity USG (Unifi Security Gateway). As mentioned when I got this latest modem, I had it in Gateway mode as a test to see how it would fair - for a week it was fine, GUI worked and everything. The main reason I went back to Bridged mode was because I want my devices to get an IPv6 address, and the CODA modem doesn't seem to serve IPv6 over DHCP on it's LAN ports, which caused my USG device to constantly complain because it was configured to get one. Switching to Bridged mode lets IPv6 pass through which satisfied the USG... but after about a day, the GUI dies.

Posts: 512

Re: CODA 4582U in bridge mode - can't access at

Thanks @Eli_Sand.


If the modem is in bridge mode then user access to the GUI should be restricted. To my knowledge this is normal if you're unable to access it. Definitely let us know though if you have any further questions.