cancel
Showing results for 
Search instead for 
Did you mean: 

Apple Watch (GPS + Cellular models) Activation

nasa25
I'm a trusted contributor

OK so the system is now live.  You should get a pop up asking if you'd like to update the carrier settings.  Click Yes

 

Then you go back to your watch app and 'setup cellular' is active.  I was able to get all the way to the 911 address screen but for some reason the 'continue' button is greyed out even when I enter my full address.  So not sure what's going on with that.  But I was able to get like 2 steps from the finish lol

 

 

***Added Labels***

604 REPLIES 604

Re: Apple Watch (GPS + Cellular models) Activation

romanser
I've been around

 For 3 entire days I have been trying to activate cellular on a series 6 watch.  In the watch app, the add cellular tab is greyed out and it displays a message "the rogers account on this iPhone cannot be used to add a cellular plan to <insert name> apple watch".  

  Repeated calls to Rogers has not resolved this issue.  Originally they said it was a credit glitch, after numerous calls and speaking to the credit department who assured me the issue is not with my credit and maintain the error is in their system, more phone calls and after a 2 plus hour call they were finally  able to add an apple watch plan to the account but the original message , "the rogers account on this iPhone cannot be used to add a cellular plan to <insert name> apple watch" remains.

  Just spent literally another hour plus on the phone with their technical support to have it "escalated again" with no success.  Is Rogers simply not able to support cellular on Apple Watches?

  iPhone 12 on rogers network, watch series 6 with gps and cellular. both updated using newest software update.

Re: Apple Watch (GPS + Cellular models) Activation

Rogers support finally contacted me.  There are no phantom lines on the account.  I was asked to restart the phone and try again but as usual got WS300 immediately on signin.  Apparently the techs are looking at this again, but to be honest at this point i'll be surprised if the device activates.  i had 2 GPS only models before this one and it now looks like i've bought a third. 

I see that someone else recently reported activation issues.  It does seem like Rogers still does not know how to support these devices.

Re: Apple Watch (GPS + Cellular models) Activation

vanessaxiao
I've been here awhile
Don’t know if it will help you but I had the same issue with “set up cellular” greyed out. I called the technical line and luckily the guy knows exactly what I am talking about. He said he will turn off something in his end, and then when my call is cut off, I will need to turn off my watch and phone, wait a few minutes and then turn on again. And it worked! The “set up cellular” is available now but I am now having a WS201 issue plus can’t add it to my infinite plan. Don’t have the courage to call again today. Just wanted to share with you what I know.

Re: Apple Watch (GPS + Cellular models) Activation

Viflanzoff
I've been here awhile

Please what while the page is loading...

 

I am stuck on this part of "set up cellular"

 

 

Re: Apple Watch (GPS + Cellular models) Activation

Good evening @Viflanzoff,

 

Welcome to the Community!

 

You've come to the right place! We'll be happy to work with you to ensure your Apple Watch is up and running. Is this a new device? Is your Apple Watch paired to your iPhone via Bluetooth? 

 

Have you had a chance to review our How to add an Apple Watch to your mobile plan page?

 

Please keep us posted.

 

You can also check out Apple Watch general help and support and Updating emergency 911 information on your Apple Watch for further assistance.

 

 

 

 

RogersZia

Re: Apple Watch (GPS + Cellular models) Activation

If you get a WS300 error when trying to activate the cellular function return the watch as soon as possible.  Just walk away and return it, or go to another provider.   Actually don’t walk, run.  Rogers does not know how to support these devices.  It will probably never work on the Rogers network and you have wasted the money spent for the cellular function.

 

I wish I had returned mine months ago and gone back to the GPS version.  My descent into Rogers tech support swamp began in October 2020.  It’s now March 2021 and no end in sight.

 

Tech support is non-existent.  You will spend hours dealing with Rogers tier 1 support going over the same things again and again and again, and escalation after escalation but with no solution at the end of it.  
Rogers has worn me down.  I’ve given up and cancelled the watch service.  It never worked and after 5 months it’s clear that Rogers is unable to identify the problem let alone find a solution.  

 

So if you have an apple watch that works on Rogers, enjoy.

And if you didn’t get the message yet, Rogers tech support is a fiction.  

Re: Apple Watch (GPS + Cellular models) Activation

MichaelYYZ
I plan to stick around

@Setanta

 

I generally am not very active here but I feel compelled to respond to your rather strong message. 

Whilst Rogers has flaws, and perhaps many of them, from my experience I feel they’re trying the best to help. I’ve ran into WSxxx errors before. When I activated my first Apple Watch 4 in 2018, I ran into such issues and Technical Support was struggling to debug. But RogersMaude, here in this very forum, did some magic and the problem was solved quickly. At other times, when I replaced my watch (warranty issues, upgrade to AW6), I received WSxxx errors and a call to Rogers to reset my account and remove the previous watch was sufficient. 

Now, of course, I am not aware of your specific issue related to the WS300 error but being patient and speaking nicely to people may take you father away than simply venting your frustration (which, I do understand, needs to be done sometimes, as well).

 

I wish you the best of luck getting your Apple Watch up and running on the cellular network. 

Re: Apple Watch (GPS + Cellular models) Activation

My  post  states that after 5 months of fruitless back and forth, many chats and escalations, nothing  indicates Rogers can resolve the issue - whatever it is.  As you noted the WS300 error has been around from apple watch day 1.  WS300 is a generic error that means 'something happened' and I've been getting this message for months.  I'm happy to hear that someone was able to solve your issues.  This has not been my experience.

 

In my interaction with Rogers support at no time have I been anything other than patient, respectful, and understanding of the difficulty support staff face when trying to deal with this issue. 

 

To infer from my last post that i have behaved otherwise is incorrect.  

 

Re: Apple Watch (GPS + Cellular models) Activation

MLH11
I've been around

Purchased iwatch with cellular , and go into set up, under Rogers and when I enter my 911 address it won’t accept, thus I can’t continue with the set up.   Called Rogers, they say Apple issue.  Called Apple, they confirmed Rogers issue , which makes sense, it’s Rogers account.  ……..I live in rural , and have box address for mailing but do have physical 911 address which I confirmed with our municipality.  Rogers system still doesn’t accept it……..

Re: Apple Watch (GPS + Cellular models) Activation

Hello @MLH11,

 

A warm welcome to the community forums and congrats on your first post! 🙂

 

I'm afraid that the address entered into the 9-1-1 emergency address screen must be a valid address with Canada Post. Unfortunately, PO boxes are rural roads are not accepted. If the address is not accepted, you would need to enter an alternate address (eg: workplace, school, etc.) that meets the criteria. 

 

So sorry for any disappointment and hopefully, you can provide another address to continue with your Apple Watch activation.

 

Kind regards,

RogersLaura

Re: Apple Watch (GPS + Cellular models) Activation

JeffEh
I've been here awhile

I am now two weeks into this issue....

 

I setup the cellular plan on my apple watch 6 after christmas of this year - it worked fine. In the last month something has happened and it no longer works.  I keep getting the error message:  Your Rogers account is not eligible to enable cellular on your Apple Watch.

 

I have had rogers cancel the line and setup a new line, I have completed, too many to count, resets of my watch and the phone. nothing seems to get this working again.  

 

The 911 screen is fine - it says "activating the cellular line" then boom...the above error message. I have probably spent 12hrs on the phone with rogers now...no resolution. 

 

i'm super frustrated....

Re: Apple Watch (GPS + Cellular models) Activation

Hello @JeffEh,

 

Thanks for joining us here in the forums and for posting your concern!

 

I can certainly understand your reason for being frustrated as this sounds like it's been quite the ordeal! Thanks for sharing what troubleshooting steps have already been taken. I'm sad to hear that nothing has worked so far. 

 

It is odd that this issue came out of nowhere. Do you recall if any changes were made to your services around the time it stopped syncing? For example, did you make any changes to your account or price plan or was a new update installed? I'm just wondering if something may have triggered it.

 

If you would like to send us over a PM, we are more than happy to have another look and see if there is anything else we can try to help get it working once again. For more information on how our Private Messaging system works, please check out our blog.

 

For all of the Apple Watch users out there, if any of you have had a similar issue happen or have some advice on what might get it working again, we'd love to hear from you! 

 

Kind regards,
RogersLaura

Re: Apple Watch (GPS + Cellular models) Activation

JeffEh
I've been here awhile

Laura,

 I did not make any changes to the account...that doesn't mean Rogers didn't....more infuriating than anything else is the complete lack of support.  I have been waiting for over a week for a call back from a manager at Rogers. Your hold times are incredibly long and many times, when i hit the 20/30 minute mark - i get disconnected. This does not seem like a difficult issue to fix...especially for a technology company.  

Re: Apple Watch (GPS + Cellular models) Activation

setzer69a
I've been around

Wow this is actually still happening...in 2022.

The settings tell me my account is not eligible ..blah blah blah...

option to connect is greyed out.

Things ive done.

- tested with telus (works)

- restore watch from backup

- reset watch as new watch.

- reset iphone 

- tried as new new watch / new phone combo

- bought a second apple watch esim package at rogers store and had them install and activate it

- had them reset my rogers shared unlimited and esim package online.

- called rogers 10 times (i have like 4 tickets)

- tried "watch for myself " setup

- they said someone didnt give me R type lines (and they knew how to fix that)

- they reset my numbers and lines

- rogers tech escalated my ticket twice (supposedly ) but did not call me back to check if it worked.

- rogers asked me for a time stamp on the error code i got...(there is no code).

 

i have been almost 10 hours on the phone.

did anyone who had this problem ever get it fixed in the past 4 years????

 

 

 

 

Re: Apple Watch (GPS + Cellular models) Activation

Good day @setzer69a,

 

Welcome to the Rogers Community and thanks for bringing this up to our attention.

 

We'd like the opportunity to access your account to take a deeper look into this. Please send a private message to @CommunityHelps to get started. For details on our private messaging system, click here.

 

RogersMaude

Re: Apple Watch (GPS + Cellular models) Activation

How did you get this issue resolved currently having the same issue

Re: Apple Watch (GPS + Cellular models) Activation

budmd
I've been here awhile

Issue currently having is error WS513

Tried factory resetting the watch, called Tech Support, was told there is nothing wrong with the account. It is a legacy account $15/month. Need help getting this resolved.