Download speed drastically slower on ALL Apple devices

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Darios
I Plan to Stick Around
Posts: 20

Download speed drastically slower on ALL Apple devices

Hello There,

on all  of my Apple devices ( macBook Air, iPad and Apple TV ) the download speed test results are drastically slower by comparison to the download speed tests done on other ( non-apple ) devices on my home network. My Linux computer and Windows get download speeds 4 x faster than any of Apple devices. That is a significant difference.

All download/upload speed tests ( on Linux, Windows and MacOS Big Sur ) were done thru wired ( ethernet cable) connection. Though the testing on wi-fi connection showed  the same results.

 

Even weirder is the fact that on both my  MacBook and iPad I got FASTER download speeds with the VPN on, than when I run the test without VPN on.

On  average any Apple device download speed is 4 x slower than on any non Apple device. For example on Linux I get ~ 900 Mbps download, while on Mac it caps it  down to ~ 220 Mbps only.  All devices go thru the same router, hence all networking rules apply the same for all devices.  Turning off/on QOS made no difference, neither.

  • I can not figure out what is common among all my Apple devices that is capping the download speed so drastically.

Thank you for your help.

 

**Labels Added**

RogersMoin
Moderator
Moderator
Posts: 1,975

Re: Download speed drastically slower on ALL Apple devices

Hello, @Darios.

 

Thank you for your post, and it's surely quite intriguing that all Apple devices experiencing slow download speed. I appreciate you testing the speed on non-Apple devices. When was the last time the speed was normal on Apple devices?

 

More details about your network can help in diagnosing the issue, please answer the following:

  • What's the model of the modem?
  • Is the modem in bridge mode?
  • What's the make, model & firmware version of your router?
  • Do you recall changing any settings on the router recently?
  • Have you tried resetting the router?
  • Have you bypassed the router and tested speed directly through the modem?

We look forward to hearing from you. 

 

Cheers,

RogersMoin

 

 

Darios
I Plan to Stick Around
Posts: 20

Re: Download speed drastically slower on ALL Apple devices

Spoiler
 

Hi,

  • What's the model of the modem? Coda 4582
  • Is the modem in bridge mode?  yes
  • What's the make, model & firmware version of your router? Asus RT-AX88U 3.0.0.4386_42095 ( latest )
  • Do you recall changing any settings on the router recently? yes,  connected a second router ASUS family to my prime router ; second router has a static IP defined on the prime router
  • Have you tried resetting the router? ...Im trying to avoid that, as only Apple devices are impacted
  • Have you bypassed the router and tested speed directly through the modem? yes ; speed test directly from RT-AX88U fluctuates at around ~700Mbps.

  Thank you for your help.

Datalink
Resident Expert
Resident Expert
Posts: 7,334

Re: Download speed drastically slower on ALL Apple devices

@Darios have you:

 

1.  Run a factory reset after loading the Asus RT-AX88U with 3.0.0.4386_42095

2.  Whats the second router model and firmware version?

3.  Is the second router loaded with the same version, specific to that router model and if so, did you run a factory reset after the update?

4.  Is the second router running as an Access Point, or is it running as an AiMesh node?

5.  What LAN port on the RT-AX88U is the second router's WAN port connected to?

 

Consider taking your query to the  Small Net Builders forums located here:

 

https://www.snbforums.com/forums/asus-wireless.37/

 

I'd post a query to the following sub-forum,  New RT-AX88U firmware 3.0.0.4.386.42095:

 

https://www.snbforums.com/threads/new-rt-ax88u-firmware-3-0-0-4-386-42095.70845/

 

or to the following sub-forum, ASUS AC Routers & Adapters:

 

https://www.snbforums.com/forums/asus-ac-routers-adapters.47/

 

I seem to recall a tidbit of info indicating that AiMesh routers had to be connected to Port 1 of the main AiMesh node, which would be the AX66U.  I'll have to try to find that.  I might be confusing that with a Guest network issue with Guest network #1.  In any event, it should be in the release notes somewhere.  

 

If you're running Merlin's Asuswrt on the second router, consider posting a query to the Asuswrt - Merlin sub-forum:

 

https://www.snbforums.com/forums/asuswrt-merlin.42/

 



Darios
I Plan to Stick Around
Posts: 20

Re: Download speed drastically slower on ALL Apple devices

@Datalink 

Thank you for these links;  I'll certainly use them.

 

1. Run a factory reset after loading the Asus RT-AX88U with 3.0.0.4386_42095  ; ...yes, did that

2. Whats the second router model and firmware version?  ...same asus family, fully  compatible - RT-AX86,  with the latest firmware

3. Is the second router loaded with the same version, specific to that router model and if so, did you run a factory reset after the update?  yes

4. Is the second router running as an Access Point, or is it running as an AiMesh node?  neither access point nor AiMesh ;  the purpose of the second router is to isolate a gaming computer from the rest of devices by  putting it on  its own sub-net and separate gaming router.   AiMesh is disabled.  2nd router is connected thru its WAN port  <-  ethernet cable <-  port1 of the main router; ....hmm, now Im thinking maybe this might be a root cause,  incorrectly configured router to  router...

5. What LAN port on the RT-AX88U is the second router's WAN port connected to? #1

 

Thank you.

Datalink
Resident Expert
Resident Expert
Posts: 7,334

Re: Download speed drastically slower on ALL Apple devices

@Darios can you describe the network layout and which devices are connected to which router?  It would help to know what your network looks like.  I'm trying to figure out what the issue is with the Apple devices, so it would be useful to know what router their running off of.  It looks like this is some type of Asus - Apple incompatibility, but I haven't seen any issues posted by anyone else that are similar to this. 

 

Ok, so, the AX86U must be running in full router mode I presume, in order to give the gaming pc its own sub-net.  Question is, why bother?  The problem with connecting the AX86U (in full router mode) to the AX88U is that you're running a double NAT situation for IPV4, with each router doing its own Network Address Translation from WAN port to LAN port.  That can be done, but for any high speed gaming, that's not an efficient way to connect the gaming pc.  There are arguments for and against running a firewalled subnet behind another router, so, you have to ask yourself what you're trying to accomplish and whether or not a double NAT configuration will do that. 

 

The other problem is IPV6.  The CMTS will assign an IPV6 prefix to the AX88U, but I'm not sure that the AX88U will assign a correct prefix to the AX86U.  If you're running IPV6, you should be able to check each router to see what prefix is assigned and try to determine if the AX86U prefix is sensible.  I can see the possibility of problems with the AX86U IPV6 prefix and the final IPV6 addresses that each connected device will have.  If the gaming pc requires IPV6 to run any games, this might be a possible issue.  I've never looked at dual routers running and what their IVP6 prefix's would look like.  Have to add that to my list of things to do...

 

Edit:  Did you make the jump from 384.19 directly to 3.0.0.4386_42095 for both routers?  And if so, was the network layout the same with 384.19 running, and then with 3.0.0.4386_42095 running?

 

Is there a way to remove network profiles from the apple devices, after which point you would then reconnect the devices.  That would, or should cause the apple devices to generate a new network profile.   That's for both wired and wifi network profiles.  I'm wondering what, if anything, Asus did on the LAN ethernet side when they went from 384.19 to 386.1 and beyond.  

 

Are the slow test results with Apple devices attributable to the router firmware updates or possibly to any Apple updates.  Just wondering when you noticed the difference and if that difference would possibly be attributable to a firmware update on the routers or connected devices?



Darios
I Plan to Stick Around
Posts: 20

Re: Download speed drastically slower on ALL Apple devices

@Datalink, 

these are all very good points you've made;

its a very straightforward network layout ; all devices ( Linux, Apple (Mac, iOS), Android ) are connected to the main router, except for the Windows gaming computer which is connected to the gaming router.

 

Apple TV and Mac are wired on 1TB ports, Linux is wired as well on 1TB, everything else is on wi-fi connection.

The one and only device connected to the gaming router ( AX86U) is my teenager's Windows gaming computer.

 

...yes,  AX86U is in  full router mode on its own sub-net.  Im well aware of the double NAT conversions , but this setup does what I expected from it, providing more  stability and security to the home  network; as before it was plagged with dropping IP addresses due to   Gamers Private Network (GPT)  and several VPNs used by other devices getting in conflicts.   Surprisingly even with double NAT conversions the gaming computer is quite fast , though its download speed tests results dropped from ~900MBps to ~700Mbps - on a sub-net.     Plus I just love the idea of  firewalled subnet behind another router, dedicated only  for gamers.

 

You raised a very good point about  IPV6,  that I did not think about when I decided to go with this dual router setup.   I will have to check IPV6 on the gaming router, though I did not hear any complains about any games issues.

 

re: Edit:  Did you make the jump from 384.19 directly to 3.0.0.4386_42095 for both routers?  And if so, was the network layout the same with 384.19 running, and then with 3.0.0.4386_42095 running?

Nope, I made the jump to 3.0.0.4386_42095 before adding the gaming router.  The firmware upgrade did not create any issues.  The slower download speed test results  started  when I  added  AX86U sub-net.

 

I will certainly try to reset network configs on all Apple devices to see if it does make any difference...that's a very good idea.

My Apple devices run on different Apple OS ( MacBook on  Big Sur, iPad iOS,  Apple TV on tvOS14 ), though they share the same Apple platform /  network access component, I'd think.
Thank you very much for your help.
 
Darios
I Plan to Stick Around
Posts: 20

Re: Download speed drastically slower on ALL Apple devices

@Datalink 

So you were right about IPV6 not being properly assigned on the second router ( AX86U ).  It operates only on IPV4 without IPV6.

 

Question:  besides a router on a subnet hidden/firewalled  behind another router,    would you recommend some other configuration ( using both routers ), configuration that would allow to fully isolate  a gaming computer from the rest of devices on my home network ?  ... I really dont care about 2nd router's wi-fi;  the whole purpose is to get a fast wired connection for the gaming computer, in isolation.

Thank you for your help.

Datalink
Resident Expert
Resident Expert
Posts: 7,334

Re: Download speed drastically slower on ALL Apple devices

@Darios, food for thought:  Rogers modems will normally allow customers to connect two devices to the modems when the modems are in Bridge mode.  So, if for example you connected two routers to the 4582, the CMTS, thru the modem will provide each router with individual IPV4 and IPV6 addresses.  

 

To do that, simply connect the second router to the modem, power it up and wait for about two to three minutes for the CMTS and modem to issue the router its IPV4 and IPV6 addresses.  If for some reason the CMTS and modem don't want to co-operate, leave the routers connected and powered up and reboot/restart the modem.  You can simply pull the power from the modem, wait for 10 to 15 seconds and plug it back in to force a modem restart.  If the CMTS and modem behave as they should, after the restart, each router should have its own IPV4 and IPV6 addresses and each one should be running its own independent network.  The modem does not provide any cross-over capability from one router to the other, or from one device to another when the modem is in Bridge mode. 

 

If in the event that the CMTS and modem don't want to play nice and issue both routers their IPV4 and IPV6 addresses:

 

1.  disconnect the first router, which should already have its IPV4 and IPV6 addresses.  Leave the second router connected and powered up. 

2.  Reboot/restart the modem.  After the reboot/restart, the second router should then have an IPV4 and IPV6 address. 

3.  Leave the second router connected, reconnect the first router and power it up.  The CMTS and modem should assign the first router with its IPV4 and IPV6 address.  If not, reboot/restart the modem.  After the reboot/restart, both routers should then have their IPV4 and IPV6 addresses.

 

So, if you can somehow connect the second router to the modem, thru an ethernet path of its own, you can run that second router independently of the first router.   This actually works very well.  I use this on numerous occasions for test purposes.  

 

With the Asus routers, you can check the network map which is displayed automatically when you log into the routers.  That will show the IPV4 address at the top of the map display.  If the CMTS and modem don't co-operate, you'll see an alert indicating that the ISP DHCP isn't working properly.  That will tell you that the router hasn't received its IPV4 address.  

 

For the IPV6 address, I've found that you normally have to reboot the router after setting up the IPV6 parameters.  That reboot allows the CMTS to assign the router with its IPV4 prefix which can be seen on the IPV6 tab.  

 

Note, if the gaming computer requires access to network resources such as a printer or NAS, then this won't work as the gaming computer is off on its own (second) network.  You would have to reconnect the computer to the first network to access those resources.