Showing results for 
Search instead for 
Did you mean: 

Cannot setup Port Forwarding using Ignite XB6 Modem

I'm here a lot



I hope everyone is doing well during these crazy time!


I am trying to setup a Port Forward on one of my computers that has a Static I.P., I have the DHCP server set to assign -

I am trying to setup a Port Forward for a computer with and I am getting the following Error Message:

"Sorry, This Won't Work.  Your device's IP isn't in range. Please check that your device is connected and has an I.P. between and"


When I checked the existing Port Forwards on my profile, I do see a few that I had setup in the past for but when I go to add or change an existing port forward for that computer, I always get an error message.  Everything worked fine prior to the launch of the Ignite WiFi app.


Any help is appreciated.  I contacted Tech Support but they were unable to assist me.


Thank you in advance.





Re: Cannot setup Port Forwarding using Ignite XB6 Modem

I plan to stick around

When you enter the port forward, you are getting it to save the forward? It does show up on the list after saving, etc??

Yes, all ports show up fine in the list.


What you you using to check the port? that its open??

YouGetSignal's port checker paired with TCP listener. I have also gotten various people outside my network to attempt connections. Never gotten anything. The port checker always reads any port UDP or TCP as closed, even if it's actively being used, and TCP listener has never received a ping to my knowledge. It logs pings and connection attempts.


Generally in my experience, going WAY back like pretty much since day1 of rogers high speed in 1995, they havent supported 'loopback'.
So if your trying to connect to whatever your hosting, via your external address, it wont loop back.
to connect internally, would have to connect via that machines local IP address. (this is assuming its running on another PC than the one your using to connect)

I test on the same PC I host anything on when testing within my own network, but I have tried using localhost on my own system and local IP addresses on my partner's laptop and that all works fine I *think*. If it's relevant I'll attempt to get more information there. I haven't attempted to connect to a minecraft server hosted on the PC or any other major test, just done some pings. I can connect to my own servers on the same system but that indicates nothing about ports to my knowledge, since I can do that without port forwarding.


I also port forwarded a port on my phone but have since removed it as I didn't know how to test ports on mobile. I know very little about mobile networking and don't feel confident going beyond that without specific direction, if necessary.

Re: Cannot setup Port Forwarding using Ignite XB6 Modem

I plan to stick around

Any updates? The issue persists.

Re: Cannot setup Port Forwarding using Ignite XB6 Modem

I've been here awhile

I'm on the same boat here. I need a way to forward a port to an internal server which is configured with a static IP address outside the configured Rogers DHCP range. Despite the fact that my server shows up in the list of devices suitable for port forwarding, I get the error "Sorry, this won't work. Your device IP address isn't in range ..." when trying to apply the forwarding rule. ANNOYING!

  • I've reset the modem several times already.
  • The port forwarding menu on the modem keeps saying "Visit to set up port forwards..." Why can't I set up port forwarding directly from the modem's menu? 

This, and the fact that I cannot disable DHCP entirely, is making me regret switching to Rogers.


Modem Model:CGM4331COM
Hardware Revision:2.0

Re: Cannot setup Port Forwarding using Ignite XB6 Modem

I plan to stick around

I'm on the same boat here.

See that's the thing, I don't get that message about it being in range. I haven't had any DHCP issues, it is straight up acting like I port forwarded but, as far as I can tell, it's not actually doing anything


I agree with you that we should be able to directly do this stuff in the modem's software. I don't care if it's optional/opt-in, I get that for the average customer the website is easier to understand, but I have port forwarded hundreds if not thousands of times in my life, and I can't do several steps of troubleshooting I'm used to because I have no idea if what I'm doing is being reflected in the router. I can't actually check to see if the router is reading these ports as forwarded, or if only the ignite website is.


It's quite possible this issue cannot be solved without access to the router, and given that rogers support isn't trained/is unable to help with port fowarding, I may be unable to port forward until something out of my hands changes.


Very frustrating for a service otherwise operating above expectations (best speeds I've ever gotten).

Re: Cannot setup Port Forwarding using Ignite XB6 Modem

I've been here awhile

I ended up modifying the DHCP address range on the Roger's modem to include the static address of my internal server. But I kept the server running with its static address definition, no DHCP, and all other parameters that I want.


The server shows up in the list of available devices on the port forwarding menu anyway and I was able this time to add the port forwarding rules. I just tested the setup and it works!

Re: Cannot setup Port Forwarding using Ignite XB6 Modem

I plan to stick around

Unfortunately mine is already within my range so this won't fix my issue. I'm glad yours is sorted!

Re: Cannot setup Port Forwarding using Ignite XB6 Modem

I plan to stick around

Update: I have been able to open ports using the port triggering feature in the router's software, by setting the trigger and target port ranges to be the same.


This is far from ideal or a permanent solution, but it does make me think the issue is with this ignite website I'm being sent to. If I was able to port forward within the router's own interface I believe it would work.


Interestingly, when I first attempted this using the port triggering feature, I still had a port forwarding rule on the ignite website, and the router's interface told me I could port forward and trigger the same ports at the same time. So the website at the very least is connected to the router, it just doesn't actually open the ports for some reason.


Again, no errors, no range issue, nothing like that, it acts like it's port forwarding but just doesn't actually open them.


My next test will be getting a cheap 1000mbps router and bridging the rogers router to it, and testing port forwarding through that. If that works it would really narrow this down, but more importantly, that's an actual permanent solution, unlike this port triggering feature which I am not very familiar with and certainly not using as intended.

Re: Cannot setup Port Forwarding using Ignite XB6 Modem

I plan to stick around

Second update: Nevermind, the solution was just to turn DMZ mode on and then off again. Now the website works perfectly.


Absolutely no idea how that's even possible but if anyone from rogers ends up reading this, or anyone having the same issue, that's how I solved it.


Tested it with a dozen or more ports, it's working as intended. I'm not even particularly clear on what DMZ mode does but it seemed to kick the port forwarding into action. I turned DMZ mode on last night while playing a game with friends to get my NAT type to read as open, and turned it off today because I noticed I left it on, and bam, now the ports are forwarding.

Re: Cannot setup Port Forwarding using Ignite XB6 Modem

Port Forwarding Minecraft Server:


I've been trying to port forward to setup a minecraft server for me and my friends. I followed this tutorial:


Everything was going smoothly, however when I got to the end and had to port forward through the ignite wifi hub it looked very different then others. It gave me options such using a manual setup, which showed no manual options, or a bunch of common applications such as Minecraft. I tried port forwarding 25565 using both manual and Minecraft options and found my public IP both online and on the rogers ignite hub. I can't seem to be able to connect to my server using my public IP address but I can connect using localhost or my IPV4 address. I've been looking for solutions online and I can't find anyone using ignite wifi to port forward so now I am here. If anyone has any solutions I'd be overly grateful! Thank you!

Re: Cannot setup Port Forwarding using Ignite XB6 Modem

I've been here awhile

This is an old thread, but after much research and futile attempts, I found the best alternative to be able to access my media server from outside my home network:


My set up is....the internet ---> myRogers Ignite cable modem/router (non-bridged because Ignite TV and Pods use the built in Ignite WiFi) ---> the Ignite cable modem to my Asus router through the WAN connection ---> my media server to the Asus router. I know I could have turned the Asus router into an access point but I wanted the security it provided to be in place even though the Ignite modem has some level of I then still have my home WiFi network with Ignite TV being on its own WiFi network from the Ignite modem.  


Long story short, the issue was trying to forward a port through the Asus router failed when it tried to go through the Ignite cable mode. Tried using the Ignite WiFi app (android phone because the desktop Ignite cable modem interface doesn't allow port forwarding) but it would not work for my port forwarding because it didn't see my Asus router as being connected even though it was.


So after watching a great YouTube video, I set the media server's NIC to a static IP address with the Asus router, and the through the Ignite WiFi app set up a DMZ for the port on the media server's app using that port number, the static NIC address and the Asus router's WAN IP address as assigned by the Ignite modem. Tested the port before and after with the program Simple Port Tester, and it works fine now.


If anyone finds this useful, great....I know I found it a challenge to sort out but I enjoy these types of IT puzzles.


Even though I know I am double NAT'ed with the Asus router and the Ignite modem, that isn't an issue as I don't game online or require the modem to be in bridge mode which would jeopardize the Ignite TV connectivity, and using my Asus WiFi for Ignite TV didn't get me the coverage throughout the house like the Ignite cable modem WiFi/Pods do.

Re: Cannot setup Port Forwarding using Ignite XB6 Modem

Unless I'm missing some details, this appears to be a dirty, unconventional, and incomplete workaround to a bigger problem with the XB6's incredibly poor implementation of port forwarding configuration options.


The solution provided by @knsaunders only works for LAN devices that have a dynamic or static IP assigned by the XB6's DHCP server.


This solution does not work for LAN devices that locally assign a static IP to their network interface. Conventionally, static IPs assigned on LAN device clients use addresses that are outside of the range of the DHCP server start/end addresses.


While the XB6 supports a LAN subnet configuration separately from the DHCP range start/end addresses (which really is only useful for accommodating LAN devices that assign their own static IP without requesting it from the DHCP server) the XB6 does not support port forwarding to any such devices.


The XB6 is apparently and short-sightedly crippled in this way by Rogers' firmware. Unless I've missed something, the XB6 only supports port forwards to LAN devices that are in the scope of the DHCP range of addresses.


In other words, the XB6 simply doesn't support configuring port forwarding to LAN devices in the scope of the subnet when the LAN device assigns its own IP address within the range of the subnet in the address space which doesn't conflict with those addresses otherwise assigned by the XB6's DHCP server. There just doesn't seem to be a way to configure a port forward to a LAN IP address. The XB6's trashy online ignite wifi portal is the only way to create a port forward, and port forwards are limited to LAN devices that are 1. actively connected to the XB6 at the time you want to create a port forward, and 2. only for those LAN devices configured as DHCP clients in the  address space of the XB6's DHCP server.


Can't say that such limitations are surprising considering the way that Rogers has implemented the XB6 configuration interfaces spread out arbitrarily between the local admin panel accessible from LAN devices, and the entirely differently nuanced UI hosted on the ignite wifi portal cloud garbage. Total lack of cohesion and reason to some features available on the LAN admin interface that are mysteriously missing from the ignite wifi portal, and similarly other features (e.g. port forwarding/triggering, DMZ, etc.) that are on the ignite wifi portal but mysteriously missing from the LAN admin interface.


Oh... that's not to mention the general bugginess of the combined configuration interfaces for the XB6... All to often the only resolution provided by rogers tech support is to factory reset the XB6. That's laughable, specially considering there doesn't even seem to be a way to backup/restore the XB6 configuration.


. , when I try to add a port forward and select my LAN device, the port forward rule is created for an IP address that isn't even assigned to that device. I literally cannot create a port forward to some of my LAN devices, and my XB6 is creating port forwarding rules with the incorrect IP address even when the device has an IP address assigned in the DHCP range with a Reserved IP.


Even what limited features are available are easily/frequently broken.


But hey.. just factory reset. Right? That's reasonable. Right?


NO... its not OK to suggest factory resets when your XB6 support is buggy.


Maybe I could forgive the process if the XB6 supported any sort of backup/restore options for its configurations, so that it could be restored to my desired settings after a factory reset. But even the feature for a configuration backup/restore is not supported on the XB6.


I don't want to have to manually reconfigure my whole . network when Rogers equipment bugs out without a suitable solution.


Sadly, Rogers chooses to release the XB6 with firmware that implements a feature set that falls short of industry standards that is buggy to boot. 

Re: Cannot setup Port Forwarding using Ignite XB6 Modem

I've been here awhile

The port forwarding can be configured not on the modem but from the ignite web page. For me it was under

Re: Cannot setup Port Forwarding using Ignite XB6 Modem

if you're replying to my post, i guess you didn't read much of it eh? trying to configure port forwards from the 'ignite web page' wouldn't work properly for all the reasons i explained before and rogers support had no idea how to fix it and kinda just said 'sorry not really sorry we have no access to support issues on the ignite web page'.

the ignite web page is buggy, poorly designed, and outright broken in some regards. plain and simple.

Re: Cannot setup Port Forwarding using Ignite XB6 Modem

I plan to stick around


It is disappointing to see that my Ignite XB6 modem's advanced settings can only be done via the ignitewifi website or app.  And of course, when I need to get in there, it is not working.


I log on to the modem/router -> Advanced -> Port Forwarding.

Message says that these settings are on

OK fine... Log on there.  Click the Connect tab, then See Network.

Scroll down, hit Advanced Settings.  Click Port Forwarding... it thinks for a couple of seconds

and I get     "We Encountered an Issue. If the problem persists, check back later."


Try this via the Ignite Wifi app on my phone.   Same result.


This is such a simple setting and Rogers has found a way to mess it up.  And yes I have unplugged the modem and plugged it back in.       😞


Re: Cannot setup Port Forwarding using Ignite XB6 Modem

I plan to stick around

I'm not sure why my post was moved to this thread.  This thread's "solution" post does not address the issue I am experiencing.  


I do have port forwards set (they were set last year).  And now I want to set another.  But I cannot even reach the Port Forwarding page.    Once I click on Port Forwarding on the Ignite website, I get a generic error message.  


This same error message appears when I try to access Port Forwarding via the Ignite app on my phone.    So frustrating.     See screenshot below....



Re: Cannot setup Port Forwarding using Ignite XB6 Modem

I know there are split people here.  Some that cant access the ignite page for port forwarding, and others that can...but cant get the port forwarding to work.

I am in the latter of the two groups.  Has anyone figured this out?  I fluked it into working about 6 months I have 3 ports working (It took about 7 factory resets, which is laughable).

I have access to the port page, set the ports, yet it still fails.

Ive opened the ports on Windows, my Velop mesh system, and the modem.  Still fails.  Connect direct to modem?  Still fails, even though the Ignite software says it is still open. (Obviously not the case).

It's frustrating that we cannot access the actual modem, and have to use this, obviously not functional, software. 

Any insight on how to get this to work would be amazing!

Topic Stats