Showing results for 
Search instead for 
Did you mean: 

Certain Apps Connect over Wi-Fi but not Data.

I Plan to Stick Around


There are apps on my iphone 6s that will not connect to my security cameras when on cellular but have no problem when on wifi. I have done the network reset, deleted the app and reinstalled, erased the phone and restored from the back up. Still does it though. Tonight I took the simm card out and tried my daughters from another carrier and the apps worked fine like they should. Reinstalled my rogers simm and problem is back. It seems to have started after the ios 11.4 update, 11.41 update didn't fix the problem either. in settings its says Rogers 32.0 for carrier

Also my wife's iphone is behaving the same so I don't think it is a simm card problem

Any ideas


*** Edited Labels ***


Accepted Solutions

Re: Certain Apps Connect over Wi-Fi but not Data.

Good morning,


Welcome to the Community & thank you for your posts @Dave2861 and @Jnick1982!


If you guys are still experiencing this issue please reach out to us via PM @CommunityHelps so we can identify the cause and create a ticket if applicable. You can find more information on our private message system here









View solution in original post


Re: Certain Apps Connect over Wi-Fi but not Data.


Hello @Dave2861,


I know how frustrating it can be not being able to view your security cameras over data when you are away from the home. It brings a lot of piece of mind seeing whats going on at home while you're away. 


We'll need a bit more information before we can determine how to resolve this issue. Can you let us know the names of the specific apps that are affected? Can you also tell us approximately when you did the update to iOS 11.4 and subsequently starting noticing this issue?


We look forward to your response!




Re: Certain Apps Connect over Wi-Fi but not Data.

I was about to ask a general question about this, but if I can be of any help, adivce I will be technical 🙂 :

- I noticed after sniffing packets on my iPhone that on Rogers network we are now getting IPv6 addresses instead of normal IPv4 addresses that everybody is used to .

IPv6 looks like : 2001:0db8:0000:0000:0000:ff00:0042:8329

IPv4 looks like :

- There are equipements, DNS64/NAT64 at provider level, that exists that are able to convert DNS server name in front of IPv4 to IPv6 addresses which allows IPv6 system to talk to IPv4 system.  BUT if your application is hardcoded with an IPv4 literral address like instead of a DNS like, that equipement can't do it's job and your IPv6 iphone address won't be able to talk to that server causing your application to malfunction.

- Apple has requirements since 2017 to force application developers to be IPv6 ready and to not use address literals, but there might still be some in the field.


For Rogers staff : I noticed problems myself too since like end of May, that would be great if you could confirm that you switch your system to deliver IPv6 instead of IPv4.


Also to note Bell/Telus/Videotron are still using IPv4 which explains why your application would work in the same phone by just switching SIM Card.

Re: Certain Apps Connect over Wi-Fi but not Data.

I Plan to Stick Around

Thanks for the reply

it was about June 12th when the problem started. 

The affected apps are Sricam WiOn E-View7 E-View7a



Re: Certain Apps Connect over Wi-Fi but not Data.



I started having similar issues around your time also, this is why it is so important to have someone from Rogers confirming my presomption that they switched to IPv6 around this time.


We are definitly not the only one, and believe me I am working in tech and we had teams working to find a resolution for one app for more then a month before I sniffed packet and circumvene issue to Rogers LTE network