MyRogers Navigation Issues

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I Plan to Stick Around
Posts: 90

MyRogers Navigation Issues

You can sign in and it seems to load a page and then it goes blank and reloads goes blank...rinse and repeat.

At least on my end.  Using FFox 73.0.1.

 

 

***Added Labels***

Solved! Go to Solution.

Accepted Solutions
Highlighted
I Plan to Stick Around
Posts: 90

Re: MyRogers Navigation Issues

Seems as though my problem was being caused by Ad Block Plus.  Removed it and went with something else and everything is working as it should.

View solution in original post


All Replies
Highlighted
Resident Expert
Resident Expert
Posts: 3,619

Re: MyRogers Navigation Issues

Working fine for me. I just tried it on Chrome and FF. Here's the usual checklist:

 

https://communityforums.rogers.com/t5/Internet/Unable-to-load-certain-website-s-and-or-videos/m-p/42...

 

Try a different browser, Try incognito/Private Window, clear Rogers cookies, cache, etc.



Highlighted
I Plan to Stick Around
Posts: 90

Re: MyRogers Navigation Issues

Now getting a message "Some information on this page maybe missing.  Please try again later." which then disappears and the page attempts to reload.   It happens after you sign in to My Rogers and select either  "TV" "Internet" or "Phone" the three services I have with Rogers.  Was working fine yesterday.   So I guess I will wait for another day/time.

Highlighted
I Plan to Stick Around
Posts: 90

Re: MyRogers Navigation Issues

Seems as though my problem was being caused by Ad Block Plus.  Removed it and went with something else and everything is working as it should.

View solution in original post

Highlighted
Resident Expert
Resident Expert
Posts: 3,619

Re: MyRogers Navigation Issues

Thanks for the feedback. That was item 3 of the link I provided.