cancel
Showing results for 
Search instead for 
Did you mean: 

Need help with ongoing packet loss issue

Effayy
I plan to stick around

My Setup

Running a CODA-4582U in bridge mode, connected to an ASUS router providing both wired/wireless connectivity to home devices.  Both my home and work PCs are wired, as are my PS5 and XBox One.  The rest of the family (wife and 4 kids) each have their respective phones and other gadgets all wirelessly connected to the ASUS router.

 

I live in a townhome in a reasonably new neighbourhood (our street is only 11 years old). 

 

Symptoms

For the past few months we've experienced packet loss which causes interruptions in all our activities. Work VDI will disconnect, Zoom/Teams meetings will stall out or pause temporarily. Online gaming will lose connection to host servers, etc.   Rebooting the cablemodem will calm things down for anywhere between 12 hours and 3 days, Once the packet loss starts up again, it will continue regardless of time of day until the cablemodem is rebooted again. 

 

Investigation

At first I thought it was a hardware issue, so had my original CODA-4582 switched out for a refurb CODA-4582U.  This did not resolve the issue.

 

When the packet loss started acting up, before rebooting I ran continual ping tests for an hour from my wired PC against the following:

  • cablemodem (192.168.100.1):  Rock solid. 0 packet loss. 
    • This means it is not a problem with my internal network, correct?
  • CMTS (174.x.x.1):  22 timeouts in 1 hour. (averaged roughly once every couple of minutes)
    • This IP was the 2nd hop in my traceroute so I assume it's CMTS?
  • DNS (64.71.255.204):  25 timeouts in 1 hour.

I also tested restarting the ASUS router without rebooting the cablemodem, and the packet loss persisted through the reboot.

 

During a period of packet loss, I spoke with support over the phone who agreed that there was likely an issue somewhere between my house and the CMTS.  He remotely rebooted my modem, we both agreed that the issue would likely occur again anyway so he scheduled a tech to come out.

 

Tech came yesterday and checked the lines outside and told me everything was fine. He said that the remote reboot was different than what I would do on my end, and that it likely fixed the problem.  I reluctantly let him go but wasn't satisfied with his reasoning on this. Unfortunately when he was on-site the network was behaving itself so I didn't really have a leg to stand on at that point.  As expected however, 24 hours later the issue returned.

 

Based on scouring through threads in here over the past couple of weeks (thanks @Datalink you're a gold mine of information!), my theory is that it's either a cabling issue between my house and the CMTS, or the neighbourhood is using more bandwidth than the current infrastructure can hold.  I asked the phone rep if he was able to determine the neighbourhood bandwidth saturation from his end and he seemed to avoid answering the question.

 

Is there anything else at this point that I can try to help shed more light on the root problem?  I'm somewhat technical but admittedly not familiar with cable networking outside of what I've read on these forums.  

 

Below are my DOCSIS stats.  I believe they're within normal range.

 

Thanks in advance!

 

Downstream Overview
Port ID Frequency (MHz) Modulation Signal strength (dBmV) Channel ID Signal noise ratio (dB)
1 615000000 QAM256 -1.500 11 37.355
2 591000000 QAM256 -0.799 7 37.355
3 597000000 QAM256 -0.799 8 37.636
4 603000000 QAM256 -1.099 9 37.355
5 849000000 QAM256 -3.700 2 36.386
6 855000000 QAM256 -4.000 3 36.386
7 861000000 QAM256 -4.500 4 36.386
8 579000000 QAM256 -0.400 5 37.355
9 585000000 QAM256 -0.500 6 37.355
10 609000000 QAM256 -1.299 10 37.355
11 279000000 QAM256 6.599 1 38.983
12 621000000 QAM256 -1.500 12 37.355
13 633000000 QAM256 -2.099 13 36.609
14 639000000 QAM256 -2.400 14 36.386
15 645000000 QAM256 -2.599 15 36.609
16 651000000 QAM256 -2.500 16 36.609
17 657000000 QAM256 -2.500 17 36.609
18 663000000 QAM256 -2.599 18 36.609
19 669000000 QAM256 -2.599 19 36.609
20 675000000 QAM256 -2.900 20 36.609
21 681000000 QAM256 -2.799 21 36.609
22 687000000 QAM256 -2.900 22 36.386
23 693000000 QAM256 -2.900 23 36.609
24 699000000 QAM256 -2.799 24 36.609
25 705000000 QAM256 -2.799 25 36.609
26 711000000 QAM256 -3.099 26 36.609
27 717000000 QAM256 -3.000 27 36.609
28 723000000 QAM256 -3.599 28 36.386
29 825000000 QAM256 -3.500 29 36.609
30 831000000 QAM256 -3.599 30 36.609
31 837000000 QAM256 -3.500 31 36.609
32 843000000 QAM256 -3.599 32 36.609
OFDM Downstream Overview
Receiver FFT type Subcarr 0 Frequency(MHz) PLC locked NCP locked MDC1 locked PLC power(dBmv)
0 NA NA NO NO NO NA
1 4K 275600000 YES YES YES 5.599998
Upstream Overview
Port ID Frequency (MHz) Modulation Signal strength (dBmV) Channel ID Bandwidth
1 38700000 64QAM 34.270 4 6400000
2 21100000 64QAM 33.260 1 3200000
3 32300000 64QAM 34.270 3 6400000
4 25900000 64QAM 34.270 2 6400000
5 0 QAM_NONE - --- 1600000
6 0 QAM_NONE - --- 1600000
7 0 QAM_NONE - --- 1600000
8 0 QAM_NONE - --- 1600000
OFDM/OFDMA Overview
Channel Index State lin Digital Att Digital Att BW (sc's*fft) Report Power Report Power1_6 FFT Size
0 DISABLED 0.0000 0.0000 0.0000 0.0000 0.0000 2K
1 DISABLED 0.0000 0.0000 0.0000 0.0000 0.0000 2K

 

 

**Labels Added**

 

 

5 REPLIES 5

Re: Need help with ongoing packet loss issue

Datalink
Resident Expert
Resident Expert

@Effayy its a little late at the moment, so I'll keep this short.  You have an external cable and/or connector problem.  The fact that the tech rebooted the modem, and voila, it worked for a period of time basically proves it.  The reboot will return the cable back to a normal operative state for a period of time.  That period of time will depend on how badly the cable and its connectors have degraded.  My bet is that the modem reboot returns the cable back to a normal capacitive state for a period of time.  After that, the cable returns to its failed state.  Each cable type has a capacitive value based on its construction.  A break in the cable or water ingress would alter that value and short the internal copper conductor to the external cable ground, causing a disconnect.  For whatever reason, a reboot resolves the situation for a period of time, but it doesn't fix the problem.  

 

Call tech support and register yet another complaint.  Call every day if you have to.  That will build a history of poor service over a short period of time. 

 

Don't let tech support or the field tech reboot the modem and declare victory.  That just kicks the can down the road and makes the tech look good on paper ..... another customer complaint resolved (not really).

 

Tech support will insist on another contractor tech visit. That's the routine unfortunately.  After that visit, you can ask for a Senior Tech (real Rogers tech).  I'd say that this is going to take more than one or two visits to resolve.  

 

Assuming that you end up with yet another tech, ask if he can run a Time domain reflectometer test on the external cable.  That sends a pulse down the cable that bounces back at the end of the cable, or at the location of a break.  If the cable is tested from both ends, then the timed response should be the same.  If there's a break in the cable or water ingress at some point, then the measured cable lengths would be different.  That's an obvious sign that the cable must be replaced.  I'm assuming that the townhome has all of the external cable enclosures at one end of the building.  So, there would be a cable run from your townhome to that external NID.  Then, from the NID, there would be another run, either underground or overhead, running to the local tap.  If that run is underground, then the tech can test that run using a TDR.  I'd bet that he could also run a TDR test from the external NID to the internal end of the cable, just to check for the possibility of an internal cable fault. 

 

So, that's the starting point, or so I think.  A closer examination of the cabling, from the townhome to the external NID, and from the NID to the local tap. 

 

Fwiw, if this was a very large townhome complex, there's always the possibility of an internal Multiple Dwelling Unit (MDU) supplying data services to all of the units.  That's basically an internal local tap, designed for large buildings.  These are pretty reliable, but, if an when they go wrong, they're a pain to diagnose and fix.  I don't believe that contractor techs are allowed to do anything with an MDU other than connect and disconnect.  Anything other than that would require a Rogers tech.  

 

So, one question for the next tech is "how is the townhome connected?" Though an external NID and then out to a local tap, or thru an internal MDU?  The answer to that will also determine what needs to be done in the future.

 

Ask your neighbours if they're experiencing any disconnects.  If they are, that points the finger at the local tap or beyond, or at the MDU, if there is one located in the building complex. 

 

Here's what the TDRs look like:

 

https://megger.com/products/cable-fault-test-and-diagnostics/cable-fault-locating-equipment/time-dom...

 

 

Re: Need help with ongoing packet loss issue

hoboryan
I plan to stick around

Have you checked through the speedtest app (iphone/android)? How much % is your packet loss?

Re: Need help with ongoing packet loss issue

Effayy
I plan to stick around

Thanks for the awesome advice @Datalink

 

I started seeing packet loss again tonight, and made another call in to support.  I essentially said that I know this will keep happening, and the next time we schedule a tech call I would prefer it to be a senior tech as I feel the issue lies in a cabling malfunction somewhere between my house and the NID, or beyond.  She agreed that rebooting was just a band-aid and put a note on file.

 

She set up a monitoring ticket and when I start to see packet loss in the next couple of days (which based on history is inevitable), I'll be able to call back and (fingers crossed) get that senior tech to come out. 

 

My townhome isn't a large complex. just a row of 4 houses, and I'm the end-unit.  Likely the infrastructure is the home --> NID --> tap scenario you mentioned.  Hopefully that makes like a little easier for the tech to determine root cause.

 

I'll post back here as things progress.  Hoping for a happy ending.

 

 

Re: Need help with ongoing packet loss issue

Effayy
I plan to stick around

My speedtest app doesn't show % packet loss (or jitter either).  All tests I've done have been from my PC so that I can take any potential WiFi problem out of the equation.  I have PingPlotter installed as well, so perhaps I can get some numbers from that.

Re: Need help with ongoing packet loss issue

hoboryan
I plan to stick around

You can try the IOS app or the windows desktop app (if you drill into details it will show packet loss). I'm having similar problems to you and this is what they told me today (posting from another thread).

 

So called again today and they escalated to a supervisor. Who pinged my modem and confirmed 10% packet loss (not sure if he was just making it up). He also pinged my neighbours and confirmed they had no packet loss.

 

They're sending a guy to put in a temporary cable from the curb under the assumption that the cable leading to my house is degraded. Who knows if it'll work.

Topic Stats
  • 5 replies
  • 2627 views
  • 1 Like
  • 3 in conversation