Premium SMS - Unable to receive verification codes.

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jameso
I've Been Here Awhile
Posts: 3

Re: Premium SMS - Unable to receive verification codes.

Yes I have received a shortcode from US based services like GitHub and Google. Service Canada is another example of a service not working. I just switched to Rogers yesterday, when the issue first popped up, so I assumed the issue lies with Rogers instead of each of the other services.
Chenxh
I've Been Around
Posts: 1

Re: Premium SMS - Unable to receive verification codes.

I was asked to enter the verification code when I logged in the TD online account. I clicked "Send" but did not receive it. There is one in the solution that I see TD is to say to want to contact your phone operator, they may blocked the code,I also tried send ‘help’ to TD short code for helping [72585] but can’t send it. So I want to ask how to solve it.

RogersTony
Moderator
Moderator
Posts: 1,279

Re: Premium SMS - Unable to receive verification codes.

Hello, @Chenxh

 

Welcome to the Rogers Community Forums!

 

With multifactor authentication processes now the norm I can understand how important it is to receive these verification codes.

 

TD Canada Trust is on the approved list so you should not have any issues receiving the code.

 

  • Do you have any issues receiving a verification code for any other approved sources?
  • Are you receiving all other SMS normally?

Are there any other users in the community who are unable to receive verification codes from TD Canada?

 

We look forward to hearing from you.

 

RogersTony

 

 

jameso
I've Been Here Awhile
Posts: 3

Re: Premium SMS - Unable to receive verification codes.

I was in contact with support and things are now working for my wife and I.
It seems the cause for us was that things hadn't fully switched over from our old provider. Rogers fixed things behind the scenes. Hope this is of help to anyone else facing this issue!