Showing results for 
Search instead for 
Did you mean: 

Unable to Log Into Smart Home App

I've been here awhile

My smart home monitoring app suddenly is not letting me sign in. I log in and instead of taking me to the home page it says “Sorry there is a problem on our end. Thank you for your patience while we fix it.” It’s been like this for over a week. Any ETA on a fix?
Potentially helpful info: I have a iPhone 8 with iOS 13.3.1. I tried turning my phone off and on as well as deleting and reinstalling the app.




***Edited Labels***


Re: Unable to Log Into Smart Home App

Yesterday, android had issues. It seems that there was a problem with the Android Webview. This has been corrected.


I am unable to login the my SmartHome App. Nothing moves after clicking "Sign In". I am not prompted to enter my username or password.


I have updated the patch and rebooted. I have uninstalled the app twice and re-installed, nothing happened. 


I am using a Samsung, android phone and the app was working fine before this issue. Grateful for a resolution

Re: Unable to Log Into Smart Home App

Hello and welcome @rlakhan!


If you're having troubles with logging in after performing the troubleshooting steps you mentioned in your post, there may be an issue with your account or password.


Are you having any difficulties logging into your MyRogers account at the moment?


We'd be happy to take a closer look to see what is going on! Feel free to send us a private message to @CommunityHelps so we can assist you further. For more information on how our Private Messaging system works, you can find out more here.  




Re: Unable to Log Into Smart Home App

I've been here awhile
I am unable to sign in through Rogers smart home. I have updated version of app.
I uninstalled the app 2 to 3 tines, but cannot go beyond sign in page itself. When I click sign in, nothing happens.


Re: Unable to Log Into Smart Home App

Good day, @Heenapm2021!


A warm welcome to our community forums and thanks for posting your issue here! We understand that having access to your SHM app is pretty convenient and important! Thanks for sharing what troubleshooting steps you have tried, that is very helpful!


Just to further clarify, when you go to sign in, do you receive any specific error message or does it just sit there in a continuous loop with zero results? Is the issue happening on more than one device with the SHM app? Also, are you able to login to any other Rogers apps using the same credentials or does the same issue occur? 


Your responses to these questions will help us in figuring out what the issue might be. We look forward to your reply!


You may also want to have a peek at RogersMoin's post above to see if that might apply to your situation as well.


Thank you,




Re: Unable to Log Into Smart Home App

I've been here awhile

It is impossible to log in into the smart home monitoring app.  We have the latest app. This is a problem that has been recurring for years now. 


We have called your technical support  3 time yesterday and they suddenly in the middle of a conversation the first tech  hung up on us.  We thought it was a bad connection! Note our internet and wifi connectivity  was working extremely well. So we called your phone line once again The second tech dropped the call right at the start of the call. So we tried again to contact your tech support. The third tech talked us through  a couple of things and then suddenly said oops you must be on mute (when we were not on mute) and disconnected. This unique type of technical support service is no fun.  If you are truly recording  your customer calls you may want to check in the quality of your tech service.


Can you please fix your app so that we could have the advertised service Rogers claims to provide its customers. Thank you


Re: Unable to Log Into Smart Home App

Hello @Dv5,


Welcome to our community forums and thanks for posting your concerns here! 🙂


I'm so disappointed to hear that your recent experiences with us haven't been so good. We always want to strive for excellence on every customer interaction we have and will need to work much harder going forward. Hopefully, future interactions will be more positive. 


I understand that you've been having issues with logging into your SHM app which I agree must be very upsetting. 😞 You mentioned that this has been going on for years. By any chance, have you ever been able to get a ticket lodged for this? If so, what was the outcome?


Can you kindly share some more details about what happens when you attempt to login? Any specific error messages received?


Are you having trouble logging into any other Rogers apps?


Have you tried clearing the app cache or possibly reinstalling the app from scratch? Please be sure you have the latest version of the app and the latest OS downloaded to your device. If possible, please try a different device to see if the same issue occurs.


Thanks for troubleshooting with us and we look forward to hearing back from you with more details!





Re: Unable to Log Into Smart Home App

Having the same issue not being able to sign in to my Smart Home app. Everytime I login with my credentials, it loads and then suddenly stops and says “There has been an issue on your account. Please sign in again”

I have tried all the above and nothing seems to be working.

Re: Unable to Log Into Smart Home App

Hello, @Saleem258.


Welcome to our Community! I appreciate you joining this discussion and sharing your login experience.


Thank you for trying the suggested steps in this thread; it's disappointing that they didn't resolve your issue. Is this the first time you are signing into the app?


Based on your error message, it seems the app can't see your subscription. Do you see your Smart Home service when logging into your MyRogers?


We look forward to hearing from you.



Re: Unable to Log Into Smart Home App

I've been here awhile

I have had this same problem for the last two years. I called Rogers tech support a number of times and was unable to get the app to work properly. I had another unrelated problem with the alarm system and had the touch screen  replaced. Since then the app has been working perfectly. After a  conversation with the technician who replaced the touch screen, here is our conclusion.  There is nothing wrong with the app or phone. It is the touch screen. If you have the older touch screen which is black and uses the large sd card have it replaced with a slightly newer model which is white and has a mini sd card. The sd card has nothing to do with the problem, it is just a way to identify the touch screen. The technician told me that he has replaced many faulty black touch screens but very few white ones. It worked for me

Topic Stats