cancel
Showing results for 
Search instead for 
Did you mean: 

usb storage on CGN3

Deepashri
I've Been Here Awhile

I want to use my 1TB extrenal harddrive as a network storage.

When i connect the HDD to the USB on the CGN3ACSMR modem, it appears on the admin/usbstorage page.

I am able to connect to it and move data around.

 

When I restart the computer the drive cant be seen anymore.

I have to unplug the HDD and plug it back in again.

 

Everytime i switch on the computer I have to unplug and plug the HDD back to use it as a network storage.

 

I want to be able to see the HDD all the time without unplugging and plugging it back.

How do i do it.

 

 

***Edited Labels***

 

59 REPLIES 59

Re: usb storage on CGN3

RogersZia
Moderator
Moderator

Hi @Deepashri,

 

 

Welcome to the Community!

 

Typically the drive should still appear on the admin page after you've rebooted the computer. Is anyone else in the Community experiencing something similar?

 

@Datalink and @Gdkitty do you guys have more to add?

 

 

RogersZia

Re: usb storage on CGN3

BS
I'm a Senior Advisor

Have you mapped a network drive to the drive on the router.

 

In my case, I opened file://192.168.0.1/2467-007C/ which is the address received from my router admin page under admin, usb storage.

 

I can only explain mapping in Windows 10, but it is similiar in 7 and 8 too.

 

open a windows explorer and put the address as in above in the address line - it will open to the drive.

 

Go to network in explorer, open your network, you will first see your router with the 192... address (what ever yours is replace with that), then open the router address and you will find the drive showing.

 

Right click and choose map drive, it will open a dialogue box with a choice of drive name - mine defaults to Z and I am happy with that. The address to your drive should be filled in the box below.

 

Make sure you have the check box selected for reconnect at sign in checked.

 

In my case, I now have a drive name Z there, and when I go to my computer, it will be in the list of drives.

 

Other than that description, which works for me, that is all I can figure as to your issue.  The only way it can be lost is if you disconnect it at the computer level, or if your router is off,or the drive is removed.

 

If it can't find the drive, the mapped drive address will tell you that it can't be found.

 

Other than that, I am not sure what is happening for you.

 

Any ideas our other much more knowledgeable network gurus.

 

Bruce

Re: usb storage on CGN3

Deepashri
I've Been Here Awhile

Thanks for you reply Bruce.

I tried mapping the drive and it works as you have suggested.

 

But the problem still remains.

Once i reboot I cant see the drive.

 

I think this can be due to.

 

1. Something wrong with my HDD.

2. Some Idle time setting/some other settig on the Router.

 

After hours of research online.

3. IP address related, somthing about static IP/dynamic IP

4. Group Policy settings on my laptop.

 

But I still havent found a solution.

 

Thanks,

Deepa

Re: usb storage on CGN3

BS
I'm a Senior Advisor

@Deepashri  I am glad you were able to get the mapping done, but like you, I am totaly stumped.

 

I don't think there is a timeout issue - my drive has been running and active since pulled it and returned it when I described mapping for you.  I haven't actually used the drive - should really do a backup, my bad!

 

I would lean towards your thoughts of 1, 2 I don't think so, 3, don't thing that applies either as your connection address and information for the drive is coming from your standard, router internal IP address (usually 192.168.0.1), and from what I have seen, it doesn't change. 

 

Possibly a group policy, but that also doesn't make sense to me given the fact that you have to unplug the drivew and plug it back in.

 

Sounds like a drive issue, or a router issue that it is not keeping the address.

 

Can you try another drive, maybe this one goes to sleep?? Have you tried different computers, your smart phone, etc and see if you get the same results? Can't try another router, except to return it.

 

 

Let us know if you find anything out.  Anybody have any ideas.

 

 

Re: usb storage on CGN3

BS
I'm a Senior Advisor

I ran into a problem of my own while seeing if I could replicate what you were experiencing.

 

With two computers seeing my two connected USB devices, one drive and one USB thumb drive, I pulled the drive from the router after using the eject button on the admin page of the router.

 

When I put the drive back, the router saw it, but no way could I get either computer to see the drive.

 

Ultimately, I had to turn both computers off after disconnecting the failed drive letter (disconnecting alone would not solve it), I had to disable the USB drive feature in the router, rebooted it as just turning it on still did not solve the problem, then I rebooted the router with it disabled, drives out, then turned USB to enabled again, turned on the computers and low and behold, all working again.

 

Definitely finicky - message to me on this one - don't pull the drives, unless prepared to removed drive mappings turn my computers off, and disable the usb drive feature, reboot the router, then set it back up again and add the drives back.

 

Could be purely superstitious this solution, as ultimately it worked, but who knows.

 

Just realize that there are some very flacky things about this feature.  I think I may go back to my old reliable solution, an older computer with Linux on it and my attached drives mapped through the network.

 

You will see that in this thread there have been different issues with different posters related to format type and other things.

 

Good luck in whatever you try.

 

Bruce

Re: usb storage on CGN3

Deepashri
I've Been Here Awhile
Thanks for your feedback.
I will try out what you have suggested and post the results.

Re: usb storage on CGN3

josh_assad
I Plan to Stick Around

CGN3 Keeps rebooting when accessing USB storage

 

I've been using this modem/router for at least a year with no real problems.  I recently starting using the network shared storage capabilities via the USB ports on the router, and have found that if there is a lot of use on the storage device (say I'm transferring files to it from a PC), the router resets after about 5 minutes (all of my wifi connections drop, my internet connection drops, and all of the lights on the modem shut off for ~30s and then the model restarts).

 

Does anyone else have this issue?  I'm just wondering if it's worth me asking for a new modem/router.

 

Thanks!

 

 

Re: usb storage on CGN3

BS
I'm a Senior Advisor

I personally haven't run into that in my case. I have had a large usb thumb drive that is just used for read only (my daughter's wedding pictures), and a 350GB HD which I use for backups using backup software on 2 computers.

 

The backups run every week, but I don't do any storage of files, reading of files, just the backup sets, so there is a large continuous writing of compressed backup data and integrity check, so it gets worked hard for a short period of time.  I do continuous backups so it doesn't make many changes to the sets, but I also do full back up once per month.

 

So having said that, I don't push mine too hard.

 

So not sure what is going on.

 

It sounds a lot like overheating, so some thoughts.

 

As it is occurring when doing a lot of file transfer, but has been ok for around a year, it will be heating up during that time, but should be within reasonable ranges.

 

I would first look at ventilation - is the modem sitting straight up or on its side - needs to be straight up.

Is there any restrictions of air flow of objects around the device.

Feel the device and see if it seems hotter when doing file transferring and is their good air flow - the cooling is passive (no fan) which means air must flow without any restrictions.

 

Check the vents and look for dust build up - even if you don't see any, take a compressed air can and blow the dust out and clear the vents.

 

I don't know if you call support if they can do a diagnostic on temperature, but that would be my first consideration.

 

Have support run diagnostics and get them to recommend whether it should be returned.

 

Good luck with it, let us know.

 

Bruce

Re: usb storage on CGN3

josh_assad
I Plan to Stick Around

I thought perhaps heat as well.  

 

The modem is standing vertically.  I wouldn't say airflow is restricted, but the modem _is_ sitting between a printer and a shelf with about 2" of clearance on either side, 6" clearance behind, and completely clear above.  Probably not as open as it could be. 

 

I'm pushing mine a little harder I guess...  I have a 4-drive external usb storage case plugged into USB2, nothing in USB 1.    Interestingly, it seems to reboot less often when I use USB2, and more often with USB1, but that might be coincidental.  

 

The router is also the main DNS server for two other routers in my house (the wifi from the Rogers box doesn't cover my house very well, plus I wanted more hardwired connections for media servers and whatnot...).  I'm using all 4 ports on the router, and all 4 ports on the other two routers.  That said, there are usually only 1 or 2 hardwired devices actually in use at any one time.  

 

There are probably 6 or so wifi-enabled devices in the house as well.  Half on 5G and half on 2.4G.  The file transfers to the USB storage all occur via hardwire, but I'm also usually connected to wifi on my phone or tablet.

 

Re: usb storage on CGN3

@josh_assad what version of CGN3 modem do you have, as seen by the product sticker at the back of the modem?  It will be one of:  CGN3, CGN3ACR, CGN3AMR, CGN3ACSMR.

 

Its possible that you may have come across an undocumented firmware bug.



Re: usb storage on CGN3

josh_assad
I Plan to Stick Around

Hi @Datalink, the model says CGN3.  No other letters.

 

To confirm whether or not this might be heat related, I'm going to point a fan at it tonight and start transfering some large files to see if it reboots.

 

I chatted with a Rogers tech last night and he recommended exchanging it for a newer 'rocket' modem.  I'll likely do that but figured I'd run this test first...

 

 

Re: usb storage on CGN3

Do you have the unit standing straight up? Or on its side?

There have bee reports in the past on overheating with it on its side.

Re: usb storage on CGN3

josh_assad
I Plan to Stick Around

Hi @Gdkitty,

 

The modem is upright.  I posted details about that yesterday when @BS mentioned similar stories of overheating.

 

I have an update:  I pointed a fan at the modem and started another large file transfer.  It proceeded without any problems for over 15 minutes.  In all of my other tests the modem would reboot in less than 5 minutes.   I shut the fan off and 2 minutes later the modem rebooted.  It was somewhat unexpected as there wasn't really any heat coming out of it yet, but I suppose if the CPU or some other component got hot enough it would reboot regardless of the overall temperature.

 

I'm going to get a replacement.  I have this modem pretty much out in the open on my desk (I've moved things around so it has plenty of space all around it).  I also blew it out as best as I could.  Seems to overheat with 'normal usage'.

 

 

 

 

Re: usb storage on CGN3

BS
I'm a Senior Advisor

@josh_assad Glad you were able to troubleshoot that - definitely overheating.  Makes sense to get it swapped out. Unlike my laptop, you can't exactly pull it apart and do a solid dusting of the board, any heat sinks, all vents.

 

My daughter has a real neat feature on her Lenovo laptop.  You can set the fan to "cleaning option", which runs the fan at highest speed for 30 seconds and it is always amazing what gets blown out of there.  Because of the continuous high speed at low temperatures, it also uses convection to pull air through the whole unit pulling all the dust out.

 

Ah the ongoing enemy of everything electronic - dust.

 

Hope that solves the problem.

 

Bruce

Re: usb storage on CGN3

I do believe that there is a heat sink on the processor which is fairly large, hence the large case.  Perhaps the heat sink isn't properly seated on the processor, or perhaps the thermal transfer material between the heat sink and processor isn't doing its job.  Swapping the modem will hopefully resolve the issue.  If not, then this might be a modem model issue.



Re: usb storage on CGN3

BS
I'm a Senior Advisor

Thanks @Datalink  I have been inside my fair share of computers where I have seen exactly what you describe, but I have also seen bad CPU's and other chips that just failed over time, and then found out that they were reoccurring on many of the same devices.

 

All good thoughts for people to consider.

 

I hope that thw swap resolves it.

 

Bruce

Re: usb storage on CGN3

Just remember the adapter output for this modem is 12 volt and 2.0 amps. I've seen the wrong adapter cause rebooting many times. Even if the modem was installed by a Rogers installer. Rocket modem should have an adapter with 2.5 amps, but have been seeing the rocket and standard gigabyte released with 3 amp adapters.

Re: usb storage on CGN3

BS
I'm a Senior Advisor

Good thing to know - never thought about the power output of the adapter. There are so many modems and adapters out there at the moment, I could easily see them getting mixed up with returns and repackaging.

 

Bruce

Re: usb storage on CGN3

josh_assad
I Plan to Stick Around

@borford wrote:

Just remember the adapter output for this modem is 12 volt and 2.0 amps. I've seen the wrong adapter cause rebooting many times. Even if the modem was installed by a Rogers installer. Rocket modem should have an adapter with 2.5 amps, but have been seeing the rocket and standard gigabyte released with 3 amp adapters.



That's good to know...but if power was the problem wouldn't the modem have reset during my 'active cooling test'?

Re: usb storage on CGN3

BS
I'm a Senior Advisor

@josh_assad wrote:

@borford wrote:

Just remember the adapter output for this modem is 12 volt and 2.0 amps. I've seen the wrong adapter cause rebooting many times. Even if the modem was installed by a Rogers installer. Rocket modem should have an adapter with 2.5 amps, but have been seeing the rocket and standard gigabyte released with 3 amp adapters.



That's good to know...but if power was the problem wouldn't the modem have reset during my 'active cooling test'?


I would tend to agree that it is probably not power supply since the cooling test removed the problem, at least during the full test.  But a point for others possibly - it led me to go downstairs and make sure I had the right power supply just in case.

 

I know I once mixed up a power supply on a router a numer of years back - poof - that one I overloaded and killed it - had used a power supply for a managed switch that was right beside, and both power supplies were side by side - unfortunately, blew the power supply too, so I had to get a new router, and a new power supply for the switch.

 

Oopssy = lesson from when I worked in the field - label your connections, preferrably in different colours..

 

Learned that one the hard way.

 

Bruce

Topic Stats
  • 59 replies
  • 7376 views
  • 8 Likes
  • 13 in conversation