cancel
Showing results for 
Search instead for 
Did you mean: 

Rogers Modem will not see ethernet connected device requiring Port Forwarding

WDP1
I've Been Here Awhile

Hi gang,

I've got a new macbook Pro (setup as a server) hard wired with an ethernet cable to my Rogers Ignite Modem.

My mac, set to DHCP with wifi turned off, is given a LAN ip number and connects to the web no problem.

(With the ethernet cable removed, this same mac also connects just fine to the web when wifi is turned on. A different LAN ip number is established obviously.... but again, I can't use wifi for my server application)

When I require the macbook as an ethernet connected server, I must also add Port Forwarding and UDP in my router.

I log into the Rogers modem to administrate these necessary Port Forwarding/UDP settings. I select 'Add Port Forward', I select my macbook and enter the proper port number and UDP setting. The big green check mark comes up and says 'Finished'. However, when I look at the Port Forwarding page, it lists "No Associated Device" with an ip number that matches my macbook's wifi LAN ip number (?)

I need the router to port forward to this mac's ethernet LAN ip ....... not the wifi LAN ip.

Thanks,

 

*** Edited Labels ***

2 REPLIES 2

Re: Rogers Modem will not see ethernet connected device requiring Port Forwarding

-G-
Resident Expert
Resident Expert

@WDP1  I'm not sure what can be done about this.  When the Internet protocols were first designed 40+ years ago, the designers never thought about the possibility of having multiple network interfaces connected to the same logical network.   Although this is now typical with Laptop computers, it's not typical of servers, and port forwarding on IPv4/NAT firewalls never handled situations terribly well where a device could join a network using different interfaces that would result in them also taking on different IP addresses.

 

In the case of your Mac, when it is both Ethernet and Wi-Fi connected, it will prioritize the use of those interfaces and will (typically) only use one when initiating connections, unless the network application binds to a specific interface.

 

Port forwarding on the Ignite gateways is also problematic enough even under the most ideal circumstances.

 

I don't know of any solution to getting this working better unless you have your Mac connected by Ethernet, disable Wi-Fi, and get port forwarding set up on the Ignite gateway to the IP address corresponding to your Mac's Ethernet adapter.



Re: Rogers Modem will not see ethernet connected device requiring Port Forwarding

WDP1
I've Been Here Awhile

@-G- Thanks so much for your quick response.

Your very last paragraph is exactly what I've been attempting to do, but the router wouldn't recognize the active LAN ip of ethernet connected mac. (active ip according to the mac's System Preferences/Network)

 

Update:

I disabled my new mac's wifi then powered it off.

I logged into my Rogers router using my wife's mac.

From there, I discarded all instances of my 'new macbook' (Forget this device option)

Next, I powered up my new mac (no wifi) with the ethernet cable connected. (I want to re-introduce my new mac to my home network as an ethernet connected device)

Watching the router status (on my wife's mac) the new mac appeared after a minute as 'a connected device'

It took an attempt or two but I finally got Port Forwarding & UDP assigned properly. It was the correct ethernet LAN ip!

 

My next move is to assign a static ip to this mac server and then go through this new procedure I've just described.

 

Thanks again for your help.