cancel
Showing results for 
Search instead for 
Did you mean: 

Very slow 5G speeds in the GTA

hashimj
I've been around
I’m getting 2-5X slower speeds on 5G vs LTE in Vaughan. Wonder if other users are facing the same slower speeds? On an iPhone 13 Pro.
12 REPLIES 12

Re: Very slow 5G speeds in the GTA

RogersRahul
Moderator
Moderator

Greetings @hashimj,


Thank you for posting your concern in the Community and welcome to the Rogers Community Forums!

 

Dealing with slow speeds is the worst! I'd be looking for a solution as well.

 

When did the issue started? Is it indoors only or also happening outdoors? Is the device purchased directly from us or via a third-party source?

 

We look forward to hearing from you.

 

Cheers,

RogersRahul
 

Re: Very slow 5G speeds in the GTA

beerhoff
I've been here awhile
Same issue + 5G is no faster 100-150 Mb/s in Toronto (Peanut Plaza/North York, Sheppard/Younge, 401 highway till Kitchener), GTA (65 Allstate Prkw/Markham, Newmarket, Kamato Rd./Mississauga)
iPhone 14 pro max, directly from Rogers
Both, indoors and outdoors
Infinite Premium plan
Using since mid of Dec., 2022

Re: Very slow 5G speeds in the GTA

Good day @beerhoff,

 

Welcome to the Rogers Community and thank you for bringing this up to our attention!

 

We appreciate the details you provided in your post. You mentioned using your device since mid-December; Were 5G speeds previously fast enough or did you just change to Rogers as a service provider?

 

Additionally, if you upgraded your hardware, are you able to confirm whether you changed your SIM card to a new one as well?

 

Let us know if you've gone through any troubleshooting steps since noticing the issue!

 

RogersMaude

Re: Very slow 5G speeds in the GTA

beerhoff
I've been here awhile

Hi @RogersMaude,

I changed to Rogers as a service provider. I tested it in downtown yesterday. It was ~300Mb/s, but not in North York at the location I mentioned previously.

>>are you able to confirm whether you changed your SIM card to a new one as well<< All is new and came from Rogers.

>>Let us know if you've gone through any troubleshooting steps since noticing the issue!<< Negative. Please share details so I can share results.

 

BR,

Re: Very slow 5G speeds in the GTA

Hello, @beerhoff.

 

Thanks for the additional info, and welcome to Rogers. Since you were getting ~300 Mbps speed in downtown, we don't need to troubleshoot your device. 

 

How is the signal strength when you are testing in North York? The issue could be related to other factors like distance, Cell site frequency, obstructions, RF interferences, terrain/geography, etc. You can check the network status and report the slow speed. 

 

Cheers,

RogersMoin

Re: Very slow 5G speeds in the GTA

GGtinj
I've been here awhile
At least you’re getting upwards of 50mb/s I get ONE POINT THREE so 1.3mb/s that is slower than my fathers dial up Internet and I’ve been with rogers since 2018 and I haven’t gotten more than 10mb/a even on lte or 5G inside outside anywhere

Re: Very slow 5G speeds in the GTA

Jualukeclack
I've been here awhile
I am experiencing the same thing. I have 5g but this isn’t 5g. Google takes 2 minutes to load. It’s inside and outside, wherever. This is the first time I am experiencing such slow data speeds. Please can someone assist me to fix my data speed?

Re: Very slow 5G speeds in the GTA

Greetings @Jualukeclack

 

Yikes! Thanks for bringing this up to our much needed attention. 🙌 I know firsthand how important it is to ensure you're receiving consistent speeds when you're on the go. I just have a few additonal questions for you to get down to the bottom of this.

 

Does this tranpire only when you're attempting to load Google or other applications and websites as well? 

 

What kind of device are your using and was this device purchased through us or a third party?

 

When did the speed issues start occuring?

 

 

Looking forward to hearing from you,

 

RogersJo 
 

Re: Very slow 5G speeds in the GTA

Same thing for me but worse.  We are just outside London, Ontario and getting less than 1.3mb/s often sometimes as bad as 15 Kbps.  When we first opened the box and plugged it in after picking it up rom the Rogers store three weeks ago we were downloading at above 50 Mbps (which we were happy with because it was five times faster than the RocketHub we have had for 20 years which usually maxed at 14 mbps),  Pray for us.

Re: Very slow 5G speeds in the GTA

GGtinj
I've been here awhile
It’s gotten worse since I posted that… I can’t open web pages on data anymore, I can barely send messages either. I switched from my pixel 5 to an iPhone 14 pro max and so did my partner. I don’t know why it’s so bad

Re: Very slow 5G speeds in the GTA

Good afternoon @test2247878879 & @GGtinj ,

 

Thanks for sharing your experiences here. I'm sorry to hear about the issues you've been having with your 5G service. 😞

 

By any chance, have either of you had the opportunity to check out our troubleshooting guide found here? As mentioned in an earlier post by @RogersMoin , you may also check your network status there as well, and chat in to Technical Support to report an issue, if needed.

 

We really hope the situation improves!!

 

Kindest of regards,

RogersYasmine

 

 

Re: Very slow 5G speeds in the GTA

LordDrakkon
I'm a reliable contributor

Rogers could definitely improve network data performance across the board.  I have steadily seen data speeds decrease over the past few months after returning to Rogers.  

Topic Stats
  • 12 replies
  • 2679 views
  • 6 Likes
  • 11 in conversation