Speedtest Issues

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I Plan to Stick Around
Posts: 24

Speedtest Issues

Is something going on with speed tests?  I have been running speed tests from speedtest.net for a long time but recently they have stopped working for Rogers servers only. 

 

I can run the speed test on every server on the list, but when I try to run for a Rogers server I get a socket error.  This happens on Firefox, Chrome, and Explorer.  The same thing happens when I try to use Rogers' own speed test.

 

The error says that, "A socket error occurred during the download test.  A firewall could be blocking the connection of the server might be having some issues.  Please try again later."

 

As I said, I have performed hundreds of speed tests in the past and now this is happening - but ONLY for Rogers servers.

 

*Added Labels*

 

 

Solved! Go to Solution.
Resident Expert
Resident Expert
Posts: 6,439

Re: Speedtest Issues

@os3rules I just checked the Rogers speedtest site and the speedtest.net Toronto, Ottawa and Montreal Rogers servers and the speedtests ran as expected.  Didn't see any hint of a problem for all speedtest servers.  I ran the tests on Chrome. 



I Plan to Stick Around
Posts: 24

Re: Speedtest Issues

I just retested using Chrome and you are correct - it does work.

Checked Firefox (my primary browser) and found the the "Privacy Badger" add-on was causing the problem.  When I disable it Speedtest works. Weird.....

Resident Expert
Resident Expert
Posts: 14,124

Re: Speedtest Issues

Add blockers, and even specialty firewalls can effect something like the speedtest, or even some other sites from even allowing you to login all together.

Some of them will be 'blocking' when they try to access things outside of that page.
They assume that if its not loading assets from its own page, that it is likely pulling an add or something from elsewhere.
I have seen them effect logins for some pages, where they use a separate login service which re-directs back that you authenticated.. that it blocks that other site from you logging in as its not the same as the one your on.



I Plan to Stick Around
Posts: 24

Re: Speedtest Issues

It just makes you wonder what kind of information Rogers is gathering in the background.  All (ALL!) of the other sites work with Privacy Badger enabled.

 

 

Resident Expert
Resident Expert
Posts: 14,124

Re: Speedtest Issues

Its not necessarily a gathering thing.

Moreso, as I mentioned, an outgoing request.
That the speed test is making a request outbound to somewhere else.



I Plan to Stick Around
Posts: 24

Re: Speedtest Issues

Privacy Badger blocks trackers, not ads.  Is that what Rogers is doing (that the others are not)?

Resident Expert
Resident Expert
Posts: 14,124

Re: Speedtest Issues

Looking a little further..
"Privacy Badger was born out of our desire to be able to recommend a single extension that would automatically analyze and block any tracker or ad that violated the principle of user consent; which could function well without any settings, knowledge, or configuration by the user; which is produced by an organization that is unambiguously working for its users rather than for advertisers; and which uses algorithmic methods to decide what is and isn't tracking."

So not blocking based on connection.

BUT from that description, its based on anything which 'tracks' any information.
Yes, this is used primarily by Ads, where the specific add company when you go to say walmarts site, it writes to a cookie on your machine (or collects to their side) that you visited there, and then when you go somewhere else, reads that you went there and shows you walmarts on that site as well, etc.

Its quite possible, for recording and/or keeping past speed test results, location, etc, that its just trying to write a cookie to the machine to store that information.   And the program might be blocking it.


I completely understand the need and how/why people due use the blockers.  They are a good thing.
But sometime its the SITE thats the problem, even if they are not trying to do something bad 😞
I have seen sites, which will only load like 3 lines of the site then thats it, because of the blockers.
The code is so bad, and because its not loading in the part, it doesnt load the rest 😞



I Plan to Stick Around
Posts: 24

Re: Speedtest Issues

Honestly, I don't mind that Privacy badger (and other add-ons) pop-up and kick me when I go to a site that is doing something that it isn't supposed to - that is the purpose of the add-on and why I am using it.   If anything, this just proves that the program is working as intended.

 

What worries me is why Rogers finds it necessary to track what I am doing at this level - even something so simple as a speed test - when nobody else is doing it.  Makes me suspicious..... 

I Plan to Stick Around
Posts: 24

Re: Speedtest Issues

I have been using Ookla Speed test to measure my upload and download speeds for over a year now.  I have the 1Gig internet package but I have been unable to get more that 350M for a very long time.  I have had at lest 4 techs in to check the network and they have all has similar speeds when they do a speed test.

However, I have just tried running the speed test from command line (the CLI on the speedtest menu) as well as running the "Windows" version.  Both of these report that my download speed is well over 950 M.

How can this be?  The Rogers techs who were here reported that the local drop (2 houses away) is not capable of anything over 500 M and there is an open work order to repair it.

Can Ookla speed test be trusted? 

I know that when I run a speedtest my ethernet card shows similar activity to the speed reported by the test.

Perhaps those that have speed issues similar to mine could run the CLI version of the speedtest and confirm what I am seeing.