cancel
Showing results for 
Search instead for 
Did you mean: 

Slower download speed in bridge mode

LaraBeagle
I've been here awhile

Here is my setup.

Rogers (500U) —>  Hitron CODA-4582U  —> Cisco RV130W  —> Computer (Wired)

Cisco RV130W is a wireless-N VPN router with firewall.

Both the Hitron and Cisco are almost at factory defaults.  I’ve changed only the passwords and setup the wifi on both the Hitron and Cisco.  Wifi (both bands) are turned OFF on the Hitron.

If Hitron is NOT in bridge mode, I get 600Mbps upload, 20Mbps download.

If Hitron is in bridge mode, I get 80Mbps upload, 20Mbps download.

Nothing (settings or wiring) is changed on the Cisco.  I only log into the Hitron (192.168.100.1) and change from bridge to no bridge (gateway) and back to bridge.

Even if I reboot the Cisco or reset to factory defaults, I get a speed degradation in bridge mode.

Stumped.

Any ideas why this so.

(I’ve always been told that it is a bad idea to have two routers in a row.  I am not complaining about the speed at all.  The non-bridge mode works with no freezes, no crashes, no restarts, no lost connections etc.)

 

*Edited Labels*

39 REPLIES 39

Re: Slower download speed in bridge mode

Ok, well, that doesn't leave much left then.  Only suggestions are to nuke both modem and router to see what happens.  If that doesn't work, then I'd swap modems.  So, I would do this:

 

1. Run a factory reset on the modem.  After the reset, disable ports 1 and 2 and then kick the modem into Bridge mode.  Check the connected port LED to see if its flashing amber.  Check the LED in both Gateway mode and Bridge mode.  If that doesn't work:

 

2.  Run a factory reset on the 86U.  Before that I would:

     a.  select "Format JFFS partition at next boot" which is located in the Admin ..... System page.  Reboot the

          86U and set the modem up just enough to navigate to the Admin ..... Restore/Save/Upload Setting tab. 

 

     b.  On that tab, Select "Initialize all the settings, and clear ......"  then select "Restore" to run to return the 86U

          to Factory Default settings.  

 

3.  After the Factory reset on the 86U check the modem's connected port LED to see if its connecting at 1 Gb/s.  

 

4.  If that doesn't work, swap the modem at the nearest Rogers store.  You may have to call tech support to arrange for a work order to do that.  Seems that some stores need the work order and some don't.  Call the store first to see if they have any 4582's in stock and ask if they need a work order to do the swap.  If not, yay.  If yes, ok, call tech support to generate the paperwork. 

 

It makes no sense that two 86Us end up with the same problem.  You should be buying lottery tickets ..... 

 

I'm hoping that a factory reset on the modem first, then the 86U will solve the problem.  Maybe the firmware update to version 7.x was a enough of a change that the 86U isn't satisfied when connecting to the modem.  Version 7.x is a new kernel, so, possibly some changes occurred with the port controller firmware, don't know, just speculating.  

 

Edit;  One last thought, before swapping modems is to load Merlin's latest firmware version and run a factory reset after the firmware load to see if that changes anything.  Version 384.19 can be downloaded from site on the following page:

 

https://www.asuswrt-merlin.net/download

 

Direct download page is:

 

https://sourceforge.net/projects/asuswrt-merlin/files/RT-AC86U/

 

 

 

 

 

Re: Slower download speed in bridge mode

forcefed
I plan to stick around

I just wiped the rogers modem and it still connects at 100mbps even with the disabled 1-2 ports, i'll wipe the ac86u tomorrow, getting tired of this for now lol

 

Btw does the merlin firmware support the asus router android app?

Re: Slower download speed in bridge mode

Don't quote me on that one, but I would think that Merlin's version does.  Any questions about Merlin's version can be posted in the Merlin forum within the SmallNetBuilders site:

 

https://www.snbforums.com/forums/asuswrt-merlin.42/

 

My thinking about the modem and router factory resets is that possibly there's some value sitting in NVRAM in either the modem or router that is causing the current problem.  Hopefully, the factory reset will completely clear any offending NRVAM value after which the two devices will operate as expected.  There's no reason that I can think of that is causing the current problem.  

 

Food for thought, before running a factory reset for the 86U, consider cloning the MAC address of some device on your network.  That is located in WAN ..... Internet Connection.  

 

Fwiw, the values of interest for my 86U within that section are:

 

WAN MTU:                               1500

MAC Address:                         set to a MAC Address that works

DHCP query frequency:        Aggressive Mode

 

If you clone an address from your network, reboot the router after its set.  Check the network map after the reboot to ensure that the router has been assigned a WAN IP address.  

 

This has to be absolutely frustrating.  Beyond a modem swap, I'm stumped.  The fact that the modem connects to a LAN port at 1 Gb/s indicates that the modem will connect properly, so the question is, which of the two devices has some value set that is preventing the router, with its specific MAC address, from connecting properly.  

Re: Slower download speed in bridge mode

forcefed
I plan to stick around

The format jffs option wasn't in the asus firmware, had to load the merlin one to get it but it didn't help. Tried cloning a mac address but it wouldn't fetch an ip. The mtu setting was identical to yours, think i'll call up rogers and see if they can swap the modem.

 

https://i.imgur.com/nCffLVI.jpg

https://i.imgur.com/ENmLhXN.jpg

 

Went to swap the modem... same issue 🙄

Asus' suggestions are pretty comical...

 

 

Please try to perform the troubleshooting steps I have outlined below:

1. Verify if the router is on the latest firmware and try to restart and/or reset it.
2. May test with different LAN ports on the router
3. Test with different LAN cable
4. Test with different device if possible
5.  May test with different LAN port/cable, make sure only 1 client is connected to the router when conducting the "speedtest.net" test.
6. Verify if QoS or traffics limitation options were set?

Adaptive QoS or traditional QoS?

https://www.asus.com/support/FAQ/1008718/
or
https://www.asus.com/support/FAQ/1010950/

There's a free 3rd party LAN speed test utility for verifying the LAN speed.
http://www.totusoft.com/lanspeed1

3rd party troubleshooting guide:
Slow LAN speed on Windows 10 PCs [FIX]
https://windowsreport.com/fix-slow-lan-speed-pc/#:~:text=Slow%20file%20transfer%20over%20Gigabit,the%20issue%20should%20be%20resolved.

 

Maybe now's a good time to switch to the new ax routers from asus, rt-ax58u/rt-ax86u/rt-ax88u.

Not sure if the ax58u will give me the same range on 5ghz that my ac86u was giving me, the ax88u is a wee bit $$$ while the familiar ax86u seems just right... hopefully.

 

Re: Slower download speed in bridge mode

forcefed
I plan to stick around

Picked up the ax58u and problem solved. Compared to my ac86u its faster but only when using wifi6. In the same room as the router i'm getting 730mbps just like on my desktop 😮 in the next room its around 600mbps, the ac86u only peaked at 450mbps in both rooms.

Upstairs on wifi5 i got 200mbps, enabling wifi6 it jumped to 400mbps, the ac86u got around 300mbps. Furthest room in the house gets 300mbps, not bad for a $200 router.

 

Anyone need a 100mbps ac86u router? 😂

Re: Slower download speed in bridge mode

If you connect the 86U WAN port to one of the AX58U LAN ports, and then check the 86Us port speeds as you posted above, what do you get for the WAN port connect rate, still 100 Mb/s instead of 1000 Mb/s?  If its still showing 100 Mb/s port speed rate, are you beyond the time to return the 86U to the store or to get Asus to RMA the 86U?

 

You can use the 86U as an Access Point by disabling the firewall and DHCP server and connecting a LAN port from the AX58U to any one of the 86U's LAN ports.  That's how to manually configure a router as an access point if it doesn't have an Access Point mode.  Although the 86U has an Access Point mode, that would require you to use the slow WAN port, so, keeping the 86U in router mode and using a LAN port to connect with, would allow you to run the 86U as an Access Point, running at a 1 Gb/s connect rate. 

Re: Slower download speed in bridge mode

forcefed
I plan to stick around

You're a genius Datalink! It still connects at 100mbps https://i.imgur.com/q9nmXCN.jpg but connecting it to the lan port and using it as an ap is a great idea https://i.imgur.com/8SsOwIw.jpg 

But I don't need the ax58u anymore since i have an old ac56u i can use and it connects at 1gbps just fine,  I set the ac86u as an ap and enabled its wifi while disabling the wifi on the ac56u, the ax58u is going back to staples 😀

 

The asus guys are still pretty clueless to whats going on, i sent them log and config files and they still suggest to turn off aiprotection and qos, yet that doesn't dictate at what speed the wan port connects at, warranty is long gone.

Re: Slower download speed in bridge mode

The only problem with the ac56u is that the last Merlin update for that router RT-AC56U_384.6_0.zip dated 2018-07-25.  That's over two years old. 

 

https://sourceforge.net/projects/asuswrt-merlin/files/RT-AC56U/

 

 

Asus's last update was Version 3.0.0.4.382.51641 dated 2019/11/05:

 

https://www.asus.com/us/Networking/RTAC56U/HelpDesk_Download/

 

Although the 86U can be used as an access point, you need an up to date router at the front end.  At the very least, I'd update to the last Asus version, but, that's still 10 months old.  Asus is working on Version 386.x but the 56U isn't on the support list, at least not to date.  Its possible that Asus has put the 56U out to pasture:

 

https://www.snbforums.com/threads/asuswrt-386-rc2-public-beta-with-full-functions-aimesh-2-0.65235/

 

Hate to say it, and I'm loath to recommend spending money, to anyone, but I suspect that you're going to have to keep the AX58U, or if you return it, consider buying another router.  Ten months and counting for a firmware update is a long time, in terms of the security updates that keep rolling out. 

 

Its possible that we'll see the AX86U one of these days.  Its out, but I don't believe that its been released in Canada yet.  

 

I'm wondering if there's an issue with the WAN port to motherboard connection?  If you're adventurous, maybe its worth taking the back off of the 86U to see if there's any apparent problem between the WAN connector port and the motherboard.  

 

Did the 86U WAN port ever work properly?

 

 

Re: Slower download speed in bridge mode

forcefed
I plan to stick around

I'll stick to the asus firmware, the asus app doesn't work with merlin.

The ax86u is available at bestbuy https://www.bestbuy.ca/en-ca/product/asus-wireless-ax5700-dual-band-wi-fi-6-gaming-router-rt-ax86u/1... maybe when it drops to $250 i'll pick it up.

The wan port was working fine for 2 years, around 2 months ago i started having this problem. When i'll get bored maybe i'll take it apart, but since it kind of works now i doubt i'll touch it.

Re: Slower download speed in bridge mode

Ok, if it worked previously and only failed recently, I'd suspect a port controller failure, which would be a chip issue.  I was thinking that maybe, there's a disconnect between the WAN port and the motherboard, but, from what you're indicating, that's probably not the issue. 

 

I wasn't aware that the AX86U was available.  Yup, if it dropped down to $250 on sale, that would definitely be worth considering.  That has a 1.8 Ghz quad core processor, probably one of the few all in one routers that have a quad core processor

Re: Slower download speed in bridge mode

@forcefed here's more food for thought for your 86U which is to use on of the LAN ports as a WAN port, which the firmware should allow.  Its allowed in Merlin and I believe that its in the original Asus firmware.

 

In the 86U, reenable the firewall and DHCP server.

 

Under WAN .... Dual WAN:  Enable Dual WAN

 

Set the Primary WAN as an Ethernet LAN .... LAN Port 1


Set the Secondary WAN as the WAN port

 

Set the Dual WAN Mode to Fail Over

 

With the modem in Bridge mode, connect the modem's LAN port to the the 86U's LAN port 1. Leave the WAN port empty. That way, with Fail Over set as the Dual WAN mode, the 86U will never flip over to using the WAN port.  Hopefully, with nothing connected to the WAN port, the firmware won't complain about that fact.  Only one way to find out.

 

Give that a go and see what happens. I think it should work unless the WAN port problem prevents you from using Dual WAN mode properly. This should leave the other three LAN ports for local use.

 

 

Re: Slower download speed in bridge mode

forcefed
I plan to stick around

Did i already mention that you're a genius? 😀

That's even better than the previous solution, dual wan works perfectly, always wondered if i'll ever use it https://i.imgur.com/qbYEwEM.jpg https://i.imgur.com/gLwvkg5.jpg

Now i can get updates to the ac86u, the ac56u i set as an ap since i needed 4 lan ports, all good now 👍

Re: Slower download speed in bridge mode

lol, I'm not sure that I can list "occasional" genius on the resume.  Nice to see that its working so far.  One check that I would do is to go to grc.com specifically Services .... Shields UP to run the port check on "All Service Ports".  The result should show all ports stealthed, but, I'm wondering if running LAN port 1 as the WAN port would make any difference. It shouldn't, but, as they say, assume nothing .... look for proof.

Re: Slower download speed in bridge mode

forcefed
I plan to stick around

How'd i do? 

 

 

Results from scan of ports: 0-1055

    2 Ports Open
 1052 Ports Closed
    2 Ports Stealth
---------------------
 1056 Ports Tested

Ports found to be OPEN were: 85, 554

Ports found to be STEALTH were: 135, 445

Other than what is listed above, all ports are CLOSED.

TruStealth: FAILED - NOT all tested ports were STEALTH,
                   - NO unsolicited packets were received,
                   - A PING REPLY (ICMP Echo) WAS RECEIVED.

 

 

Btw one thing i noticed with the ac86u is once i enable ai protection/qos/apps analysis/web history and traffic statistics my wired speedtest drops to around 400mbps, with everything disabled it peaks at 730mbps. However wireless speeds are fine at 6-700mbps  🤷‍♂️

Re: Slower download speed in bridge mode

@forcefed all of those ports should be stealthed, as in no response to any external probes.  To a degree, that might depend on what you are running, but, I'd still be looking for no responses from those ports.  

 

If you have the time, patience, and opportunity to experiment, try the following:

 

1.  Rerun the grc.com .... Services .... Shields UP! test a couple of times to ensure that you see consistent results.

 

2.  In the router settings:  WAN .... Internet Connections ..... Enable UPNP:  ensure this is set to No unless you happen to be a gamer and rely on this instead of setting port forwarding manually.  I've never allowed UPNP to run or used port forwarding, and haven't seen any complaints from the family gamer. UPNP will set ports as requested by applications without your knowledge, which I won't allow.

 

3.  In the router settings:  WAN .... Virtual Server / Port Forwarding:  If there are existing port forwarding rules, and .... you didn't set them, or don't need them, delete any existing port forwarding rules.  Then set the Basic Config .... Enable Port Forwarding to OFF

 

4.  In the router settings:  Firewall .... General set the following:

            Enable Firewall:                                 Yes
            Enable DoS protection:                   Yes
            Logged packets type:                      Dropped
            Respond ICMP Echo (ping) Request from WAN:      No


  5.   Go through all of the settings under the General section on the left hand side and through all of their sub-pages.  Disable anything and everything that you know you're not using or never intend to use.  

 

6.  When that is all complete, reboot the router and pc and rerun the grc.com port scan two or three times looking for consistent results.  

 

7.  At this point I would expect to see that all ports are closed and that you shouldn't see any response from an external ping.  You might still see ports 135 and 445 are not stealthed (no response).  Consider shutting down your wifi for test purposes and disconnect everything except the pc that you're using to run the test.  Reboot the router and rerun the test again.  

 

8.  At this point, I'd expect to see all ports stealthed.  If you do see some strange results, consider disabling Dual Wan so that the WAN Port is once again the primary WAN port.  Reboot the router and rerun the grc.com test, just to see if there are any differences in the results from the two ports.  I think in theory the results should be the same, but, I've never used Dual Wan and haven't had the chance to check for any differences in port test results.  I'll have to try this with my 68U just to satisfy my curiosity.  When you're done testing, reenable Dual Wan and set Port 1 as the primary port.  Reboot the router. 

 

Fwiw, I know that AiProtection will affect IPV6 test speeds.  I suspect that AiProtect runs packet scans on the incoming traffic, and as a result, routing traffic thru the CPU for packet scan purposes results in lower throughout data rates.  AiProtect shouldn't slow the IPV4 tests.  I suspect that AiProtect uses site reputation to clear traffic from IPV4 sites.  Are you using IPV6 by any chance?

 

There is also the general issue of the Asus use of Hardware Acceleration to bypass the CPU wherever and whenever possible, resulting in higher throughput data rates.  The only problem with this is that various functions, like AiProtect(?), parental control, filtering, etc, can disable one or both parts of the Hardware Acceleration.  The components that comprise Hardware Acceleration are titled Runner and Flow Cache.  I think in the stock Asus Firmware that these are shown in the LAN .... Switch Control, but don't quote me on that one.  It been a while since I've used the stock firmware.  With any of the mentioned functions, I believe that Flow Cache will be disabled.  If you can have a look around the settings, you should come across this.  You can't set these.  They are set when the router boots up and their state will depend on what functions are active, or later on, when you enable a function that isn't compatible with Runner or Flow Cache, they will be disabled without warning the user (not good !!).  You will notice that Runner of Flow Cache is disabled when you run a speed test.  So, the starting point is to disable just about everything except the Firewall and DOS protection and run a speed test to see what results you end up with.  When you enable a function that you want to use, enable it, and then run a speed test to see what effect it has on the throughput.  You can also check on the Runner And Flow Cache status to see if there is a change in their status.  If you disable a router function that you know causes Runner and/or Flow Cache to be disabled, reboot the router.  The final status of those two after the reboot will depend on the number and type of router functions that are still enabled.   

 

Fwiw, with only IPV4 running, and no AiProtect, I'll see 940+ Mb/s down 32.8 Mb/s up.  That's using the www.speedtest.net Ottawa or Montreal Rogers servers.  I'll see pretty well the sane results using the Toronto Rogers server, but with higher latency due to the distance.  I'll located in Ottawa, hence the use of the Ottawa and Montreal Roger servers.  I don't use Aiprotect, instead, I use Merlin's firmware with two add-ons running, Skynet and Diversion.  Skynet is used to disallow access to malware sites and to block entire countries known for malware and hacking, and Diversion is used to block Adds.  There is an additional add-on available which is Suricata, but its not a full up version.  That is used for PfSense, OpnSense, type of routers as well which run the full Suricata version.  I'm thinking about it, but, the real answer is to run a router using PfSense, OpnSense or others.  That's the next leap .....

 

Ok, that should do it for now.  

 

Edit:  The gears are still churning.  There was or still is an issue with the Asus App.  I'm not sure of the current status, so, you might have to do some digging.  It seems that when you load and set the app, there was a setting to enable a remote connection.  Even with this setting disabled by user choice, the Router's WAN interface was still available which is a security risk, which might explain some of the open ports that you're seeing.  Here's a reference point to start from:

 

https://www.snbforums.com/threads/asus-router-app-and-unintentional-activation-of-remote-access-to-r...

 

This appears to be dated from Nov 2019:

 

https://thenextweb.com/security/2019/11/05/asus-alexa-data-leak-network-wi-fi/

 

There's more to this but I don't have time at the moment to look around to see what the specifics are and where this issue sits today. 

Re: Slower download speed in bridge mode

forcefed
I plan to stick around

Figured out what was opening those ports, to view my security cameras i need to enable dmz to my dvr, otherwise i can't view them outside of the house. With dmz disabled it passed.

 

Results from scan of ports: 0-1055

    0 Ports Open
    0 Ports Closed
 1056 Ports Stealth
---------------------
 1056 Ports Tested

ALL PORTS tested were found to be: STEALTH.

TruStealth: PASSED - ALL tested ports were STEALTH,
                   - NO unsolicited packets were received,
                   - NO Ping reply (ICMP Echo) was received.

 

Still stuck on ipv4, with aiprotect off it goes up to 500 and disabling qos it goes up to 700, i'll disable qos for now but need aiprotect.

Re: Slower download speed in bridge mode

Peach-R
I've been here awhile

Hi guys

I have the CODA-4582u modem and 500mbps/20mbps internet.

 

If the modem is in gateway mode, I can get about 530mbps down and 20mbps up.

 

However, if I put the modem into bridge mode, the speed will only remain 500/20 for about 5 to 10 minutes, then drops to 10mbps down and 15mbps up, whether through the router or not.

 

No idea why this is happening. Does anyone know what’s the problem?

Re: Slower download speed in bridge mode

c_config
I've been around

I've had similar configuration with Netgear router (R6400) and Hitron Coda-4582U (configured with “Residential Gateway Function” – enabled) .
The issue was in the Internet speed’ drop when connecting via the router. When I plugged my desktop PC directly to Hitron, it showed the speed above 500Mbps (as expected) and when I plug this PC in to the router, the achieved speed was only about 360Mbps. 
The problem was in "Downstream QoS" setting enabled in Netgear router. As soon as I disabled it, the speed at PC plugged to the router started showing 500Mbps or so.

Re: Slower download speed in bridge mode

EhmTeeEhf
I'm a reliable contributor

Just a question, Do you have at least Cat 6E Ethernet Cabling? I mean you could possibly get it using Cat 5 but there are some bottleneck issues. I was having similar issues, then upgraded to Cat 6e and then zoom super fast

Topic Stats
  • 39 replies
  • 50274 views
  • 12 Likes
  • 9 in conversation