cancel
Showing results for 
Search instead for 
Did you mean: 

Hitron CODA-4582 Port Forwarding Issue (Added ports don't save)

Gilae
I'm Here A Lot

I've been trying to set up port forwarding on the above modem and every time I add a Port Forwarding rule, it shows up on the table but pressing save changes and reloading the page shows that rule has not been added.

Hardware: Hitron CODA-4582
Firmware: 2.0.10.28T2

I'm using it as both router and modem.

I notice ports forwarding rules are added automatically for programs like Skype but I can not manually add a rule.
I tried turning off UPnP and adding rules, still didn't work. Interestingly, saving changes on any pages other than the port forwarding page works. Even enabling/disabling "All Port Forwarding Rules" saves. However, adding a rule doesn't save.

The following are the steps and what occurs:

- Open Port Forwarding page

- Press Add Rule

- Fill out all fields as needed

- Press Apply

- Press Save Changes
- Receive "[Success] Your changes have been saved" message

- Reload page/Change Tabs/Reboot Router
- Revisit port forwarding page/check canyouseeme.org
- The rule is not there and the port is still closed


The same issue occurs when removing or modifying rules. Some help would be appreciated, as this is really getting on my nerves. Thanks in advance!

 

 

 

***Edited Labels***

30 REPLIES 30

Re: Hitron CODA-4582 Port Forwarding Issue (Added ports don't save)

porchemasi
I've Been Here Awhile

I have given each page well over 10s to load. I am wired via ethernet to a 24port switch. I have no ability to plug my desktop into the router. I can add IPs into my DMZ, configure Wifi pass, enable/disable UPNP, add dhcp reservations.... as soon as I add a port fwd rule, boom session has timed out please login againa nd kicks me to login page.

Last resort is to factory restore.... ive DMZd my PC as a workaround to port fwd not working

Re: Hitron CODA-4582 Port Forwarding Issue (Added ports don't save)

Hello @shadowvillain,

 

Thank you for your post and welcome to the Rogers Community Forums! 😃

 

I know how important it is to have your Home Wireless Network setup the way you like and have it be secured properly too! You've definitely reached the right place to receive support, we've got some awesome Resident Experts like @Datalink@Gdkitty & @gp-se who may be able to provide a solution to this problem for you.

 

Anyone else in the Community Forum who has experience with Port Forwarding is welcome to chime in as well!

 

Cheers,

 

RogersTony

Re: Hitron CODA-4582 Port Forwarding Issue (Added ports don't save)

Thanks for summoning fellow experts. Not sure if it matters, but I'm on 33T3.

 

I just swapped my previous DSL modem (still has service) in bridge mode to my router, and ports are working fine, either via UPnP or manual port forwarding. Seems to me that it's something to do with this Hitron modem, not allowing ports to open even in bridge mode, and there's not any setting I can configure.

Re: Hitron CODA-4582 Port Forwarding Issue (Added ports don't save)

defective modem perhaps? should i exchange for a new one?

Re: Hitron CODA-4582 Port Forwarding Issue (Added ports don't save)

I Am having the same problem, I have tried everything mentioned in this thread. Anybody have any luck solving this?

Re: Hitron CODA-4582 Port Forwarding Issue (Added ports don't save)

After much trial and error, I found the following process to work:

Model: CODA-4582,

Hardware: 1A

Software: 2.0.10.28T2

Mode: Gateway.

 

1. Factory Reset

2. Disable uPnP (Super critical)

3. Reboot

4. Setup the port forwarding - (This is critical) Do NOT use punctuation in the Application Name field

5. For my purposes, I have ports 80, 443, 22 and 25532 setup for forwarding.

I don't do gaming, and if you do and games need ports opened dynamically, as far as I can tell, you are SOL. As soon as I enabled uPnP, and an applicated added a port, then all port forwardings that I had added were disabled.  However, the dynamically added ports by uTorrent, worked.

 

When I have time, I'll set it up in Bridge mode and see how that works, and will post it here.

 

Good luck

 

Re: Hitron CODA-4582 Port Forwarding Issue (Added ports don't save)

Problems with setup of personal website via Dyn Stanadrd DNS: Having trouble with port forwarding.

 

Thanks for anyone who can help.

I am running the DynUpdate client on my end to resolve the DNS entries my computer will be running. From Dyn's side everything is OK - they said I have to handle this through port forwarding.

Naturally the website using port 80, but for port forwarding I also have to say the internal ports (?). Does anyone know how this is done - or do I need to bridge the router?

I did this before with the old router by bridging the modem and then handling static IP's for each device but when I tried this with the Hitron CODA the network essentially become unstable for all the other devices (XBox, Samsung, etc)... 

Can anyone help?

Re: Hitron CODA-4582 Port Forwarding Issue (Added ports don't save)

Port forwarding, is for when something is trying to connect to YOU, on one of your machines, etc inside your home network.

Is that running a web server that their service is trying to connect to you to?

So you would be putting in 80 as the external port.. and then whatever port the service is running on the local machine (not always the same) and that machines address.

Re: Hitron CODA-4582 Port Forwarding Issue (Added ports don't save)

techuser123
I Plan to Stick Around

Hi,

 

I have a CODA-4582 Hitron Gigabit modem setup in bridge mode.  My son wants me to port forward 25565 which I have done in my router (Netgear Orbi) but the port is not being forwarded.  Is Rogers for some reason blocking the ports?

 

I tried a number of other ports and none of them appear to work either.

 

Thanks.

Re: Hitron CODA-4582 Port Forwarding Issue (Added ports don't save)

Just to be sure, the modem is fully in bridge mode?
You went into the section, and choose disable gateway, rebooted the modem, and then connected your netgear?

Just making sure, as there have been some that have thought they have, when they are really just running a double router setup.. where in that case it wouldnt work with the forwarding on the 2nd router.

While I dont have the CODA anymore.. I only ever ran into a few ports specifically in which I think I knew were blocked (22 and 443 I think).  I was able to forward most all other ports ok.


Topic Stats