Touchscreen Repeatedly Hangs and Triggers Alarm

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I've Been Here Awhile
Posts: 4

Touchscreen Repeatedly Hangs and Triggers Alarm

Over time the interface on the touch screen becomes more and more sluggish and I'm unable to disable the alarm.

 

Often I come home and try to disable the alarm, but the touch screen only registers a touch with 10-15 seconds delay, sometimes the display just freezes (preventing any touch input) and sometimes the whole thing goes black and then reboots.

Needless to say the alarm countdown is still happening in the background, so the alarm blasts off when it reaches zero. This has happened  more times than I like to count.

I even deleted all those apps on it that I never use, so only the bare minimum is left. No change in behaviour.

 

I talked to Rogers support who adviced "You should probably reboot it at least every month".

SERIOUSLY!?

 

I could understand memory leaks etc. if this was a device where users could install all sorts of apps, but the software image on this device is static!

 

Does anybody else have this problem?

I'm so fed up with this so we are looking for another security provider.

 

*** Edited Labels ***

 

Highlighted
Moderator
Moderator
Posts: 921

Re: Touchscreen Repeatedly Hangs and Triggers Alarm

Hello, @BigMikeCanada

 

Welcome to the Rogers Community Forums!

 

Dealing with a sluggish touchpad for your security system is a major inconvenience especially if your alarm is getting triggered as a result. 😞

 

This definitely should not be happening. We'd like to run some additional tests on your equipment to see if we can detect an issue. A service call may be required to investigate this further. Please send a Private message to @CommunityHelps so we can pull up your info and get started on this for you.

 

Not familiar with our Private messaging system? No worries, Click Here.

 

RogersTony

Highlighted
I've Been Here Awhile
Posts: 4

Re: Touchscreen Repeatedly Hangs and Triggers Alarm

PM sent.
Highlighted
Resident Expert
Resident Expert
Posts: 14,210

Re: Touchscreen Repeatedly Hangs and Triggers Alarm

I dont have to reboot mine monthly... but I do reboot it ever couple of months.
Ends up getting into that really slow response time as well.

I am running the cameras etc as well.. so not sure if something like that can effect whats triggering the slow.
(vs say a very basic  modem install)

 



Highlighted
I've Been Here Awhile
Posts: 4

Re: Touchscreen Repeatedly Hangs and Triggers Alarm

Memory leaks (or other resource starvation) should not happen at all on a software image that Rogers (or its 3rd party developer) has 100% control over.

It's simply inadequate testing of valid configurations.

Highlighted
I've Been Here Awhile
Posts: 4

Re: Touchscreen Repeatedly Hangs and Triggers Alarm

Wanted to give an update on this:

 

The technician came in February. He was nice and knowledgeable, but of course limited by the equipment he was installing.

 

First he tried a newer type of touch screen, but it kept rebooting spontaneously. Next one was the old type like the one we had - that one refused to pair with any of the sensors. The last one (also old type) managed to pair with the sensors, but the whole exercise took 2 days.

 

His advice was - instead of rebooting the touch screen via the menu every 3 weeks - to do a full power cycle which included disconnecting the battery (yes, that requires screws to be removed every time). That should keep the required reboot to be annually(!).

 

2 months went by and no apparent sluggishness... then one day I wanted to adjust the temperature. I clicked the "Thermostats" touch button and the screen went black except for a top bar saying "Thermostats"... 30 secs. later it shows a "Loading. Please wait..." message... 30 secs. later the LIGHTS screen appears!!!
Nobody touched the device while this was going on.


Clicking the physical Home button made the screen go totally black followed by a "Rebooting..." message.

When it came back to life it now constantly shows an alert (I can acknowledge the alert but it keeps coming back). The alert is "SD Card removed while recording" - the device never had ANY SD card installed!!!

 

I can't believe how bad this software is. Please give me the name of who developed it, and I'll make sure my company never buys anything from them.

Please don't send a new technician or anything. We're done with this system!