cancel
Showing results for 
Search instead for 
Did you mean: 

Has There Been A Recent Ignite release that requires IOS 14 or greater

Gazsnets
I've been here awhile

We have an old iPad that we use solely for Ignite TV in our kitchen. Today we are greeted with a screen saying IOS 14 is required. Our poor ol' iPad is 12.5.

 

Was there a new release to Ignite that requires this and if so, when did it come out

 

**Labels Added**

 

 

12 REPLIES 12

Re: Has There Been A Recent Ignite release that requires IOS 14 or greater

Schmenge
I'm here a lot

Same question here.

Re: Has There Been A Recent Ignite release that requires IOS 14 or greater

RogersCorey
Moderator
Moderator

Hello!

 

To answer your question @Gazsnets and @Schmenge, the iOS14 requirement came alongside version 7.6.1 approximately 6 months ago.

 

Regards,

RogersCorey

Re: Has There Been A Recent Ignite release that requires IOS 14 or greater

Appreciate the response on this one Corey.

 

There has to be another parameter in how this is implemented then.  I watch BBC World news on the iPad every morning, and have done so minimum of 6 days a week over the last year. 

Could it be that the App update was only recently forced down to my iPad (I didn't manually do any updates)?

Q:  Is there any way to revert to/use the version prior to the current one ?

Thanks,

Re: Has There Been A Recent Ignite release that requires IOS 14 or greater

Gazsnets
I've been here awhile

Thanks @RogersCorey ,,, I am a little puzzled as to why my app stopped working last week. Might you have any speculation as to the delay?

Thanks

Re: Has There Been A Recent Ignite release that requires IOS 14 or greater

Schmenge
I'm here a lot

IgniteVer.jpg

 

Seems IOS version 14 is mentioned as being required 6 months ago on release of version 7.6.1...  but it appears that its only within the release of version 7.13.0 (less than a week ago) - where it is now enforced.

 

 

Re: Has There Been A Recent Ignite release that requires IOS 14 or greater

Schmenge
I'm here a lot

Q:   Is there a way for us to revert to a previous Ignite version (7.6.1) so we can still use on our iPads ?

(other streaming services still supported, seems crazy that Ignite TV is coded to essentially obsolete these devices when others don't have to)

Re: Has There Been A Recent Ignite release that requires IOS 14 or greater

There is no officially supported way to revert to a previous version of an app on iOS devices. You can only ever find the most up to date version available on the AppStore.

 

Regards,

RogersCorey

Re: Has There Been A Recent Ignite release that requires IOS 14 or greater

-G-
Resident Expert
Resident Expert

@Schmenge wrote:

Q:   Is there a way for us to revert to a previous Ignite version (7.6.1) so we can still use on our iPads ?

(other streaming services still supported, seems crazy that Ignite TV is coded to essentially obsolete these devices when others don't have to)


You can also try opening https://ignitetv.rogers.com/ with Safari.

 

(other streaming services still supported, seems crazy that Ignite TV is coded to essentially obsolete these devices when others don't have to)


Actually, Prime Video now requires iOS 15 or later, Disney+ requires iOS 15.3 or later, and Netflix requires iOS 16.0 or later.

 

Apple encourages developers to support their latest products.  To be eligible for submission to the App Store, Apple currently requires developers to build their apps with SDK 14.1 or later.  This, in turn, may require developers to make changes to their code; changes that break compatibility with older operating systems.

 

Also, only iOS and iPadOS versions 15 and later are currently getting security updates from Apple.  You are at high risk if you are actively using older devices that cannot be kept up to date.

Re: Has There Been A Recent Ignite release that requires IOS 14 or greater

Schmenge
I'm here a lot

Appreciate the response  -G-.

Tried to open the url above in Safari...  directed to a (Rogers) page advising to open/download the App.  Doing so in Firefox browser, just hangs (unresolved).

 

(FYI) While the stated iOS versions for Prime Video and Netflix are likely as you've stated...  my old iPad Air (Gen 1) is running version 12.5.7 ...  and Prime Video and Netflix continue to run without issue.

 

Points taken re: older iOS versions and security.

Re: Has There Been A Recent Ignite release that requires IOS 14 or greater

-G-
Resident Expert
Resident Expert

(FYI) While the stated iOS versions for Prime Video and Netflix are likely as you've stated...  my old iPad Air (Gen 1) is running version 12.5.7 ...  and Prime Video and Netflix continue to run without issue.


If you have old versions of apps installed, they will not update if your device does not support the new version.  That they still work is great but services can also block old/unsupported versions of their apps from working too.

 

Here are links to the App Store showing the current minimum platform requirements for the major streaming apps:

 

https://apps.apple.com/ca/app/amazon-prime-video/id545519333

https://apps.apple.com/ca/app/disney/id1446075923

https://apps.apple.com/ca/app/netflix/id363590051

Re: Has There Been A Recent Ignite release that requires IOS 14 or greater

Schmenge
I'm here a lot

"If you have old versions of apps installed, they will not update if your device does not support the new version.  That they still work is great but services can also block old/unsupported versions of their apps from working too."

 

That is the perhaps the point... the big streamers (Netflix; Prime) will not allow the download a version that the device doesn't support -and more importantly- they don't block services for devices running an older version.

 

Here is how they manage access to older (compatible) versions on the Apps store:  

Prime Video:  select "UPDATE", as the App sees a version older that what is available.  It responds with:

Download an older version of this app?

The current version requires iOS 15.0 or later, but you can download the last compatible version.

 

So, the big streaming services:

1)  Don't block services if you're running an older version

2)  Pro-actively facilitate download availability of  "the last compatible version"

Rogers  would do well to offer the same level of Customer-focused service.

Re: Has There Been A Recent Ignite release that requires IOS 14 or greater

-G-
Resident Expert
Resident Expert

I agree.  That said, there could also be technical reasons for pulling old versions of the Ignite TV app -- e.g. incompatibilities with the current DRM implementation, broken features/functions, or other support-related issues.

 

Comcast have their own minimum requirements that they support from a technology and infrastructure perspective.  e.g. Things like casting could break (or worse) if the Rogers Ignite TV app is old or even just a few versions behind its Xfinity counterpart.

Topic Stats
  • 12 replies
  • 1386 views
  • 3 Likes
  • 4 in conversation