cancel
Showing results for 
Search instead for 
Did you mean: 

Rogers and Twitch.tv - Seeking an official response

dtx1
I Plan to Stick Around

Hello,

 

First and foremost, mods, please don't merge this post with the "Throttling RTMP" thread. That thread has gone unanswered long enough (10+ pages) and this issue needs to be addressed by a Rogers employee. Believe me, I am not trying to be passive aggressive, but whats the point of telling people to reach out to the community forums if posts with effort put into them are just buried into inactive posts?

 

My problem can be best described as follows:

I am unable to maintain a consistent upload bitrate stream to Twitch (i.e. I am the broadcaster, not to be confused with tuning into Twitch streams). I struggle to maintain even a 5k upload bitrate to Twitch on a 150/15 plan.

Many other community members have been suffering the same issues.

DSLReports members reporting the same thing (many other threads like it).

Here is a fairly large Twitch streamer who also suffers from the same issues on the Rogers network.

 

I believe I have ruled out any hardware related issues because

  • I have swapped out my modem twice (CGN2 -> CGN3ACSMR -> CGNM-3552, so unless they're all busted, I've done my due diligence)
  • I have tried the same settings on another computer
  • I have tried different versions of OBS, the logs all explicitly state that the frames are dropped solely due to connection issues (as opposed to skipped frames, which are caused by insufficient processing power)
  • I have tried directly connecting my machines to both the modem in default gateway mode, as well as an Archer C7 into the bridged modem
  • Most importantly, streaming to YouTube and Facebook is flawless, i.e. I can hold an 8k upload bitrate to those platforms with zero problems for extended periods of time (which likely rules out any Puma6 related problems, as all three of the streaming platforms mentioned make use of RTMP)

This likely leaves two culprits (perhaps more, please feel free to leave any other ideas):

  1. This is an issue with Rogers throttling Twitch ingest traffic, or there is a problem with the routing of Twitch ingest bound traffic
  2. This is an issue on Twitch's end (Twitch ingest server problems are unheard of, and they have officially stated that there is no limit to reasonable bitrates to their ingest servers. Moreover, in the past, Rogers community members have found that the use of VPNs solved their problems completely, although it appears that Rogers has found a way to "fix" that

The farthest that talking to livechat has gotten me is a tech visit, but what's the point of the tech visit? My signals are well within spec. The tech is just going to tell me that my connection looks fine and it's on Twitch's end. Even if it is a case of throttling and/or routing issues, what is one customer complaint going to do when it's a problem of this magnitude?

 

All of my friends who are also Rogers customers are unable to stream to Twitch because of the issues mentioned. All of my friends using Bell have no problems streaming to Twitch.

 

Ever since Bell laid fibe in my neighbourhood, they've been sending reps door-to-door twice a month or so, and they offered 300/300 for 60 bucks (not permanently, the price skyrockets after a year as usual).

 

I know it's not sweat off anyone's backs if I switch, but I've been with Rogers for five years now, and was recently offered a seemingly good deal when I called to upgrade (I thought I could finally broadcast with 15Mb upload). Rogers has been excellent in every other regard, and I want to make this work. However, none of the technical support live chat people have any answers, the network engineer "signal testing" always comes up empty-handed, and now the last avenue I can try (the Community Forums) has no answers as well.

 

Is this just a case of employees not admitting that Rogers is throttling because it's downright illegal and a legal liability?

 

Hopefully this post isn't just slapped onto the other one. Despite all of the things I've tried, questions I've asked, and people I've reached out to, no one knows the cause and/or doesn't want to talk about it.

I'm all out of options and just want to reach out for help one last time.

 

Any ideas, suggestions to try, or help is greatly appreciated.

 

 

 

***Edited Labels***

28 REPLIES 28

Re: Rogers and Twitch.tv - Seeking an official response

Gdkitty
Resident Expert
Resident Expert

Not a rogers employee here, etc..

But from your listing of things there.. and some of the semi findings/solutions..
I would tend to lean towards a ROUTING issue than throttling.
Mostly from the fact that that going through a VPN, your changing potentially from where its connecting to the servers from, and taking another route.

Re: Rogers and Twitch.tv - Seeking an official response

dtx1
I Plan to Stick Around

Thanks for your suggestion.

 

How would I go about testing if it is a routing issue? I ran some PingPlotter tests to each of the each of their ingest servers (reminder that only Twitch is problematic):

 

 

I'm not too sure on this, but wouldn't another explanation be that VPNs encrypt data so that ISPs are unable to throttle and/or properly apply traffic shaping?

 

In both cases, whether it's a routing issue, or a throttling issue.. what would you recommend is the best course of action to get someone to look at it?

Re: Rogers and Twitch.tv - Seeking an official response

Datalink
Resident Expert
Resident Expert

Just to add a couple of comments here, your Pingplotter plots show excessive packet loss for the modem and second hop.  That's caused by a modem timing issue and results in Pingplotter displaying false packet loss indications.  To confirm that, you can run a command line ping test to those same addresses.  They should result in no, or next to no packet loss.  

 

The packet loss at the Twitch address leads me to think that the server is set to ignore ICMP pings, and as a result the loss result is 100%.  Thats not a surprise.  Looking at the routing, from your modem to the Twitch address, its all Rogers, that means that there is a problem with the modem or a problem with the Rogers / Twitch interface.  Given the fact that you've indicated no problems streaming to Youtube or Facebook at high rates, I'm wondering if Twitch is using some variant of the RTMP protocol that the modem isn't processing correctly.  Only Twitch would know that, or, if anyone compared the upstream data for all destinations, any differences should be evident.  That would take a Wireshark monitoring session and data comparison to figure it out.  Beyond that, my thoughts would be that there is some issue at the Rogers / Twitch interface point that should be addressed.  Its a pretty short path from modem to Twitch, so there shouldn't be much to look at.  I'm wondering if all of the servers are actually showing up in that plot.  Rogers uses Cogent to carry a good portion of its data, so, is there a possibility that the data stream bound for Twitch is looping thru the U.S., without showing up in the path, and if so, is that causing some issues?  Only the network staff would be able to answer that question.  

 

I've asked @RogersGordon to have a look at your earlier post.  Can't make any promises on his behalf, but, I'm hoping that his arrival back in the forums will help with issues such as this. 



Re: Rogers and Twitch.tv - Seeking an official response

AhmedAskar
I Plan to Stick Around

Fairly decent sized streamer here that had to quit because of this.

Your only option is to go to Bell, I've dealt with this for 2 years now.

There is no solution to it, If I had Bell fibe in my area I would switch instantly.

I'm surprised you're still posting here honestly.

Re: Rogers and Twitch.tv - Seeking an official response

dtx1
I Plan to Stick Around

Yes, it is as you suspect, pinging the modem and router through command prompt yields normal ping results. The final Twitch hop is probably just set up to drop ICMP pings.

 

I sent an e-mail to Twitch asking about any potential issues/incompatibilities about 3 weeks ago, I have yet to receive a reply.. so I don't think I'll have a way to confirm if Twitch's RTMP differs in any way from the others. I'm not familiar with Wireshark either, I'd be willing to learn though.

 

That is an interesting point about potential problematic hops not showing up on the the plots, I didn't know that could happen.

 

Thank you for your advice

Re: Rogers and Twitch.tv - Seeking an official response

dtx1
I Plan to Stick Around

@AhmedAskar

 

I'm still hopeful that this will get fixed. I've been with Rogers for quite a while now, and it's been excellent for everything short of uploading to Twitch, both performance wise and customer support.

 

This is obviously not some easy issue that can be fixed overnight. I am trying my best to be cooperative and supply as much information as I can give. If you look over on the other Twitch thread, there's not a whole lot of information engineers, and IT can work with, despite being 15 pages long. Compound that with the fact that we're all on dodgy modems and the problem gets even harder to diagnose.

 

Another factor is money. Bell's prices skyrocket after the promotional period (usually 1 year). The same could be said about Rogers, but they made a loyalty offer that I feel is pretty good (assuming this gets fixed in the near future).

 

I don't mean to derail the thread, but I didn't want to ignore a community member either.

Re: Rogers and Twitch.tv - Seeking an official response

AhmedAskar
I Plan to Stick Around

Didn't know Poke was from around here. The twitter post was from a while ago.

 

Talked to him and he said he's still having issues with Rogers, he's on the old modem with 25/10 package. 

Funny thing is that he said he's been using WIFI over Ethernet and has less issues. lol.

 

Did a 5 hour stream today and had 3000 dropped frames, around 0.3%. Way better than what I usually get.

Re: Rogers and Twitch.tv - Seeking an official response

dtx1
I Plan to Stick Around

Is that with or without a 3rd party router?

Re: Rogers and Twitch.tv - Seeking an official response

AhmedAskar
I Plan to Stick Around

I tried both.
With and without, no issues anymore.

 

Hopefully it stays like this.

Re: Rogers and Twitch.tv - Seeking an official response

dtx1
I Plan to Stick Around

What a coincidence. I don't watch Pokelawls, but around the time the PUBG tourney started, I asked him in chat if he still uses Rogers as well. He confirmed he was still having some issues on Rogers, but he said that they were minor now, and just told me to trust him on trying a wireless adapter.

 

Today I streamed multiple sessions, totalling a couple of hours with less than 1% dropped frames, here is the best session yet:

 

Here is the log for it:

19:30:29.047: [rtmp stream: 'adv_stream'] Connecting to RTMP URL rtmp://live-yto.twitch.tv/app...
19:30:29.047: [rtmp stream: 'adv_stream'] Binding to IPv4
19:30:29.090: [rtmp stream: 'adv_stream'] Interface: Realtek PCIe GbE Family Controller (ethernet, 1000 mbps)
19:30:30.121: [rtmp stream: 'adv_stream'] Connection to rtmp://live-yto.twitch.tv/app successful
19:30:30.121: [rtmp stream: 'adv_stream'] New socket loop enabled by user
19:30:30.121: [rtmp stream: 'adv_stream'] Low latency mode enabled by user
19:30:30.123: ==== Streaming Start ===============================================
19:30:30.291: [AMF] <Id: 8> Initial Frame Latency is 133282382 nanoseconds.
19:32:15.559: adding 23 milliseconds of audio buffering, total audio buffering is now 69 milliseconds
19:35:51.667: adding 23 milliseconds of audio buffering, total audio buffering is now 92 milliseconds
19:58:30.399: adding 23 milliseconds of audio buffering, total audio buffering is now 116 milliseconds
21:07:44.524: [rtmp stream: 'adv_stream'] User stopped the stream
21:07:44.782: socket_thread_windows: Normal exit
21:07:44.782: Output 'adv_stream': stopping
21:07:44.782: Output 'adv_stream': Total frames output: 349341 (350053 attempted)
21:07:44.782: Output 'adv_stream': Total drawn frames: 350107 (350151 attempted)
21:07:44.782: Output 'adv_stream': Number of lagged frames due to rendering lag/stalls: 44 (0.0%)
21:07:44.782: Output 'adv_stream': Number of dropped frames due to insufficient bandwidth/connection stalls: 712 (0.2%)
21:07:44.782: [rtmp stream: 'adv_stream'] Freeing 26 remaining packets
21:07:44.782: Video stopped, number of skipped frames due to encoding lag: 2/350086 (0.0%)
21:07:44.783: ==== Streaming Stop ================================================

 

I should note that, the streams were still done over ethernet.

 

As for what fixed it..

 

Two things have changed recently:

  1. I spoke with a technical support manager (named Billy) 2 days ago about this issue, and he was stumped by this issue and was helpful in noting any potentially useful information into a ticket for his IT office. I got an e-mail a day later to inform me that they were unable to find the issue. I did not get a chance to test the stream around that time.
  2. I grabbed an old wireless adapter (TP-LINK WN722 V1), installed the drivers and tried to stream over wireless (via binding to the wireless interface in Settings > Advanced). I can without a doubt confirm that I was still getting around 20% dropped frames.

A couple of hours later after installing the drivers, I messed around with the settings, switching back to ethernet (again, via binding to the ethernet interface), and everything has been running perfectly for hours now.

 

If it is fixed, I'm stumped on what could have fixed it. I don't think Rogers fixed it, as the stream was not running fine earlier today, which was well after the engineers checked it out.

 

Ruling that out, the only other thing that I changed was install a wireless adapter (OBS runs fine now, without the adapter plugged in, but the drivers are still installed, however).

 

So more likely than not, this sounds like a software issue? This would support out findings (or lack thereof) of any problems relating to Rogers.

Maybe a hardware issue (perhaps a problem with an old Realtek network chip (RTL8111E); I'm using an old P8Z68 LX)?

Something that hasn't been documented yet? I could not find a hit on Google for anything like this.

Could this be in any way shape or form linked to the modem? I can't seem to think of any reason that it would be.

 

In any case, it's probably still too early to draw any conclusions, but I have never ever streamed with <15% dropped frames. Fingers crossed, I'll be sure to provide an update in a few days.

Re: Rogers and Twitch.tv - Seeking an official response

Gdkitty
Resident Expert
Resident Expert

Its possible something to do with the realtek RTL8111E card and how its interacting with the modem?
Or at least the drivers which it was running.

Recently at our work, the security team has forced/required installation of a Cisco security software suit (cisco anyconnect)
Almost every single machine we had which had the realtek card was having issues and  not connecting, till we did some major driver changes.   Something flakey with the sort of standard realtek drivers.

Re: Rogers and Twitch.tv - Seeking an official response

dtx1
I Plan to Stick Around

Unfortunately, it looks like the problems back again.

 

I haven't been able to stream all day today (15% dropped frames).

 

@AhmedAskar Is your streaming still fine?

 

Back to the drawing board I guess..

Re: Rogers and Twitch.tv - Seeking an official response

AhmedAskar
I Plan to Stick Around
Still fine, streaming on 6000 bitrate, can't achieve anything higher.
Starts lagging on 8000 bitrate.
Im partnered so I usually stream at 8000 bitrate, now I can't do that.
Every stream, it lags for 30 minutes where my bitrate drops to 100-500 and then goes back to normal for the rest of the stream (8hours)

Re: Rogers and Twitch.tv - Seeking an official response

AhmedAskar
I Plan to Stick Around

Nevermind, now I'm constantly stuck on 4500 bitrate, every day it's lower.

Sounds like Rogers throttling (:

Re: Rogers and Twitch.tv - Seeking an official response

Nadernt
I Plan to Stick Around

I've been having frame drop issues as well. It's not constant, but instead comes for a few hours then goes away. For instance, I've been noticing every day almost around 2-4pm I get frame drops and sometimes along with it ping spikes in-game. Also around 9:30-10:30pm. Fairly sure it's an issue with my upload speeds in general becoming really bad, and not some sort of general Twitch issue, but sometimes I really don't know why it happens. Sometimes I'll get massive frame drops but still keep low ping in-game. Sometimes no frame drops but high ping in-game. Sometimes I get both. 

 

I'm running on Bridge mode and I would swap over to just the CODA modem but I know that has RTMP streaming issues already. I've contacted support in the past about upload issues and usually it goes nowhere. I've had a technician come out once who couldn't solve the problem, so I just feel as if nothing will get done if I try to get this fixed.

 

The frame drops started happening a few weeks ago; they weren't always there.  Either way, I'm gonna do a short stream today and see how it goes. 

Re: Rogers and Twitch.tv - Seeking an official response

AhmedAskar
I Plan to Stick Around

Haha funny you said PUBG, I'm a PUBG pro and a streamer.

 

Anyway, it's back to being garbage.

Bitrate drops to 0 and then back up to 6000 or 8000 for a min and then back to 0.

 

Having 500 subs and not being able to stream is awesome (:

Thank you Rogers.

 

60f940f765d6c29b35c5103788ebefab.png

 

 

 

On the other hand when it was actually working.

1d30bad35a5f705622aff9502a66436a.png

 

Ordering Bell as soon as I'm back from a PUBG tournament, that 10mb upload might be more consistent than this "30mb" garbage.

Re: Rogers and Twitch.tv - Seeking an official response

Nadernt
I Plan to Stick Around

Honestly streaming on Twitch has been horrible for me. Every single day for the past month I can say I've had frame drops. Today though, I've been getting over 60% frame drops @ 60fps/5k bitrate. I dropped it to 30fps and 3k bitrate, still getting 11% frame drops. I'm getting packet loss in-game, around 1-15%, including one 3-second full disconnect. 

 

I was running bridge mode, and tried going back to gateway to see if that would help, but no, it wasn't the router's fault. I have nothing else running but my PC which I'm streaming and playing a game from. My speedtests seem to be showing good results, either maxing out at 15mbps or good enough that I should be able to stream easily.

 

Gonna give it 1 more day then contact CS. Not sure what they're going to do since it's only intermittent packet loss and upload issues. 

Re: Rogers and Twitch.tv - Seeking an official response

RyzenFX
I'm a Reliable Contributor

Is using a VPN the only way to resolve this issue? This issue has been reported on by many for more than a year now, and at this point it should be escalated to engineering.... 

 

If Rogers says the network is optimized for gaming, it should also mean that the network is optimized for streaming....

Re: Rogers and Twitch.tv - Seeking an official response

Nadernt
I Plan to Stick Around

It just doesn't even make sense at this point. It's not a consistent issue for me. Seems that their network is just overloaded or has issues. I can rarely get some good days with 0 frame drops but seems that it's just congestion at this point (for me at least). 

Re: Rogers and Twitch.tv - Seeking an official response

MrEMeatshield
I've Been Around

Sorry to bring this up again, but starting two weeks ago, I've been getting random dropped frames usually at night.

 

For example, I did a 3 hour stream at around 2 - 4:30 today with 0 dropped frames. But another stream I did from 8:30 pm to 2 am, I ended with 2683 dropped frames. Granted it was 0.2%, but that last thousand came almost instantaneously. I check once, it's at 1682, next thing I knew it was at 2683. I'm using SLOBS, so I can't put an OBS log.

 

But in the past two weeks, I've tried Studio, Slobs and Xsplit, all give me the same problems. Switched servers from the Toronto ingest server to Chicago, because it seems to be better according to the Twitch Bandwidth Tester, and it did reduce my dropped frames. I even tried a test stream on Youtube, at I still got dropped frames. Lowering the bitrate from my regular 5500 to 3500 didn't help either. I've done test streams through out the day, and most of the time, I get less during the day. Unfortunately, I can only usually stream at night. Every time I have a stream that has dropped frames, Twitch Inspector shows that it's got some Unstable Events too.

 

The afternoon stream

ooZN27C.png

 

The night stream at 5000 bitrate, because I used to do 5500 without any problems.

JKQeWx2[1]

 

Reading through this thread, it seems like some have been having this problem for over a year? Is there really no fixing this at all?

Topic Stats
  • 28 replies
  • 5563 views
  • 7 Likes
  • 10 in conversation