Showing results for 
Search instead for 
Did you mean: 

Extremely slow internet 1Gbps service less than 200 Mbps over the last 2 years

I Plan to Stick Around

I apologize in advance for the length of this description. For two years now I have been trying to figure out what the problem is and am about to give up and try Bell fibre as it may be the only way to rule out my Rogers feed line.

Here is my situation, I have Rogers 1Gbps service to a home, the tap is in my front lawn 20 meters from the home. The line comes from the tap to the home and goes through two connections directly to the CODA modem, no splitters etc. This line from the tap to the home has been checked by Rogers and they say there is no issue.

When I do a speed check with a direct connection to the CODA using an I7 multi-core PC windows 10 pro I get 150/30 Mbps speed. The 2.4 ghz wireless gets 25/30 Mbps and the 5 ghz wireless gets 50/30 Mbps.

Rogers line maintenance has come and say that they get 900/30 Mbps at the tap in the front lawn.

I have done speed tests using 4 pc’s and 2 mac-books all get less than 200 Mbps speeds. I have run speed tests using new android phones on both 2.4 and 5.0 and get less than 50 Mbps on both spectrums.

So to date here are some of the things I have done to try to figure out what the speed issue is:

  1. I test using Rogers speed check directly wired Ethernet using Cat 6 or 5e cables.
  2. My laptop is I7 multicore less than 2 years old, NIC is Qualcom and driver is most recent.
  3. I have run my PC in safe mode with networking.
  4. I have run my PC booting into Linix Ubuntu.
  5. I have run speed tests using an android TV box.
  6. I have run tests using Pingplotter and Solarwinds software.
  7. This is my 6th CODA modem.

Here is what I get for my 1Gbps service:

  1. On my PC normal boot into windows 10 I get 150 Mbps Ethernet wired only connection to CODA modem.
  2. If I boot into safe mode with networking, I get 150 Mbps or less.
  3. If I boot my PC into Ubuntu I get 800 Mbps.
  4. Macbook air, using 5G gets less than 80 Mbps.
  5. Samsung phone S8 gets less than 50 Mbps both 2.4 and 5G.
  6. I can run a Cat6 cable to my TV’s android box and test on the TV. If I run a speed check on the TV through a chrome browser to Rogers internet speed check I get 125 Mbps. If I run a speed test using ookla app on the TV I get 700 Mbps.
  7. When using pingplotter it shows a 200 ms response time in the first hop to a Rogers switch about 10 miles from here.
  8. Rogers techs have twice now said that they see flapping in the signal, as in either all on or all off.
  9. Most recently, I have had “Rogers chronic care” tech come to the home and using his laptop, Ethernet wired got 800 Mbps, said the problem was in my PC.

I am at a complete loss to know what to do next. I know this, with any of my PC’s directly wired fully updated I get less than 200 Mbps, if I boot into Linix I can get 900 Mbps using firefox. I know that wirelessly either 2.4 or 5.0 I get less than 50 Mbps using android phones. Apple mac-book gets 100 Mbps wirelessly. Android TV will get either 700 using Ookla app or 75 Mbps through browser to Rogers speed check.

My speed problem is on Windows 10 professional machines unless I boot into Ubuntu where I get full speed. But the speed problem is also on Apple mac-book, and the speed problem is on android phones. The speed problem on android TV is there if using a web browser but not when using an app.

I am at my wits end with this, if anyone has any ideas it would be very much appreciated.




Re: Extremely slow internet 1Gbps service less than 200 Mbps over the last 2 years

Installed the new 1Gb modem this past week because of supposed better performance and latest technology.

I would like to know why I’ve seen the following message twice in less than a week and I had NEVER seen it before - MSG: Slow Internet

Any idea anyone?

Re: Extremely slow internet 1Gbps service less than 200 Mbps over the last 2 years

Welcome to the Community and thank you for your post @C14,


Seeing a slower than expected connection to the internet can come as quite an unwanted interruption to say the least! To assist there's a few additional details we'd need to know. To start, is this with a wired or a wireless connection?


Additionally, may you please connect the Ethernet cable directly from the modem to the computer (not in bridge mode)?

Then, open a web browser and enter the following address to access the gateway login page:

Login using the following credentials:

  • Username: cusadmin
  • Password: password   (Or with your password if it was already set up)

Click Status at the top of the page and the DOCSIS WAN tab.


Copy and paste the results, but please make sure to remove your MAC address.


Looking forward to hearing from you.






Re: Extremely slow internet 1Gbps service less than 200 Mbps over the last 2 years

Is there a way to pull the drivers Ubuntu is using to see if the versions are the same? I agree, it seems the issues are tied to something Windows 10 and MacOS are doing more so than the adapter. If the other machines (other than the Mac) are windows machines, it is more likely related to the OS being more cumbersome than Ubuntu. The best I have achieved on my Roger's 1G service is 330 Mbps, so I am very interested in your findings.



Tagged - @mikemeddings1 

Re: Extremely slow internet 1Gbps service less than 200 Mbps over the last 2 years

The above last post, was from Dec of last year.. some of the users may not be actively following this thread anymore.

There are many users which, at least say via speed tests (to the appropriate source) have been able to pull the 1g speeds.

But in a REAL WORLD scenario.. the likelyhood of anyone coming even remotely close, especially when say pulling from a single source is very unlikely.  No end server will likely be feeding you the data at that speed.

Re: Extremely slow internet 1Gbps service less than 200 Mbps over the last 2 years

I have the same issues, I get speeds as high as 300mbps on their 1gig package and as you watch it , it continuously falls until it reads between 170-190mbps. Sometimes at night it goes as low as 65mbps. All of my issues are on the download side.

I have asked the techs who visit my location, to use their own computer with my modem, and then their modem to test outside at the green box, where their service comes to my property. At first they get over 800mbps, then it drops off and the reach no higher than 190mbps. Proof that my lines, my computer, my modem is not the issue, but their lines coming to my property. Now one of those tech's who seems to be stuck in the middle, get's told by his superiors that the test he preformed was not valid as the hard drive on his pc is slowing down and he will not get fast speeds. So basically he's been told to shut up!! Two other tech's who preformed the same test, using their own (Ignite/Rocket) modems, separately of course, with their own computers, their own cad 6 line, and their own coaxial cable, plugged in directly to the green box on my property, and they get the exact same speeds as tech one. No higher than 190mbps. There is an issue, and instead of fixing it, it seems the higher ups would rather silence their tech's for trying to fid out the problem, then to spend any money or brain matter on getting the issues resolved. As you can tell, I have little faith in the powers at rogers, with a small r. Unless the problem affects many customers, the singles and individuals are out of luck. 

Re: Extremely slow internet 1Gbps service less than 200 Mbps over the last 2 years

Hey @johnineed


Welcome to the Rogers Community Forums, and congratulations on your first post with us! 😊 I hope you're staying safe and sound. That is certainly not the type of experience I want you to be having. I know first hand how imperative it is to ensure consistent speeds. 


Did you happen to complete your speed test on with two different Gigabit-capable devices that are wired directly to your modem? If not, if you could kindly do so, that would be much appreciated. 👍 The second device can be connected to your 5G wireless network, also please ensure all other devices are disconnected from the network. The speed tests must be run at the same time though and not in sequence. Once you've received the results, please feel free to share them with us here so we can gain a better understanding of what the next steps should be to assist you with this issue. 





Re: Extremely slow internet 1Gbps service less than 200 Mbps over the last 2 years

I've Been Here Awhile
I wish I were as tech savvy as you and that i had read this before upgrading to ignite in January 2021. Multiple problems with Rogers. First, can't get the 1 GB download speed, even when I run CAT6 directly to a laptop/desktop device. Most of our devices (iPhones, MacBook Pro and iPads are very new models with all of the latest processing hardware for max speeds). Issues connecting through the ignite Hub include inability to Airplay (using WIFI) to the Samsung TV. Likely going to have to switch to Bell Fibe.

Re: Extremely slow internet 1Gbps service less than 200 Mbps over the last 2 years

Resident Expert
Resident Expert

@AH15 what modem do you have?

We Want Your Opinion
Would you be interested in becoming a Community Testing Lab member?
Topic Stats
  • 28 replies
  • 12 in conversation