cancel
Showing results for 
Search instead for 
Did you mean: 

A valid government website is blocked

muralibaskar
I've been around

Hello, 

The Canada government website - https://cic.gc.ca which redirects to https://clegc-gckey.gc.ca after login, is getting blocked in my laptop. The following error is shown

"Security check failed For your protection GCKey employs security checks to verify user authenticity. This can fail if you try to log in too many times, or access GCKey from a VPN. Please try again later or from another device."

I have tried the following options:

1. Rogers wi-fi on my laptop - blocked

2. Rogers wi-fi on my mobile - connects

3. Mobile hotspot on my laptop - connects

Thought the problem was with my laptop, so I added these URLs to trusted websites, changed the proxy settings to use "Autmatically detect settings", tried with and without VPN, cleared cache, browsing history, checked with different browsers - Chrome and Edge, incognito mode. Nothing seems to work. Any help on this would be appreciated. Thank you..!

 

**Labels Added**

1 REPLY 1

Re: A valid government website is blocked

-G-
Resident Expert
Resident Expert

@muralibaskar  Do you have Advanced Security enabled on your Ignite Gateway?  If so, try disabling it.  Having this feature enabled can cause some web sites to break.

Topic Stats
  • 1 reply
  • 1114 views
  • 2 Likes
  • 2 in conversation