cancel
Showing results for 
Search instead for 
Did you mean: 

XB7 modem slow wifi speeds and weak wifi signal

tester2013
I Plan to Stick Around

I am on the Ignite Gigabit package with Ignite TV.

I had issues with my internet about 3 weeks ago and a Rogers contracted tech came over and resolved the issue and he decided to change my XB6 modem to the new XB7 as he mentioned it has better wifi range.  He said it will take 3 days for modem to get used to everything. I left it as is and went onto do my regular surfing and what not. After 5 days I do a speed test on Wifi and my speed wont pass 100mbps up and 21mbps down. Decided to reboot the modem and redo the test; no change. I decided to come right near the modem and the speeds were not that great 120mbps down 29 up. Decided to chat with tech support who sent another tech out to me. He said it was a problem with one of the splitters. He replaced it and we did the speed test. Similar results as what I posted. He said that it was fine and the speeds are slow because the Wifi speeds gets shared to each devices. All tests were done on 5Ghz. I reached to chat again and they sent another tech as the rep said something is not right. The speeds are too slow on wifi. This time it was tech from Rogers directly (no contractors). He figured out right a way what was the issue. My cables run under the carpet and the nails touch the cable causing interference. The cables run from outside to basement and then are split upstairs in the main room where the modem is. He said one of the wires is showing as "open" and it should be closed. The easiest option was to run a direct line from outside and right into the room where the modem is, drilling was required and that should solve the problem. I told him to go ahead. after completion of the cabling we did the tests again and it was no better than before. He told me that there are temp lines that are on my street that may be affecting the wifi speeds. I was wondering how could that be. He left without any further work. 

Tracing back to my XB6, wifi speeds were constantly above 400mbps down almost anywhere in the house. Chat rep did do a software update from his side on the XB7 which did nothing to improve wifi speed.  Hardwired speeds are perfect on both modems; 980 down and 30 up.

What choices are left for me? Do I have a defective XB7?

 

*Added Labels*

 

3 REPLIES 3

Re: XB7 modem slow wifi speeds and weak wifi signal

RogersMoin
Moderator
Moderator

Hello, @tester2013.

Thank you for your detailed post; troubleshooting WiFi speeds can be a little tricky. However, let’s see if we can optimize your network and achieve higher speeds. 

While XB7, the Ignite WiFi Gateway modem, offers powerful WiFi throughout your home, depending on where you install your gateway, building materials, and other factors can influence the WiFi speeds. 

We need more info about your network:

  • Where is your modem physically located? Please check our knowledgebase article for modem placement.
  • Do you have WiFi Pods? If yes, what Gen and how many?
  • Are you using a third-party router?

We look forward to hearing from you!

Cheers,
RogersMoin

Re: XB7 modem slow wifi speeds and weak wifi signal

tester2013
I Plan to Stick Around

Modem is installed in an open space with no obstruction. No wifi pods or router are being used. 

Re: XB7 modem slow wifi speeds and weak wifi signal

tester2013
I Plan to Stick Around

I have given up and decided to go out and get a router. I got the TP Link 5400 and now I finally get wireless signal with proper speeds at places that were under 100mbps. I now get 300mbps and over.

Bell is in the area laying down Fibe. I just can't wait to switch over to Fibes. Rogers has been nothing but frustrating. 

We Want Your Opinion
Would you be interested in becoming a Community Testing Lab member?
Topic Stats
  • 3 replies
  • 242 views
  • 0 Likes
  • 2 in conversation