CODA-4582 MoCA 2.0 setup

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I Plan to Stick Around
Posts: 14

Re: CODA-4582 MoCA 2.0 setup

Update: 

 

Tech came today. Was far more understanding and attempted to help me out. Although he had the MVRA502b, not the 902b I specifically requested. Told him not to do any work however since currently, everything works as-is.

However the techs seem to be ill-informed of the full capabilities of MoCA, only knowing and understanding it's PVR capabilities.

Might be because i'm in my mid-twenties that they feel I am unaware of what i'm talking about.

 

Either way, it was a good shot for now.

I'm gonna put the whole project in the backburner and take a break for now until I can get my hands on a 902b.

Who knows how long it will be before 

 

Thanks for your time, effort and knowledge, @Datalink!

Highlighted
I'm Here A Lot
Posts: 7

Re: CODA-4582 MoCA 2.0 setup

Need help with the GoCoax 2.5 MoCa adapter to connect with the Rogers Gigabit modem

 

Could someone please help me with a GoCoax 2.5 MoCa adapter to connect with the Rogers gigabit modem?

 

Based on my understanding, since the Rogers modem already has builtin MoCA capability I don't need an extra Gocoax adapter near my modem/router. In my case, I just need MoCa to my upstairs computer. FYI, Yes, I have enabled the MoCa option in the Rogers modem and as well connected to the MoCA interface via configuring the correct IP address as advised on the manual. But the MoCa status shows as "down" in the interface. unable to connect to the internet via MoCA. Could you please help me? I have tried everything possible, including rogers IT support but no luck.

Highlighted
Moderator
Moderator
Posts: 921

Re: CODA-4582 MoCA 2.0 setup

Hello, @ronaldanton

 

Thanks for posting your concern in the Community!

 

A lot of users use MoCa connections in their home networks. Regrettably, we are unable to directly support issues with this type of set up.

 

@Datalink, has provided a lot of help to other users who wish to use a MoCa set up. I have tagged him into this post and I am confident he will be able to assist you with this matter.

 

If there are any other users in the Community who are able to assist with MoCa adaptors, please feel free to chime in!

 

RogersTony

Highlighted
I'm Here A Lot
Posts: 7

Re: CODA-4582 MoCA 2.0 setup

Thank you for your response @RogersTony 

 

@Datalink  Could you please kindly help me?

 

 

"

Need help with the GoCoax 2.5 MoCa adapter to connect with the Rogers Gigabit modem

 

Could someone please help me with a GoCoax 2.5 MoCa adapter to connect with the Rogers gigabit modem?

 

Based on my understanding, since the Rogers modem already has builtin MoCA capability I don't need an extra Gocoax adapter near my modem/router. In my case, I just need MoCa to my upstairs computer. FYI, Yes, I have enabled the MoCa option in the Rogers modem and as well connected to the MoCA interface via configuring the correct IP address as advised on the manual. But the MoCa status shows as "down" in the interface. unable to connect to the internet via MoCA. Could you please help me? I have tried everything possible, including rogers IT support but no luck."

Highlighted
Resident Expert
Resident Expert
Posts: 6,826

Re: CODA-4582 MoCA 2.0 setup

@ronaldanton  in order to make this work you will need a MoCA filter installed on the inbound external cable followed by a MoCA 2/2.5 qualified splitter to replace your existing splitter. 

 

The CODA-4582 modem is most likely locked to D-High, allowing any Nextbox MoCA network to use D-Low.  The MoCA bands can be seen on pages 9 and 13 of the following MoCA 2.5 spec:

 

http://www.mocalliance.org/MoCA2.5/specification.htm

 

Due to the modem being locked into D-High, you will have to log into the goCoax adapter and lock the adapter to D-high and try setting it to use 1400 Mhz as the Lowest Usable Frequency, or closely related terminology that the adapter uses. 

 

That may or may not work. 

 

Have a read thru the following thread in the DSLReports forum which goCoax participates in:

 

https://www.snbforums.com/threads/gocoax-moca-2-5-adapter.59499/

 

Take a look at the following posts in that thread:

 

https://www.snbforums.com/threads/gocoax-moca-2-5-adapter.59499/page-9#post-596982

 

That shows the various MoCA adapters that are running in the network, so, by looking at that display in the goCoax user interface, you will be able to determine if in fact the goCoax adapter is detecting the modem’s MoCA network. 

 

Now, fwiw, one item that has come up recently in that thread is the fact that the goCoax adapter assumes that its going to be the network controller, simply due to the fact that it’s the most recent adapter, in terms of its specifications.  There is nothing in the MoCa specification that indicates that, so, I don’t know where that design spec comes from, perhaps a secondary interface spec that I’m not aware of?  This has caused problems with another customer who was attempting to use a set of goCoax adapters on the same cable system as the Nextbox MoCA network.  I don’t believe that ever worked, but, I’d have to reread the thread to see what the outcome was. 

 

What this does is raise the question of the behaviour of the Hitron MoCA controller.  Does it relinquish network controller duties to the goCoax adapter, as assumed by the goCoax adapter, or does it retain network controller duties which will probably cause problems for the goCoax adapter?  If the modem won’t relinquish MoCA network controller duties, can the goCoax adapter be set to disable network controller duties?  Don’t know.  The worst case scenario would be if both modem and goCoax adapter were running as the network controller.  You’re going to have to figure that out when you get this far.  Perhaps posting appropriate questions in the DSLReports might result in quick answers to the questions. 

 

Ok, so, the steps, in order as I see it:

 

  1.  Install a MoCA filter and MoCA splitter.
  2. With those installed, enable the modem’s MoCA network and set the privacy code.  Log into the goCoax adaper, set the privacy code and check the goCoax adapter display to determine if the goCoax adapter can see the modem’s MoCa network. 
  3. If not, then there is a chance that there’s another splitter between the MoCA splitter and the goCoax adapter, blocking the MoCa frequencies.  That’s a problem that has come up in previous cases.
  4. If yes, then the question is, which device acts as the MoCA network controller?  You should be able to determine if this is a problem pretty quickly.  If the goCoax adapter sees the modem’s MoCA network, but, the network simply does not work, that means that the goCoax adapter isn’t set to use D-High and 1400 Mhz as the lowest usable frequency, or, if it is, then possibly both modem and adapter are running as the network controller.  If this is the case, then its time for plan B. 
  5. If the goCoax adapter sees the modem’s MoCA network and you end up with a working network, congrats. 

 

Plan B:

Buy and install another goCoax adapter and disable the modems MoCA network.  You will still need a MoCA filter and MoCA 2.0/2.5 splitter.

 

Plan C:  Return the goCoax adapter and buy a set of Actiontec adapters.  You will still need a MoCA filter and MoCA 2.0/2.5 splitter.

 

https://www.actiontec.com/products/home-networking/ecb6200/

 

Actiontec does make a MoCA 2.5 adapter as well.  Last that I saw, it wasn’t available to the public but, looking at amazon.com, it shows up as a listed, but out of stock item:

 

https://www.amazon.com/gp/product/B088KV2YYL/ref=as_li_tl?ie=UTF8&camp=1789&creative=9325&creativeAS...

 

It doesn’t show up on the amazon.ca site.

 

Note, due to the modem locking to D-high, you won’t be able to run the goCoax or Actiontec adapters to their full data rates.  That’s simply due to the frequency band in use and the allowable number of bonded channels D-High will support.  If you wanted to use the full bandwidth for the maximum data rates possible, then you need to run a MoCA network using the adapters and leave the modem out of the picture.  It would be worth checking the goCoax display to determine if the CODA-4592 modem is still locked to D-high.  Using firmware version 2.0.10.36T6 it should be locked.  Version 7.1.1.32 is rolling out from what I understand, but, I don’t know if the modem is still locked to D-high in this version.  Hopefully that would be an easy to check item by using the goGoax display.

 

One last item is to test the MoCa network by connecting both modem and adapter to the same cable, that is:

 

-> inbound cable to modem -> connected to goCoax adapter input -> goCoax output connected to modem

 

goCoax ethernet port -> pc or laptop

 

You will need a short RG-6 cable to connect the adapter to the modem.  By doing this, you should be able to prove fairly quickly whether or not the goCoax adapter will work with the modem.  Your results should determine whether you proceed to plan B or C.

 

Hope this helps.

 

 

 

 



Highlighted
I'm Here A Lot
Posts: 7

Re: CODA-4582 MoCA 2.0 setup

@Datalink Wow, I'm speechless, surely an impressive helper you are. FYI, I already have the MoCA splitter and just ordered the MoCA filter now, waiting for the delivery. I am going to try all your steps and will let you know soon. 🙂 Ones again, thank you very much for giving your time here.

Highlighted
I'm Here A Lot
Posts: 7

Re: CODA-4582 MoCA 2.0 setup

@Datalink As per your advice with MoCA filter installed works like a charm. The problem I am facing now is the speed lesser than 200mbs in my upstairs computer room. I did the test in the basement where the MoCA filter and splitter are located and getting around 700+mbs. Will any moca (coax) amplifier would increase the speed to upstairs? Thank you again for your help.

Highlighted
Resident Expert
Resident Expert
Posts: 6,826

Re: CODA-4582 MoCA 2.0 setup

@ronaldanton it looks like your at the "leave no stone unturned" stage.  Ok, if I'm interpreting this correctly, with the following configuration:

 

MoCA Filter -> MoCa splitter -> short cable -> MoCA adapter -> short cable -> modem

 

you're seeing 700 Mb/s.  When you go to:

 

MoCA Filter -> MoCA splitter -> port 1 -> cable -> modem

                                                      -> port 2 -> cable run upstairs -> adapter

 

you're seeing 200 Mb/s.  

 

The question at this point is whether or not you have a cable or connector problem, or, possibly a hidden splitter somewhere between the cable start point downstairs and the cable end point upstairs.  That has been a problem with other users.  

 

First thing I would do is check the speeds thru the splitter.  Disconnect the MoCA adapter, take it downstairs and connect it to the same splitter port that is used for the upstairs cable, using a cable that allows you to connect the adapter to a laptop or desktop downstairs.  Pull off the current upstairs cable off of the splitter and connect the adapter to the same port with another cable for test purposes.  Take note of the "notes" below, regarding the length of the center copper conductor of the cable, beyond the connector end.  This test should resolve any questions about the splitter performance, that is to say, thru the splitter, in one port and out the other port, or one of the other ports if that's the case. 

 

You should get 700 Mb/s or more with a MoCA 2.0/2.5 qualified splitter in place.   The configuration should look like this:

 

MoCA Filter -> MoCA splitter -> port 1 -> cable -> modem

                                                      -> port 2 -> test cable -> adapter

 

If you see 200 Mb/s then there is an issue with the splitter ports or the cables that connect to the splitter ports.  This is where the issue of copper conductor length can come into play.  The port barrels are designed to grip the copper conductor when the connector is screwed down onto the port, and the internal construction of the port barrels should be consistent port to port, but, if the internal grip mechanism of the barrel is out of place, or if conductor is too short, then you end up with a bad connection between the copper conductor and the internal mechanism of the barrel.  Simpy swapping cables with the splitter ports might resolve the situation to the point where the copper conductor has adequate contact with the internal grip mechanism of the port barrel.

 

If you end up with 700ish Mb/s from a speedtest, then the question is, whats the problem with the cable run that goes upstairs?  

 

At this point, I would also log into the adapter and look at the signal data to determine how that looks in comparison to the test configuration where you had the adapter sitting in front of the modem.  The signal data should look the same, unless of course there is an issue with the splitter.  

 

Have a look at the cable jacket for the cable that runs upstairs.  Hopefully you will see the manufacturers cable data printed in the jacket.  You're looking for RG-59 or RG-6 printed on the cable jacket.  The preferred cable type is RG-6.  RG-59 dates back to analogue tv days.  RG-59 has higher signal losses than RG-6 in the higher frequency ranges where MoCA operates, so, that might be part of the problem if in fact you have RG-59 in your home. 

 

The F-81 connectors that are used in the wallplates should be replaced with higher frequency connectors.  The older connectors support frequencies under 1 Ghz, whereas MoCA 2.0/2.5 runs up to 1.675 Ghz.  The higher frequency F-81 connectors can be found at Home Depot and possibly Lowes as well.  They look like the following:

 

https://www.homedepot.ca/product/ideal-3ghz-f-splice-adapter-10-pack-/1000751479

 

Make sure that you buy at least 2.4 Ghz, preferably the 3.0 Ghz connectors.  I recommend replacing all of the F-81 connectors in all wallplates throughout the house.  

 

With an F-81 connector on hand, you can run the following experiment, and that is to use the modem as a test tool to look for any hidden splitters.  

 

1.  Connect the modem to the incoming external cable, essentially replace the MoCA filter with the modem.  Fire up the modem, log in and navigate to the DOCSIS WAN tab.  Copy the Downstream Overview, all the way to the bottom of the OFDM/OFDMA section.  Paste that into a text editor such as Microsoft Notepad or other editor and save it.  When you select that entire table area in the modem's UI, right click .... Copy.  Then, in the text editor, right click .... Paste.  That should paste in the entire table data.  

 

2.  Connect the incoming external cable to the upstairs cable using one of the 3 Ghz F-81 connectors so that you can determine the signal levels at the upstairs cable port.

 

3.  Replace the upstairs F-81 connector in the wallplate.

 

4.  Connect the modem to the upstairs cable port, fire it up and log in to the modem again to grab the signal data from the STATUS .... DOCSIS WAN tab.  Copy and paste the data into the same text file.  

 

What your looking for at this point is a signal drop between the downstairs data and upstairs data.  If you look at the DOCSIS 3.0 data (channels 1 to 32) you really shouldn't see much of a drop in signal levels, but, that also depends on the cable type that you have in your home, RG-59 versus the preferred RG-6.  RG-59 cable would probably show a slightly higher signal loss in the upper frequencies.  

 

If you see a fairly consistent drop of 3.5 dB in the upstairs data, that would suggest that the upstairs cable runs thru a splitter and its connected to a -3.5 dB port.  This could suggest that there is a two port splitter in place somewhere.

 

If you see a fairly consistent drop of 7 dB in the upstairs data, that would suggest that a larger splitter is in place, a three port or larger splitter, and that the upstairs cable is connected to one of the -7 dB ports. 

 

If you see a drop of 11 dB or more, that suggests that there is something like a 7 port or larger splitter in place with the upstairs cable connected to any of the ports.  

 

The other possibility is an issue with the cable or connectors.  You would need a test tool to determine if there was any issue with the cable itself, either with any signal losses thru the cable or with any potential cable breaks.  Rogers techs would normally have the test tools to do this, but, at the present time, the techs can't enter anyone's home.

 

I would carefully examine both ends of the upstairs cable, with magnifying glass on hand.  Look for any sign of the cable shield wires contacting the center copper conductor.  There is usually more than one type of aluminum shielding surrounding the dielectric material that surrounds the center copper conductor.  That could be aluminum foil and/or stranded aluminum wires.  That shield material is normally wrapped back along the cable when the connector is installed so that the connector itself is connected to the cable shielding, with the center copper conductor insulated from that shield by the dielectric material.  In the case of a faulty connector installation, if there is any contact between the center copper conductor and the shielding, that will ground out the copper conductor, causing a signal loss.  So, a quick inspection is in order to determine if that situation exists, and if so, the shielding should be removed from the copper conductor.  When you're doing this, disconnect both ends of the cable, from the splitter downstairs and and the wallplate F-81 connector. 

 

If you notice that there is copper oxidation on the exposed center conductor, consider replacing the connectors, if you happen to have a crimp on connectors, crimping tool and wire stripper on hand.  You can clean off the oxidation with sandpaper as well, just be sure to blow the dust out of the connector when you're done. 

 

Also check the length of the center conductor where its exposed at the connector.  If that centre conductor is too short, you could have problems connecting to the next connector, be it F-81 or modem or splitter connector.  Only solution in that case would be to install a new connector and leave the center copper conductor with a longer length.  I usually leave two to three milli-meters exposed beyond the connector end, sometimes longer if I run into a problem device that I'm connecting to.  Here's a Youtube video that shows a crimped connector installation on a cable.

 

https://www.youtube.com/watch?time_continue=188&v=2SbbWHH9ek0&feature=emb_logo

 

Ok, that should do it for now.  The question are:

 

1.  what do you get if you connect the MoCA adapter downstairs, thru another splitter port 

 

2.  If you go as far as testing for signal drops between the downstairs connection to the external cable, and the upstairs cable port, what do you get for signal levels?  That should be a big indication of the condition of the upstairs cable run and possibly the presence of a hidden splitter somewhere in the walls or floor. 

 

3.  What type of cable to you have in your home, RG-59 or RG-6.

 

I would hold off on any MoCA amp until you determine that the upstairs cable run is good to go and that there's no hidden (non-MoCA) splitter somewhere.  Rogers would probably supply a MoCA 2.0 amp if requested.  I'll have to look up the model number again.