Showing results for 
Search instead for 
Did you mean: 

Ignite Home connect app will not login

I'm here a lot

The Home Connect app will not log me in. It's just an infinite loop of entering my info and the code that is sent to me. Reinstalling doesn't work, changing the browser that opens to enter the info doesn't work, clearing the cache doesn't work. Very frustrating that I need to even use this app to change certain router settings!!!

Brand new Samsung s23+, android 14 running.


*Labels Added** 


Re: Ignite Home connect app will not login

I've been around

Hi, I just got migrated over to Rogers from Fido Internet, my new modem arrived today (April 4, 2024) and the Home Connect app works for me.  I use an Andriod phone and it works fine.  Make sure you log in to the My Rogers app first then the Home Connect app and wait for the modem light to turn white.

Re: Ignite Home connect app will not login

Resident Expert
Resident Expert

@Waynegc69  ...Thanks for the tip. That aspect was discussed in the following recent thread from yesterday...

Re: Ignite Home connect app will not login

I've been around

Its been weeks now and the problem is still there. I am now stuck in an infinte loop. Followed the solution steps, did not work. Deleted and reinstalled, clear cache, unplug and replug the modem, unlink and relink, no there is no shaw user, and the problem still persist. 

Re: Ignite Home connect app will not login

I called customer service and was suggested trying on another phone. It worked!

Re: Ignite Home connect app will not login

I plan to stick around
I just signed up for Ignite and initially had all these issues ranging from login loops to the app repeatedly configuring the router even though it already had a name and password. The main thing is to ensure the internet account is linked to your TV account login profil. It cannot be separated. Once the accounts are linked the magic will occur within a day. It will recognize the login, associated gear and the app will start working. From what I can see you don't need to get the app configured at set up. It can be done after initial set up going through the IP address of

Re: Ignite Home connect app will not login

I've been around

I received a new modem today.  All my devices but my printer are now reconnected to the new modem.  However I can't get my printer to connect and it is telling me to check the MAC Address filtering.  Now the next problem is exactly what is being discussed here.  I cannot get into the application to do any config of the modem.  Endless looping.


Re: Ignite Home connect app will not login

Hello @dkettles,


Thanks for chiming into this conversation and sharing with us the issue you've been having. 


By any chance, have you had time to review this thread and try some of the troubleshooting steps provided in the Accepted Solution post, as well as suggestions made by other users? They seemed to have worked for some our community members.


Please let us know what troubleshooting steps you've tried so we may assist further.


Kind regards,




Topic Stats