cancel
Showing results for 
Search instead for 
Did you mean: 

Login error received when submitting likewize request

varunkc30
I've been around

I am trying to process a device protection request, but everytime I open the portal it gives me this error.

 

"Oops. Username or Password seem to be incorrect. Please check and try again."

 

There's no option to enter any username or password, and I shouldn't even need to as I'm already logged in to MyRogers. I've tried accessing this page from both Rogers and Likewize, and both of them redirect me to https://onlineportal-ca.likewize.com/rogers/login where I see this login error. 

 

*Added Labels*

3 REPLIES 3

Re: Login error received when submitting likewize request

RogersJermaine
Moderator
Moderator

Hi @varunkc30,

 

Thank you for your post here on the Rogers Community Forums. We do hope we are able to assist you with getting your service request completed.

 

After clicking on the link to start a service request on their website here, it should prompt you to sign into your MyRogers account using your MyRogers username and password, or if you are already signed in, it should take you directly into your account, where you would go to the Device Protection tab.

 

Have you tried using a different browser or clearing your cache and cookies and trying again?

Let us know if those steps work for you or if you are still having trouble accessing the website. You can also contact them directly by dialing 1 855 877-3887.

 

Regards
RogersJermaine

Re: Login error received when submitting likewize request

Spraggsy
I've been around

I am also having this issue. Have tried in three different browsers (Chrome, Edge and Firefox) and keep getting this error message.

Re: Login error received when submitting likewize request

Hi @Spraggsy,

 

Welcome to the Rogers Community Forums, and thank you for joining this thread. Are you getting the same error message when trying to access the link as referred to in the original post? If you have already tried different browsers, cleared your cache and cookies, and you are still getting an error, can you also try using inprivate browsing mode or incognito mode, depending on the browser you are using?

 

Can you also ensure that you are using the correct MyRogers account that is attached to the wireless number that you are looking to complete a service request on?

 

Thank you
RogersJermaine

Topic Stats
  • 3 replies
  • 761 views
  • 0 Likes
  • 3 in conversation