CODA-4852 Gateway not receiving WAN IPv6 Address

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
Showing results for 
Search instead for 
Did you mean: 
I've Been Here Awhile
Posts: 2

CODA-4852 Gateway not receiving WAN IPv6 Address

I've had recurring issues where the modem will not grab an IPv6 address on the WAN side. If I set the modem to Bridge mode, my desktop will get an IPv6 address.


I called in to support Wednesday and they said they made some change on the Network end to resolve it, as it was an area-wide issue. That solved it for the day, but my modem disconnected around 11 PM last night and when it came back it was no longer capturing a WAN IPv6 address again, it's just stuck with this: 


WAN IP Address

99.248.x.x, none


(redacted full IPv4 address for privacy).


Modem is currently configured in Gateway mode with Router mode set to Dual. No changes were made between when the device had IPv6, the reboot at 11 PM, and now.


I'd call back in to support, but if I'm asked to reboot or reset my router one more time I'm going to swallow my phone. I'm logging this here so that I have another venue to track this issue, and hopefully get it resolved when it crops up.



**Edited Labels**

Solved! Go to Solution.
Resident Expert
Resident Expert
Posts: 6,050

Re: CODA-4852 Gateway not receiving WAN IPv6 Address

@RandomNinja, if you kick the modem into Gateway mode and after a reboot you log into the modem to check the Status page, specifically the Wan Address (which should show both IPV4 and IPV6) addresses, and it only shows the IPV4 address, that's a CMTS fault.  By using the modem to detect the presence or lack of an IPV6 address, that keeps the discussion to the Rogers equipment only, ie:  Rogers CMTS and Rogers modem.


For now, the best thing to do is to send a private message to @RogersSergio with your modem MAC address, so that he can pass that onto the engineers.  With that MAC address, the engineering staff can find your modem, and more specifically the CMTS and have a look at the CMTS configuration to determine what the problem is.  Most likely someone has changed the CMTS configuration and as a result, the connected modems are not assigned an IPV6 address.  


The alternative to this is to ask for a Level II tech if you call into tech support.  I've seen in another post that there isn't a Level II tech anymore, but, that makes no sense what so ever.  There has to be some level of tech or manager above the Level I techs who can handle CMTS issues or at least report them to the engineering staff.  

I've Been Here Awhile
Posts: 2

Re: CODA-4852 Gateway not receiving WAN IPv6 Address

Rogers' proud support of IPv6 was a big reason I selected them over Bell for my small business needs.  I'm getting conflicting information from business and tech support about IPv6 and  IPv4 dual support for my small business connection.  Could I ask for some community help, please?

Yesterday my CODA-4582 modem was installed and I was given a static IPv4 address, with the modem set as a bridge, but no IPv6 /56 or /64 assigned.


After calls and chats, I was eventually told that

  • I could only have static IPv4 disabled, and
  • get both IPv4 and IPv6 (/56) dynamically assigned.

That doesn't make sense to me at all; I have no troubles assigning static IPv4 and IPv6 addresses within my location's network.   I get the impression that Rogers tech and business support are not reading from the same page.


Does anyone know, please, if there is a definitive IPv6 service page for Rogers?


Can I get both a static IPv4 and a permanent IPv6 /56 or /64 assigned?

I've Been Here Awhile
Posts: 2

Re: CODA-4852 Gateway not receiving WAN IPv6 Address

So I believe I have the definitive answer, albeit one that leaves me a little astonished.


Business static IPv4 is IPv4 only.


It is currently not possible to get IPv4 and IPv6 statically assigned.


Come on, Rogers, IPv6 has been around for 20 years.  You don't sell phone service with "dynamically assigned phone numbers".  I don't have a dynamically assigned house address.  IPv4+NAT was always broken.  There's no excuse for IPv6 to work any way but statically.

I'm Here A Lot
Posts: 7

Re: CODA-4852 Gateway not receiving WAN IPv6 Address

It is curre

@Simon_Clift wrote:

It is currently not possible to get IPv4 and IPv6 statically assigned.

This is shocking.


There's surely no technical reason why you'd need to dynamically assign IPv6 addresses and static assignment is done as a matter of course in at least some other providers I'm aware of (for example, my back-up WAN connection is DSL from ebox and they happily emailed me the /56 prefix that was, automatically, permanently assigned to my account).


Shame, considering I finally got end-to-end IPv6 working, including my DNS filtering server.