cancel
Showing results for 
Search instead for 
Did you mean: 

Ignite tv/internet constant disconnect - error code rdk-03117

Dire
I Plan to Stick Around

We recently got ignite tv and internet and everything was working reasonably well until yesterday. The tv and internet suddenly began to cut out periodically through the day. I would go to the hub unplug it then plug it back in 7 to 10 times. Now today it’s happening again. I get the error code rdk-03117 anyone have a clue as to what it means. Thank you for any help in advance.

 

***EDITED LABELS***

23 REPLIES 23

Re: Ignite tv/internet constant disconnect - error code rdk-03117

RogersCorey
Moderator
Moderator

Greetings and good afternoon!

 

That error is typically related to an outage. If rebooting your modem isn't helping, then that leads me even further to believe there is an outage.

 

If you're still encountering a service interruption, please PM us @CommunityHelps so we can look into it for you. If you're not familiar with our PMing process, you can find instructions here.

 

Regards,

RogersCorey

Re: Ignite tv/internet constant disconnect - error code rdk-03117


@RogersCorey wrote:

That error is typically related to an outage. If rebooting your modem isn't helping, then that leads me even further to believe there is an outage.

I just got home, started watching some recordings on my PVR, and also got RDK-03117.  Had problems accessing Internet sites on my computer and mobile devices as well.

 

I have my XB6 in bridge mode and am using my own router and Wi-Fi mesh.  As @RogersCorey  said, this error is caused by a connectivity problem, often a service outage of some sort.  In my case, it could be due to a problem with my equipment or it could be a problem on the Rogers side.

 

I tried to check the stats on the XB6 but could not log into it.  Restarted my router but that didn't fix the problem; I still cold not communicate with the XB6.  Checked the XB6 modem:  Status light was solid white (normal), unit was still at a normal temperature, but the internal fans were revving at full speed.  Power-cycled the XB6, then restarted by internal network.  Everything went back to normal again.

 

Checked the logs on the XB6 and saw 7 Critical errors where DHCPv6 failed to obtain an IPv6 address earlier this evening.  I don't know to what extent it was even able to communicate over the Cable/WAN link.  Nevertheless, power-cycling the XB6 restored my Internet connectivity.

Re: Ignite tv/internet constant disconnect - error code rdk-03117

nurfwilli1
I've Been Around

error 03117 - since installation. I have logged a ticket today and tech was at my house yesterday to change a wire outside and add some pods but that has not changed the situation.  Every day my system loses complete connectivity, all devices go offline, all tvs stop broadcasting, XB6 modem goes offline and all pods are unreachable. Particularly notice it at night because I am not home or busy much of the daytime.  Wondering if anyone has experienced this and what the resolution was. I used  the phone app to troubleshoot this last night when it happened again, this is where I see that all is offline.  Logged into the XB6 modem today to see the logs and there are no reported errors there. Nothing obvious!

 

Advice welcome!!

Re: Ignite tv/internet constant disconnect - error code rdk-03117

Sounds like a local node... Or maybe the local CMTS, might be having failures and droping out?

But a regular tech can not fix that.. it needs to be escalated up to maintenance.

Re: Ignite tv/internet constant disconnect - error code rdk-03117

oy47
I've Been Around

hi, I've got one tv that is giving a disconnect RDK-03117 error. (This started a few days ago when I inadvertently changed the pwd on my ignite wifi, and it disconnected all devices. I changed the pwd back to the original one, and got all devices back online, except for one TV.) I restarted the XB6 router, but no luck.

 

Any ideas why one device would have a connection problem, but all others seem fine? (btw, got ignite about 5 months ago, and haven't had any issues until now)

 

Re: Ignite tv/internet constant disconnect - error code rdk-03117

-G-
Resident Expert
Resident Expert

@oy47 wrote:

hi, I've got one tv that is giving a disconnect RDK-03117 error. (This started a few days ago when I inadvertently changed the pwd on my ignite wifi, and it disconnected all devices. I changed the pwd back to the original one, and got all devices back online, except for one TV.) I restarted the XB6 router, but no luck.

 

Any ideas why one device would have a connection problem, but all others seem fine? (btw, got ignite about 5 months ago, and haven't had any issues until now)

 


I have seen this error before but could not find any information on that specific X1 error code, not even on the Xfinity support site.  It seems to be part of a family of network connectivity errors but that's not much to go on.

 

(In my case, I saw a bunch of errors in my modem's error log.  Power-cycling the XB6 (followed by the set-top-box after the XB6 came back online) cleared the problem for me.)

 

Are you able to interact with that set-top box in any way?  Can you go to "Settings / Device Settings / Network" and see any helpful messages about the status of your network connectivity there?

 

If that does not work, try to press and hold the Exit button on the remote for three seconds, then key in: "Down Down 2" and you should see a information screen.  Does that work and do you see any problems listed in either the Summary or WiFi Details section?  (Press "Exit" to exit this info screen.)

 

I have no idea why only one set-top box would be affected.  If you cannot interact with the box and also do not experience any problems with any other set-top box, I would try to reset and reconnect to Wi-Fi.  You may need to press the WPS button (the concave depression) on the bottom of the set-top box and follow the on-screen prompts to initiate the pairing that way.  (Warning: Pressing that button and proceeding will reset the box's Wi-Fi connection and you will need to successfully reconnect to Wi-Fi to regain network connectivity.)

Re: Ignite tv/internet constant disconnect - error code rdk-03117

-G-
Resident Expert
Resident Expert

This morning, I got the RDK-03117 error on my set-top box:

Please give us a minute...

There seems to be a connection issue here.  Sorry about that.  We'll try to resolve the issue on our side.  In the meantime, please check that your Gateway, modem, or router connection is tightly secured.  If the problem persists, try restarting your WiFi device.

RDK-03117


I power-cycled the set-top box and could watch TV again... but something wasn't quite right.

I checked my network: IPv6 connectivity was broken.

I checked the modem; the firmware had updated overnight.

I reset my XB6 and network gear (and confirmed that my network was working properly again) and then reset my set-top box once more.  Everything has been working fine since then.

Re: Ignite tv/internet constant disconnect - error code rdk-03117

iantweedle
I've Been Here Awhile

Hello:

 

Approximately 2 weeks ago our modem was replaced as it was getting so hot you couldn't touch it.  Since then most of our Rogers services in the house have gone wacky.  We've had several technicians out the house to reconfigure the system that was installed.

 

We've had technicians check the main box outside our house to make sure everything is fine, they've checked that the main line coming into the house in fine, they've removed and reconnected the white boxes located throughout our house, they've wiped the modem connection and re-established it.

I've called Rogers nearly a dozen times in the last 2 weeks because of consistent issues with our wi-fi, modem, tv, and home phone.

 

Now the latest issue is our tv boxes.  At random times the picture will freeze and an error code will come on saying that it cannot connect to the Gateway modem and that I should check the connection; if everything is fine then I should restart the modem.  Then it gives me the error code RDK-03117.

 

This happened twice to one tv box on November 7 and once on another tx box the same night.  In all 3 instances, the tx boxes were unplugged and then plugged back in.  After some time everything seem to be okay until it happened again.  The same procedure was done and moments later it happened again.  This time we unplugged the power from the modem and waited 15 seconds, then plugged the power back in.  Everything was fine until the next night.

 

The following night the picture froze then a white circle appeared, then the white circle froze.  I called Rogers and spoke with technical support for the tv.  They rebooted the modem and the tv box that was having issues.  They detected no issue.  After hanging up, I unplugged the tv box that was having issues and plugged it back in.  After it rebooted the issue went away.  Less than an hour later the tv froze and the error message from the previous night appeared.

 

I have read many message posts on this forum that all say the same thing.  Just reboot the modem.  But honestly, is this something that Rogers expects it's customers to do EVERY NIGHT?!  Am I expected to reboot the modem LITERALLY EVERY NIGHT?  I don't think so.  In 9 months since we got the new service we never had any issue.  Since Rogers replaced the old modem (due to heat issues) we've had nothing but errors.

 

I am getting real tired of calling Rogers each time there is an issue which is happening more and more often.  It is also disgusting that with all these service issues and outages Rogers does not offer any compensation for the lack of service.  The fact that I am expected to pay full price when I cannot use my internet, tv or home phone during hours or days of service is beyond stupid.

 

I would appreciate any help that someone can give me.  To give further information on the tv box that is having issue, the tv box is approximately 10 feet away from the gateway modem, the tv box shows 3 full bars of service connection to the modem and no other device (phone or tablet) looses connection during this time.  As it is, I am on my desktop computer typing this and the tv box is in the same room (also 10 feet away from the desktop computer) and the tv box is still frozen.

Re: Ignite tv/internet constant disconnect - error code rdk-03117

-G-
Resident Expert
Resident Expert

@iantweedle wrote:

Approximately 2 weeks ago our modem was replaced as it was getting so hot you couldn't touch it.  Since then most of our Rogers services in the house have gone wacky.  We've had several technicians out the house to reconfigure the system that was installed.

Welcome to the Community!

 

I have see this error a few times before and in all cases, I was able to resolve it by restarting the Ignite modem by power-cycling it.  (RDK-03117 has also been discussed here as well.)  It seems to be caused by a network glitch on Rogers side, likely stemming from overnight maintenance work/configuration changes, not a signal issue, but I can't really confirm this.  The Comcast Xfinity support site has a page describing RDK-03117 but that link does not work for me.

 

Now the latest issue is our tv boxes.  At random times the picture will freeze and an error code will come on saying that it cannot connect to the Gateway modem and that I should check the connection; if everything is fine then I should restart the modem.  Then it gives me the error code RDK-03117.

 

This happened twice to one tv box on November 7 and once on another tx box the same night.  In all 3 instances, the tx boxes were unplugged and then plugged back in.  After some time everything seem to be okay until it happened again.  The same procedure was done and moments later it happened again.  This time we unplugged the power from the modem and waited 15 seconds, then plugged the power back in.  Everything was fine until the next night.

 

The following night the picture froze then a white circle appeared, then the white circle froze.  I called Rogers and spoke with technical support for the tv.  They rebooted the modem and the tv box that was having issues.  They detected no issue.  After hanging up, I unplugged the tv box that was having issues and plugged it back in.  After it rebooted the issue went away.  Less than an hour later the tv froze and the error message from the previous night appeared.


Ignite TV is a live streaming service.  For the TV service to work well, your Internet service needs to work well and your in-home network needs to work flawlessly.  If you ever see freezes or drop-outs in your picture, it is because the Ignite set-top box did not receive media stream data in time, either because that data got lost/delayed or because you did not have enough available network bandwidth.  The STB basically ran out of data to process when it needed to process it and (momentarily) had no video to display.

 

I have read many message posts on this forum that all say the same thing.  Just reboot the modem.  But honestly, is this something that Rogers expects it's customers to do EVERY NIGHT?!  Am I expected to reboot the modem LITERALLY EVERY NIGHT?  I don't think so.  In 9 months since we got the new service we never had any issue.  Since Rogers replaced the old modem (due to heat issues) we've had nothing but errors.

 

I am getting real tired of calling Rogers each time there is an issue which is happening more and more often.  It is also disgusting that with all these service issues and outages Rogers does not offer any compensation for the lack of service.  The fact that I am expected to pay full price when I cannot use my internet, tv or home phone during hours or days of service is beyond stupid.


I have only had to power-cycle my Ignite modem once every few months to resolve problems.  You DEFINITELY should not have to reset equipment your every day.

 

I would appreciate any help that someone can give me.  To give further information on the tv box that is having issue, the tv box is approximately 10 feet away from the gateway modem, the tv box shows 3 full bars of service connection to the modem and no other device (phone or tablet) looses connection during this time.  As it is, I am on my desktop computer typing this and the tv box is in the same room (also 10 feet away from the desktop computer) and the tv box is still frozen.


The problem with WiFi is that while it is important for a WiFi device to have a good, strong connection to the network, its performance will be SEVERELY degraded if there are other WiFi devices that actively transmit/receive data over poor connections.  All devices on a WiFi channel share airspace and airtime (including those not on your network but also using the same channel) and if a device is hogging airtime on that channel (transmitting or receiving data) ALL other devices on that channel will suffer because they cannot transmit or receive data until the channel is clear.

 

Are all WiFi devices connecting to the Ignite gateway directly or are you using Pods to extend your WiFi coverage?

 

 

You can also check the quality of your Internet service by logging into your XB6 gateway with a web browser (go to http://10.0.0.1 ).  First, check the "Rogers Network" Connection stats.  If the Rogers techs told you that your modem stats look good, your power levels and SNR stats are probably fine.  However, go to "Gateway > Connection > Rogers Network" and check the "Uncorrectable Codewords".  Ideally there should be zero (or close to zero) of these errors across all channels.  However, it is especially important to check the Downstream DOCSIS 3.1 OFDM channel; It's usually the last column.  It is totally okay for this to have a HUGE number of correctable errors but it should have few (if any) uncorrectable errors.  If you see a lot of uncorrectable errors across ALL channels, this needs to be investigated by Rogers.

Also, go to "Troubleshooting > Logs" and display the Events log for the "Last week".  I don't have anything logged in mine.  If you are seeing any Critical errors, this needs to be investigated by Rogers.

 

 

As for RDF-03117, it's probably happening because there is a problem with your IPv6 network connectivity.  You can verify this with one of the following test sites:

https://test-ipv6.com

https://en.internet.nl/test-connection/

https://ipv6-test.com

 

 

Lastly, I would also try connecting the set-top box (that is 10 feet away from your Ignite modem) using an Ethernet cable.  If the video drop-outs go away, you (most likely) have WiFi issues in your home that need to be identified and resolved.

Re: Ignite tv/internet constant disconnect - error code rdk-03117

iantweedle
I've Been Here Awhile

Thank you for your reply.

 

Each time I have an issue with the tv/internet I call Rogers and they do a cycle through on the modem.  So in the last 2 weeks they've done it 9 times.  That cycle makes everything work again for about 2-3 days before it drops out again.  I can try doing a cycle of the modem but since it only lasts for a few days it seems pointless to keep doing it every few days.

 

When the system was first installed we had 4 pods placed in the house.  When our modem was swapped out on October 22, the technician didn't bother to hook up the pods and that's when we had issues.  Another tech was sent to hook up the pods and they removed 2 and kept 2.  Since then we have issues in the house where there are no pods.

 

The other issue I have with the pods is that no one at Rogers has the same answer about the pods.  Everyone I speak to has a different answer.  Both technicians that came to our house told us "pods are horrible .. don't know why Rogers has them .. they are stupid".  Yet when I call in with internet/tv issues, the people I speak with on the phone tell me pods are necessary.  I've been told that pods help extend the wifi coverage to the pods cause interference and restrict wifi coverage to the pods do absolutely nothing and that everything connects to the gateway regardless if the pods are connected or not.  It sounds like no one at Rogers actually knows what the pods do.

 

The gateway used to have a google home located next to it.  One technician to our house told me that no device should be in the room as the gateway modem.  They told me to move the google home directly out of the room and put it in another room.  The issue is, the google home is in that room for a reason so now it's making things more difficult having it in another room.  That tech also told me that having a tv in the room with the modem also causes interference so I need to consider moving the tv.  They told me that all technology will have an impact on the gateway working properly.  My question to that is, if all technology has an impact on the gateway working properly then why give it to customers if it doesn't work with devices near it?  Sounds odd to have something that controls everything in your home and yet other devices can make it not work.

 

I tried going to the log in for the gateway modem but it asks for a username and password and I don't know what that would be.  Rogers never gives that information to us.  When the devices were installed we received no information on how to use the devices.

 

I do think that a lot of the issues we have relate back to the main junction box on our boulevard.  Around the time that we started having issues, there was a Rogers tech that did work on the junction box and then went down the side of our house where the main Rogers line comes in and started banging with tools.  There was no Rogers technician scheduled to be at our house (for that day or anyday) and when I called Rogers they had no record (that day or going forward) of any Rogers tech doing work on the junction box.

 

I am just getting tired of things constantly not working.  I understand that the modem is the main device that connects everything but honestly, I shouldn't have to unplug the main power line from it on such a regular basis.  I also don't like that the gateway box gets so hot all the time.  I've been told it should get warm but never hot.  The previous one and this one get to the point that I have to unplug them to let them cool down.  It scares me how hot it gets.

Re: Ignite tv/internet constant disconnect - error code rdk-03117

-G-
Resident Expert
Resident Expert
@robcolburn wrote:

No biggest mistake I have made. We are always losing the signal and they can't seem to fix it and their customer service is truly awful


The other thread is not really the right place to troubleshoot Ignite TV issues so I'm posting a response here as well.  Are you only seeing problems with Ignite TV or are all devices on your network experiencing connectivity issues?  What about devices that are directly connected to the modem with an Ethernet cable?  Do you have Ignite WiFi Pods installed and if so, what guidance were you given as to where to place your Ignite modem/gateway and where to install your Pods?  As I said in my reply, there is no reason why Ignite TV should not work flawlessly.  However, in order for Ignite TV to work well, your Internet service needs to work well, your in-home network needs to work well, and all WiFi devices on your network need to have good, strong connections -- including your Pods, and they need to have good, strong connections not only to the WiFi clients that connect to them but also (more importantly) to the Ignite gateway as well.

Re: Ignite tv/internet constant disconnect - error code rdk-03117

 

I'm having similar issues.   Ignite was rock solid till about 3 weeks ago. No replacement of gateways but same error and same intermittent wifi drops/errors.  I have lost all services (TV, internet and home phone) at times but it's mostly TV outages.  Our neighbours also have Ignite and had outages at the same time as we did.  Cables to our home were changed.  Techs have diagnosed the issue as a infrastructure issue (cables or boxes feeding our green box).  I have a case # but no date on when this will be resolved. I'm getting annoyed as well with these outages.   Different topic but I'm frustrated with how the FFWD and PVR controls work.  It feels like Ignite is a work in progress.  😞

 

Bob

Re: Ignite tv/internet constant disconnect - error code rdk-03117

Rogers must have known I was sending this note, just as I posted it the TV froze and is out
😞

Re: Ignite tv/internet constant disconnect - error code rdk-03117

RonRodrigues
I've Been Around

We hopefully just found the answer to our Ignite TV disconnection every 15-18 minutes.  The Router Box was placed too close to the TV.  We moved it at least three feet away and our TV hasn't disconnected in over 45 minutes.

 

Re: Ignite tv/internet constant disconnect - error code rdk-03117

iantweedle
I've Been Here Awhile

UPDATE:

 

Everything finally got sorted out.  Only took 5 more technicians coming to our residence to clear things up.  Each time the technician would reinstall everything that had been installed in our residence.  Everything would work for a week then stop.

 

The solution in the end was to replace EVERYTHING, which is what I had asked the first time.  After everything had been replaced, all the known issues have stopped.

Re: Ignite tv/internet constant disconnect - error code rdk-03117

Is not an outage. I have 2 tv boxes, only one is behaving like this and gives this error. Average restarting per day for this tv box is 10 times. The other tv box I have doesn't act like this. I can't replace it x Roger doesn't replace it (due to logistic and technician needs to come home pick up old one and drop off the new one). That's not gonna happen for a 8$ / month. Honestly you guys have the worst TV services. Anyway....

Re: Ignite tv/internet constant disconnect - error code rdk-03117

@Cabernet2021 The Comcast Xfinity support site does not list any cause for RDK-03117, so I have no idea what that error really means.  I have only seen it (likely) as a result of networking issues/changes/maintenance on the Rogers network in my area, and fixed it by restarting my Ignite gateway followed by my set-top boxes.  In my case, other devices on my network also had issues with semi-broken Internet connectivity as well, not just my set-top boxes, and everything worked fine again after resetting the modem/gateway.

Re: Ignite tv/internet constant disconnect - error code rdk-03117

icanuck
I've Been Around
Not exactly the same problem as mine is a new setup, but may shed some light on the problem if perhaps someone or an update modified your WiFi router settings. The box here would give the same 03117 code and not connect. A quick Google of the error code mentioned IPv6. So for a lark, I checked my routers network settings and IPv6 was not enabled. Enabling it then restarting the tv box resolved the problem.

Re: Ignite tv/internet constant disconnect - error code rdk-03117

Theatreman
I've Been Here Awhile
My ignite tv boxes have lately been a frequent problem due to signal problems. I even got the wifi pods and put one on every level of the house, to Rogers specifics in terms of leaving open space and away from metal furniture. I check my phone and laptop and the signal is strong but the tv box keeps showing signal issues. My wifi pods randomly go off line everyday also.

I can’t get a love agent on the phone. Have waited on hold and average of 1.25 hours each time I call before hanging up. I’m floored with how bad this service is.

Re: Ignite tv/internet constant disconnect - error code rdk-03117

-G-
Resident Expert
Resident Expert

@Theatreman  Are you seeing problematic connectivity from any device that is connected to a Pod?  What speed test results are you seeing when connected to a Pod?

 

Where is the Ignite modem/gateway located?  If you unplug your Pods, go to the locations where your Pods had been plugged in, and connect directly to the Ignite gateway from a mobile device, are you able to get a good connection from that location?  If you can only get a marginal connection, you will need to find a better location to place your Pods that is closer to the Ignite gateway.

 

Pods are only useful if they have a good strong connection to both the Ignite gateway and to the devices that connect to them.

Topic Stats
  • 23 replies
  • 24384 views
  • 9 Likes
  • 14 in conversation