Slow Speeds on XB7

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Nimec
I've Been Around
Posts: 1

Slow Speeds on XB7

Hi all,

 

We recently switched from Rogers from Bell Aliant here in NB after a door-to-door Rogers salesman offered us a package at a price that was more than $160 cheaper/month than we were paying for FibreOP. Our home is only 3 years old and had no prior coax so he had to run all new lines inside and out, so everything is brand new.

 

Our package includes gigabit internet but I have been unable to climb higher than ~520mbps with a Speed Test to Moncton.  That only happened a few times, most of the time it is under 500, +/- 450mbps on average. With our Bell plan we had 500 download and always hit 510/520 on every single speed test, so it is a bit concerning that with a plan that is supposed to be twice as fast our actual in home speed has gone down. (I understand Fibre to the home is a superior technology but still figured if gigabit was advertised over 500 should be possible)

 

Searching these forums this seems to be a common issue so I'm worried that maybe there is not much I can do but figured I would reach out anyways.  On the Troubleshooting post it says:

 

  • Downstream Overview: A total of 32 channels should be here with an expected Signal Strength (dBmV) between -13.5 and 12 and an SNR above 38dBmv.

I am using the XB7 (I think, tall white square tower looking router).  I wasn't able to see anything about DOCSYS but under Connection -> Rogers Network when I go down to the Downstream table there are only 24 "Indexes", and then 2 after numbered 33&34 that have NA values for Power Level and SNR so I assume they aren't being used.

 

Am I supposed to have 32 here? Could this be a reason for a loss of speed?

 

Copy & Paste isn't working properly, it is saying the table labels are invalid HTML, sorry if it's hard to read. The values listed below top to bottom are:

  • Index, Lock Status, Frequency, SNR, Power Level, Modulation
Downstream
Channel Bonding Value
7
1
2
3
4
5
6
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
 
33
34
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
 
Locked
Locked
591 MHz
555 MHz
561 MHz
567 MHz
573 MHz
579 MHz
585 MHz
597 MHz
603 MHz
609 MHz
615 MHz
621 MHz
633 MHz
639 MHz
645 MHz
651 MHz
657 MHz
663 MHz
669 MHz
675 MHz
681 MHz
687 MHz
693 MHz
699 MHz
 
350000000
723000000
39.4 dB
40.4 dB
38.5 dB
38.1 dB
38.2 dB
38.8 dB
39.2 dB
39.6 dB
39.5 dB
39.3 dB
39.5 dB
39.3 dB
38.6 dB
38.2 dB
38.3 dB
38.8 dB
39.1 dB
39.3 dB
39.4 dB
39.1 dB
39.9 dB
39.9 dB
39.9 dB
39.5 dB
 
NA
NA
6.7 dBmV
8.5 dBmV
4.9 dBmV
4.1 dBmV
4.6 dBmV
5.4 dBmV
6.3 dBmV
6.9 dBmV
6.9 dBmV
6.5 dBmV
6.6 dBmV
6.3 dBmV
5.3 dBmV
4.4 dBmV
4.6 dBmV
5.2 dBmV
5.8 dBmV
5.9 dBmV
6.2 dBmV
6.7 dBmV
7.3 dBmV
7.4 dBmV
7.4 dBmV
7.2 dBmV
 
NA
NA
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
 
OFDM
OFDM
 

 

Same as above, not posting labels correctly, they are:
  • Index, Lock Status, Frequency, Symbol Rate, Power Level, Modulation, Channel Type
Upstream
Channel Bonding Value
1
2
3
4
Locked
Locked
Locked
Locked
18 MHz
23 MHz
30 MHz
36 MHz
2560
5120
5120
5120
40.0 dBmV
41.5 dBmV
41.8 dBmV
41.5 dBmV
QAM
QAM
QAM
QAM
TDMA_AND_ATDMA
ATDMA
ATDMA
ATDMA
 

Other than that is there anything else I can try to improve my speeds?

 

Thanks all, have a great day.

RogersTony
Moderator
Moderator
Posts: 1,289

Re: Slow Speeds on XB7

Hello, @Nimec

 

Welcome to Rogers and to our Community Forums, we're thrilled to have you as a customer!

 

I can imagine how disappointing it is to see that your speeds are only half of where they should be. We definitely want to investigate this for you and try to find a solution.

 

Can you provide us with a bit more information:

 

  • Are you performing your speed testing using a device connected via Ethernet with all other devices disconnected from the modem?
  • Can you confirm what tool you are using to test the speeds?
  • Have you attempted any troubleshooting steps as of yet such as a reboot of the modem?

We look forward to hearing from you.

 

RogersTony

dmfan
I Plan to Stick Around
Posts: 29

Re: Slow Speeds on XB7

My own experience with Speedtest depends on a few things.

1) the test server - they vary a lot from time to time, and often there is a huge gap between servers.   I find that sometime the difference is 200 mbps.  Crazy, right?  After all these years, I have found several servers that give me good readings, and I keep going back to them for testing.

2) Your own machine.  Other than the network card and wireless adapter, I find that the CPU power also makes a difference.  I don't know the inner workings of Speedtest so I don't know why that would be the case.  But on my own network, between different machines connecting to the modem via ethernet, the Speedtest difference can be 200 - 300 mbps.

My best test is using my 1-month old Asus ROG laptop via ethernet.  I can get 200 mbps above my subscription package's speed.  I feel lucky that my area gives me that.

-G-
Resident Expert
Resident Expert
Posts: 2,468

Re: Slow Speeds on XB7

@Nimec  Is your computer directly-connected to the XB7 gateway or are you using your own router with Bridge Mode enabled on the XB7?



Datalink
Resident Expert
Resident Expert
Posts: 7,372

Re: Slow Speeds on XB7

Ok, in a nutshell, the signal levels are a little high on both downstream and upstream sides.  There are only 24 QAM downstream channels running, which is a little odd, but in NB, maybe that's normal.  The two OFDM downstream channels aren't running.  Normally there should be at least one channel running, but, I've seen two running on east coast modems.  Running a single OFDM channel should provide gigabit service without any problem.  Two will definitely provide gigabit service.  So, the question is, for your Cable Modem Termination Service (CMTS), which the modem is connected to, is there one or two OFDM downstream channels running off of the CMTS?  If the answer to that is yes, then the modem can't process the OFDM channels which points to a signal issue within the bandwidth of the OFDM channels.  I suspect that the lower OFDM channel should be enabled, but, you would need tech support to tell you what the CMTS is configured for.  The first line techs that you chat with only have a single line data overview of the OFDM channel.  @RogersAndy has a secondary data display that breaks down the OFDM channel into sub-channels, which is useful for diagnosing problems.  Andy might have to have a look at your modem signal levels to sort this out.  

 

Also note, there is no data posted for an OFDMA upstream channel, which should also be present.  Maybe its there but the data isn't posted?

 

The observation of flipping the modem back into its default gateway mode and running tests with an ethernet connection directly with the modem is definitely valid.  I'd recommend doing that just to see what turns up in the speedtests. 

 

 



Draconix
I Plan to Stick Around
Posts: 14

Re: Slow Speeds on XB7

I have also been experiencing slower than expected file download speeds on my new XB7. I had much higher speeds on my previous CODA-4582 modem which definitely had OFDM enabled. Here are my modem stats, could you tell me if my XB7 has OFDM working? If it's not then maybe that could explain my slower download speeds after switching from the CODA.

 

7
1
2
3
4
5
6
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
Locked
591 MHz
279 MHz
849 MHz
855 MHz
861 MHz
579 MHz
585 MHz
597 MHz
603 MHz
609 MHz
615 MHz
621 MHz
633 MHz
639 MHz
645 MHz
651 MHz
657 MHz
663 MHz
669 MHz
675 MHz
681 MHz
687 MHz
693 MHz
699 MHz
705 MHz
711 MHz
717 MHz
723 MHz
825 MHz
831 MHz
837 MHz
843 MHz
350000000
43.3 dB
42.0 dB
42.5 dB
42.4 dB
42.8 dB
43.0 dB
43.3 dB
43.6 dB
43.2 dB
43.5 dB
42.8 dB
43.5 dB
43.7 dB
43.0 dB
43.1 dB
43.0 dB
43.2 dB
43.1 dB
43.5 dB
41.9 dB
43.4 dB
43.1 dB
43.4 dB
43.6 dB
43.6 dB
43.3 dB
43.3 dB
43.1 dB
42.5 dB
42.5 dB
42.5 dB
42.3 dB
NA
5.2 dBmV
3.8 dBmV
4.9 dBmV
4.0 dBmV
4.7 dBmV
4.4 dBmV
5.6 dBmV
6.3 dBmV
5.2 dBmV
6.1 dBmV
5.1 dBmV
5.9 dBmV
6.1 dBmV
4.7 dBmV
5.3 dBmV
4.3 dBmV
5.1 dBmV
4.6 dBmV
5.6 dBmV
4.6 dBmV
5.4 dBmV
4.6 dBmV
5.4 dBmV
5.4 dBmV
5.7 dBmV
5.0 dBmV
5.7 dBmV
4.9 dBmV
5.3 dBmV
4.2 dBmV
4.9 dBmV
3.8 dBmV
NA
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
256 QAM
OFDM

 

1
2
3
4
Locked
Locked
Locked
Locked
21 MHz
25 MHz
32 MHz
38 MHz
2560
5120
5120
5120
35.5 dBmV
37.3 dBmV
38.5 dBmV
39.0 dBmV
QAM
QAM
QAM
QAM
TDMA_AND_ATDMA
ATDMA
ATDMA
ATDMA
-G-
Resident Expert
Resident Expert
Posts: 2,468

Re: Slow Speeds on XB7


@Draconix wrote:

I have also been experiencing slower than expected file download speeds on my new XB7. I had much higher speeds on my previous CODA-4582 modem which definitely had OFDM enabled. Here are my modem stats, could you tell me if my XB7 has OFDM working? If it's not then maybe that could explain my slower download speeds after switching from the CODA.


That's strange.  I just checked my XB6 and it also shows NA in the Power and SNR stats on the downstream OFDM channel.  However, my "CM Error Codewords" stats are still incrementing so that channel appears to be active.



Draconix
I Plan to Stick Around
Posts: 14

Re: Slow Speeds on XB7

The original post at the top also shows NA on his two OFDM channels and Datalink replied saying that the OFDM downstream channels aren't running, so I assumed that my OFDM isn't running either. It would also explain why my download speeds decreased since switching from the CODA which I'm 100% sure had OFDM enabled.

-G-
Resident Expert
Resident Expert
Posts: 2,468

Re: Slow Speeds on XB7

@Draconix  Send a PM to @CommunityHelps  and ask them to double-check the signal to your modem and stats on your local node and CMTS.



Datalink
Resident Expert
Resident Expert
Posts: 7,372

Re: Slow Speeds on XB7

Its possible that a recent firmware update has nuked the user interface data for the OFDM channels.  Its a little odd that the signal level and SNR isn't present while the counter updates.  Only way to find out is to get the moderators @CommunityHelps to check the OFDM data from their end to determine if the OFDM channel is running correctly.  @Nimec @Draconix follow that link for @CommunityHelps when your logged into the forum.  That takes you to the public page for the mods, and then follow the link to "Send this user a private message".  Include the MAC address from the modem so that the mods can find the modem and check the data. 

 

Other food for thought:  Consider pulling the power from the set top boxes, disabling both wifi channels and then reboot the modem.  After the reboot, run a few speedtests and download test to see what the result is without any external data usage.  In theory it shouldn't make a difference, but, one can never assume that will be the case.  See what the data says......