cancel
Showing results for 
Search instead for 
Did you mean: 

Rogers IPv6 Status

foodgodessto
I've Been Here Awhile

Hello,

 

I'm wondering what the current IPv6 status is within Rogers.  A search on the forums only shows 10 topics over the past year that even mention IPv6, and there doesn't appear to be any official communications from Rogers since IPv6 day last year.

 

I know that Rogers (supposedly) supports IPv6 tunneling (although the only person to ask about it did not get any responses).

602 REPLIES 602

Re: Rogers IPv6 Status

JKnott
I'm a Reliable Contributor

Based on what you say, Rogers is providing IPv6, but the router is not passing it.  Rogers uses something called DHCPv6-PD, which not only provides an IPv6 address for the router, but also the prefix for your LAN.  So, either your router doesn't support DHCPv6-PD or it's misconfigured.  The fe80 link local addresses are essential for IPv6 to work properly, but will not work beyond the local LAN.  For example, with IPv6, your gateway address will likely be a link local address, even though it may have a public address.  On this computer, my default gateway address on IPv6 is fe::1:1, even though it also has an address that begins with 2607.

 

When your router is working properly with DHCPv6-PD, it will announce the LAN prefixes to all devices on the LAN.  The devices will then take that prefix and create a host address, using either the MAC address or a random number.

 

Re: Rogers IPv6 Status

JKnott
I'm a Reliable Contributor

@Datalink wrote:

Fwiw, with IPV6 running, if you go to www.speedtest.net and use the Rogers servers to run a speedtest, that test runs using IPV6 addressing.


The Mississauga server is no longer in operation.  That was the one closest to me.

Re: Rogers IPv6 Status

Just reporting back.. ipv6 looks to be working fine with my Google Wifi now. Now sure when it started working, but I checked it today and it's good. Possibly thanks to a firmware update (not sure since they're automated on Google Wifi)

Re: Rogers IPv6 Status

Junker2
I've Been Here Awhile

Thanks. Problem solved. Here's how.

Reminder: Arris XB6 for Ignite service, Asus GT-AC5300 router (stock)

Was originally using my traditional internal ip addresses - changed Rogers modem local ip to 192.168.0,x and subnetted my router to 192.168.1.x. Rogers ships the XB6 with 10.0.0.1 default addresses. Direct connection to it gets ipv6 connectivity. Converted Asus to 10.0.1.x with native ipv6 - nothing.

In the spirit of try anything, i changed the Asus to ipv6 passthrough - it worked. ipv6-test.com score went to 17 first try. 

DMZd router and it still works - stable for @3 days now. Ipv6 firewall enabled on both devices

Re: Rogers IPv6 Status

ASUSWRT supports “IPv6” after firmware version—“3.0.0.3.78”

 

The setting mentioned here with ASUS is wrong, since roger's router is using Automatic IP, the setting for IPv6 on ASUS routers should be "Passthrough" instead of "Native".

Re: Rogers IPv6 Status

@TomasLee don't know why you indicate that Passthrough mode should be the operating mode for Asus routers.  That reference to Asuswrt Version 3.0.0.3.78 is for a version that is 6 years old.  Asus has long since moved on from that version and has rewritten its firmware, so I would completely discount the reference to using Passthrough mode.  Checking latest versions, for example: 

 

RT-AC68U Version 3.0.0.4.385.20433 Released April 14 2020
RT-AC86U Version 3.0.0.4.384.81792 Released April 14 2020

 

Check the latest version released for your router model.

 

Native IPV6 is what Rogers has developed and this is used across multiple routers and multiple operating systems.  

 

At the present time I have one of my routers running Merlin's Asuswrt, running Native IPV6 without any problems, as have others.  

 

To run IPV6 on an Asus router you have to set up IPV6 as follows:

 

Connection Typs:  Native

DHCP-PD:  Enable

Release prefix on exit:  Enable

 

Auto Configuration Setting:  Stateless or Stateful    (Stateful works now.  It didn't for a very long time)

 

Connect to DNS Server Automatically:  Enabled or Disabled as per your preference

 

If you disable that setting, you will see the three IPV6 DNS server address entry windows.  Enter the addresses as required.  

 

 

Enable Router Advertisement:  Enabled or Disabled as per your preference. 

 

Apply the setting and reboot the router.  When all is said and done you should end up with the router running Native IPV6. 



Re: Rogers IPv6 Status

JKnott
I'm a Reliable Contributor

"Release prefix on exit"

 

Are you sure you want to do that?  If you do that, your prefix can change, which means all your addresses will be different and it makes it impossible to use a DNS server to point to your devices.  There is a similar setting with pfSense and I set it to not release.

 

Re: Rogers IPv6 Status

I can be convinced to use either setting.  I think that might be the default for Merlin's Asuswrt, but, don't quote me on that one. 



Re: Rogers IPv6 Status

JKnott
I'm a Reliable Contributor

If all you're doing is going out to the Internet, it makes no difference.  However, if you want to access things on your network by host name, then you'll want addresses that stay put.  The same is true if you want to access your network from elsewhere, such as with a VPN, etc..  If your address can change, you'll find yourself locked out.  I found out about this when I discovered that simply disconnecting/reconnecting the Ethernet cable to the modem was enough to cause my prefix to change.

 

Re: Rogers IPv6 Status

Longpar3
I Plan to Stick Around

Is there updated settings for routers from Rogers  for IPV6? I am looking for Asus settings for rogers? 

Re: Rogers IPv6 Status

Longpar3
I Plan to Stick Around

I called rogers twice and they had no information on what to put in a ASUS router to make it work. 

Currently I have :
Internet Connection type = Native

DHCP PD = ENABLE

Auto Conf Setting = Stateless

Connect to DNS Server Auto = Enable

Enable Router Adv = Enable

 

This did give me IPV6 service but no IPV4 at all and very slow surfing the net. Any thoughts? Router model RT-AX88U Asus.

Re: Rogers IPv6 Status

@Longpar3 running stock firmware or Merlin's Asuswrt?  Your settings look correct, but, typically you have to reboot the router after setting it up for IPV6.

 

Reboot both modem and router.  Pull the power for the modem, wait for about 15 seconds and plug it back in.  While the modem is rebooting, reboot the router.  The end result should be IPV4 and IPV6 to and through the router when the modem and router reboot cycles are complete.   

 

The modem is running in Bridge mode, correct?



Re: Rogers IPv6 Status

Longpar3
I Plan to Stick Around

Datalink

 

I have a DOCSIS® 3.0 Cable Modem Aris, Surboard SB-6141 modem. I guess I will have to figure how to log in to it to see if it's in bridge mode. 

 

My firmware on the RT-AX88u from Asus is from Merlin 384.17 . I believe it's the latest. I had to turn a bunch of options off to make it consistently connected, such as Beamforming, but that another issue. It's been pretty good so far.

When I originally tried the setting I had I did get very slow speeds for IPV6 and no Ipv4 service, but I did not reboot modem only router. I will try rebooting both. If that doesn't work I will figure out how to login to Modem and put into bridge mode.  

Re: Rogers IPv6 Status

@Longpar3 my first question at this point is how are you running a Surboard SB-6141 modem?  Rogers usually doesn't allow private modems to run on the network.  Did a Rogers agent at a Rogers store or did someone at tech support manage to register that modem on your account?  Just wondering at this point how you even got to this point with that particular modem?  

 

The internet plan cost comes with a built in modem cost for what ever modems are eligible for your particular internet plan.  The installation tech should have installed an appropriate modem or Rogers should have sent you a modem via courier.  Thats the modem that you should be using.  



Re: Rogers IPv6 Status

JKnott
I'm a Reliable Contributor

"I guess I will have to figure how to log in to it to see if it's in bridge mode."

 

What WAN address do you get?  If in one of the RFC1918 blocks, the modem is in gateway mode.  If a public address, it's in bridge mode.

 

Re: Rogers IPv6 Status

Longpar3
I Plan to Stick Around
Well at the time I had a 100u internet package from Rogers and I asked them what modems they support. Then I bought one and went to a store to register it, they config it from distance and that was it.
I did some research and this particular modem doesn't have a bridge function as it has no internal router function. I made the changes tonight on my Asus router and rebooted both the modem and router as u said and it seem to work. So far so good. I got ipv6 and ipv4 functional. Test the speeds and ipv6 is slightly faster.
Thank you for your help !

Re: Rogers IPv6 Status

Longpar3
I Plan to Stick Around
Well I had a100u internet package at the moment and asked for what routers they supported and they told me. I bought one and went to a store to register it. Once I got it home they activated from distance and that was it. It's been pretty reliable piece of equipment. I now have a 300u package, 500u will require their router, haven't seen very much positive feedback of that router/modem they use so I'll hold on to a 300u package with my modem and get 350 down and 20 up.

I looked into the modem tonight and found out it has no router capabilities so it acts like it's in bridge mode all the time. I made the changes to the router and rebooted the modem and then rebooted the router and it worked. I tried a speed test and it looks like ipv6 is a bit faster then ipv4.
Appreciate your help on this matter, too bad rogers doesn't post these settings somewhere on there site so people could config their routers right. I guess most use the internal routers in the Roger supplied modems maybe.
Thanks again!

Re: Rogers IPv6 Status

Stretch
I've Been Here Awhile

If you are using pfSense and have multiple LANs, you'll want to ask for a larger prefix.

 

I set the DHCPv6 Prefix Delegation Size to 60 and check the "Send IPv6 prefix hint" checkbox. Then for each LAN where I want IPv6, on the relevant interface I set the IPv6 Configuration Type to "Track Interface", in the "Track IPv6 Interface" section I set the IPv6 Interface to the interface connected to the Rogers modem, and choose a different IPv6 Prefix ID for each LAN.

Re: Rogers IPv6 Status

JKnott
I'm a Reliable Contributor

Rogers can provide a /56, which means you get up to 256 /64s.  A /60 will only get 16.

Re: Rogers IPv6 Status

clarenceb5
I've Been Here Awhile

I've been reading through this thread and wow lots of knowledgeable people here.  So maybe someone here will have the experience I'm in search of.  I recently have upgraded to Gigabit internet speeds but I'm unable to configure my existing router to get the speeds provided.  So I'm wondering if anyone here has any experience or knowledge configuring a TP-Link R600VPN router with Gigabit internet? I get full speeds using Rogers router but can't get more than 400-450 mbps downstream on my R600VPN with modem in bridge mode.  I found the post earlier in this thread showing the configurations to use for IPv6 but still no luck with speed improvements.  Is this a case of my router is simply not capable of Gigabit speeds?  I get 1000 mbps connectivity between my router and PC and the router even reports that the connection between the WAN port and the modem is 1000 mbps.  Crossing my fingers I've come to the right people.

 

Thanks for any insight!

Re: Rogers IPv6 Status

@clarenceb5 there appears to be 4 versions of that particular router.  The latest version, V4 is listed on the datasheet as running 680 Mb/s for NAT throughput.  That is IPV4 Network Address Translation throughput.  So, if you're getting 400 to 450 Mb/s throughput, that implies that you have an earlier version, or, that the router, even if it is a version 4 router, is maxed out.  

 

Here's the support page for the router.  

 

https://www.tp-link.com/ca/support/download/tl-r600vpn/

 

You have to select the correct version to download the datasheet that matches your router.  On the bottom or back of the router, should be a product sticker which indicates the version of the router. 

 

It appears that you need to buy a faster router to run gigabit rates.  Practically speaking you can expect 940ish Mb/s on the downstream side, considering the ethernet overhead.  

 

If you're looking specifically for faster VPN rates, you need a router that supports Intel's Advanced Encryption Standard New Instructions (AES-NI).  At the most these days with OpenVPN, you could see somewhere in the order of 250 Mb/s with an Asus router running Merlin's Asuswrt.  OpenVPN is a single threaded application, so it will max out one core of a multi-core processor.  Processor speed and AES-NI hardware support is the key to running faster VPNs.  Alternatively you could run Wireguard on a pc which is a multi-threaded application, and which should produce faster VPN data rates. 

 

Just as a test, you should kick the modem into Gateway mode, connect your pc to the modem and run a speedtest using the www.speedtest.net Rogers Toronto, Montreal, or Ottawa server, which ever is closer to your home.  With the www.speedtest page up, change the test server and type in   Rogers   to display the Rogers servers.  You could also use the Rogers speedtest which is located at:

 

https://www.rogers.com/customer/support/article/internet-speedtest

 

The question at this point is, are you actually seeing ~940 Mb/s on the download side and 30 Mb/s on the upload side?