cancel
Showing results for 
Search instead for 
Did you mean: 

IgniteTV Surround Sound

DDave_ca
I've Been Here Awhile

Hello!  First post...

 

Long time Rogers customer, new Ignite subscriber.  Any Ignite customers having trouble getting surround sound (DDS5.1) to work from these Ignite TV boxes?  In the settings, I have tried both Auto and Expert (forced surround sound), but neither work.

 

My connection is not HDMI direct to my surround receiver - it only has optical (toslink/SPDIF) input.  My Panasonic TV has optical output.  I have DDS5.1 when using the smart TV for Netflix playback - not from the Rogers Netflix app.  I also tried using an audio extractor/splitter - same results.

 

Thoughts?

 

*** Edited Labels ***

135 REPLIES 135

Re: IgniteTV Surround Sound

BobEmery
I've Been Here Awhile

I just followed your instructions to enable my Polk sound bar to work with the Ignite remote. Works perfect!!

Re: IgniteTV Surround Sound

Square
I'm a Reliable Contributor

Okay here is my strange problem.  The Dolby Digital 5.1 works on live tv, but not on the recorded shows.  Any ideas? 

Thank you.

Re: IgniteTV Surround Sound

Ignite TV no surround sound...

 

hi Folks, 

 

Long time Rogers subscriber, recently upgrade to Rogers Ignite. I have a Sony Bravia (XBR55A8G) with a Bose 700 Soundbar, Bose Bass Module and Bose Surround Sound Speakers. Using my iPhone I can Airplay music and hear it through all the speakers. However when I watch TV the sound only comes through the Soundbar. Nothing coming through the Bass Module or Surround Sound Speakers.

 

I think it's pretty straight forward. I have the Rogers Ignite connected via HDMI cable to HDMI 2 Input on the Sony. The Soundbar is connected via HDMI cable to HDMI-ARC on the Sony.

 

During the setup I was able to get the Ignite remote to turn on both the TV & Soundbar. But regardless of what settings on Ignite, Sony or the Bose components. No sound out of the Bass Module or rear speakers.

 

Perplexed...

Re: IgniteTV Surround Sound

57
Resident Expert
Resident Expert

@jeffrdonald  Here are my comments, suggestions.

 

I see that you're going "through" the TV for audio since the Bose has no HDMI Input (only HDMI-ARC connection to/from the TV, which is "weird").  This means that the audio going through the TV to the Bose needs to be configured properly.

 

1. Some TVs do not allow for the proper passthrough of Audio as discussed in note 4 of the following FAQ:

 

https://www.digitalhome.ca/forum/30-57s-home-theatre-faqs/17870-faq-whats-available-dd5-1-a.html

 

2. However, most new TVs do allow for proper passthrough, however, they need to be configured properly in the TV's user audio setup menu.  It needs to be configured for "external speakers" as well as for DD5.1 (or "original audio" or "bitstream", or something similar.  Often, the TV may be configured by default to send PCM (2 channel) audio instead, which is what I suspect is happening.

 

3. Another thing to try would be to use the optical output from the TV into the optical input of the Bose.

 

4. Also, make sure you're using the appropriate HDMI input on the back of the TV for 4K signals etc.  A quick look at the operating manuals seems to indicate HDMI 2/3 are good for this, but check to be sure.

 

5. Makes sure you've enabled the appropriate surround sound mode in the Bose for the HDMI-ARC input. Many devices may "remember" different modes for different inputs. See also page 49 - Troubleshooting of the Bose operating manual.



Re: IgniteTV Surround Sound

Square
I'm a Reliable Contributor

Switch the audio setting to Expert on the Ignite box, if not already.  When I first had trouble, I had my box set on Dolby Digital Plus, was not getting surround on rear speakers, when switched to Expert, then it worked.  Still won't get DD 5.1 on Recordings tho, that's a Comcast/Rogers problem.

Re: IgniteTV Surround Sound

Kromtara
I Plan to Stick Around

When our Rogers Ignite TV was first installed we also lost our surround sound but figured out a solution.

 

Our audio is through HDMI to a Sony Receiver.  The receiver then connects to a Bose Accoustimass Surround system with Subwoffer, a BRAVIA TV (also via HDMI) and other components.

 

Here is the solution that worked for us:

1. Use the Sony receiver remote and push the “GUI Mode” button to bring up the receiver menu through the TV

2. Scroll down to “Settings” (the little toolbox) and select it

3. Scroll down to HDMI and set it to the following:

    Ctrl for HDMI: OFF

    Pass Through

        Audio Out: AMP

    HDMI Assign

4. I am not sure if this is important but you can also scroll to “Surround” and I have mine set to the following:

    HD D.C.S.           Theatre

 

Once I made these changes my surround sound returned for all Ignite TV functions. I hope that this helps. Cheers and all the best for the Season!

Re: IgniteTV Surround Sound

57
Resident Expert
Resident Expert

@Kromtara wrote:

A: Our audio is through HDMI to a Sony Receiver.  

 

3. Scroll down to HDMI and set it to the following:

    Ctrl for HDMI: OFF


A. The Bose 700 sound bar in question doesn't have an HDMI (A/V) Input, only HDMI-ARC to accept audio from the TV, so you cannot go "through" the Bose 700.

 

3. Setting the HDMI-CEC to off will eliminate the ARC functionality, so that won't help @jeffrdonald , unless he switches to optical as the output from the TV.



Re: IgniteTV Surround Sound

Kromtara
I Plan to Stick Around

Yes, my post to this thread was our experience losing surround sound on Ignite TV with our config and solution, not for @jeffrdonald's specific configuration. There were others I hoped this would help. Cheers.

Re: IgniteTV Surround Sound

I spoke to an agent and confirmed that ignite recordings do NOT playback in 5.1. The best in 2019 is pcm stereo. Live and on demand do. Also the agent confirmed that this maybe something that changes but can't confirm when or if they will. Sad sad sad. My old PVR,s worked fine for this. I switched because Rogers would not lower my cable package. They said if I switch to ignite It would be cheaper and better. So. Stupid me. I switched. Now I listen to stereo recorded shows in my Onkyo THX receiver and Sony 85 inch Bravia. And it sucks compared to last week when I had my cable per 8300 that's about 10 or 15 years old. Wow. Just wow.

Re: IgniteTV Surround Sound

Rogers Ignite plays recordings in stereo PCM only. Live is 5.1 capable. This was as per the agent. I have a screenshot of this. Also they may never fix this is what I was also told.

Re: IgniteTV Surround Sound

Don't blame Rogers for this one.  It appears to be a Comcast decision.  So, Comcast equipment, Comcast rules ......  to put it politely. 



Re: IgniteTV Surround Sound

Really? This is because I asked for a lower cable bill and they gave me this stating it's better. Sounds like Rogers problem to me. Anyway. I want it fixed. That's what I'm after. So how do I get Rogers to fix this. Stereo on a product that they are pushing is not acceptable in 2019. How is it Netflix, Kodi etc can make this work. Stereo.

Re: IgniteTV Surround Sound

How do you fix it?  Tell Comcast to record tv shows in 5.1 instead of 2 channels.  When Comcast decides to do it, that would or should give Rogers the ability to do the same.  If you cruise thru some of the xfinity forums, you will see the same complaints.  Comcast doesn't appear to be in any hurry to make any changes.



Re: IgniteTV Surround Sound

Could you supply a link to COMCAST For this. I don't mean a link to see that xfinity does this. I mean a link to whom can solve the issue. I will gladly offer them a free trip to my house to see my state of the art setup and their equipment short comings. Also who at Rogers thought going backward was a good idea? I find it off I pay my monthly bill to Rogers and they choose to blame their chosen vendor?

Re: IgniteTV Surround Sound

57
Resident Expert
Resident Expert

@jpihura1 : I assume you're being sarcastic about the Comcast person. Here's the link to the last update from Rogers.  There are numerous previous posts (61 onwards in that thread) on the topic of no DD5.1 on recordings on Rogers Ignite.

 

https://communityforums.rogers.com/t5/Ignite-TV/Should-I-Make-the-Switch-to-Ignite-TV/m-p/451264#M41...

 

All Ignite customers look forward to a quick resolution, so keep bugging them.



Re: IgniteTV Surround Sound

jpihura1
I'm Here A Lot
I actually am seroius. I appreciate your link to this issue. Sadly I was not informed of this when I asked "so what am I going to lose" if you know whom I should contact. I will. And do what I said on my dollar. .

Re: IgniteTV Surround Sound

Kromtara
I Plan to Stick Around

Tonight I tested our recordings on Ignite TV after reading these posts.  Per my earlier update - after changing the HDMI pass-thru settings on our Sony receiver there is surround sound on both live TV and recordings.

 

Now, I am not certain if it is Dolby Digital 5.1 on recordings.  Dolby Digital 5.1 scrolls on the receiver during live TV.  But, the recordings are definitely not 2-channel (we are getting left, centre, right, surround and LFE-woffer separation).  The receiver says it is receiving Dolby D+.  Normally PCM lights up on the receiver if it sees PCM.

 

I am trying to figure out if this is "simulated" surround on the recordings or true surround. I am no expert.  More research required?

Re: IgniteTV Surround Sound

Pro logic is Dolby but in stereo. I have the agents response if you would like to see it. Not 5.1 as per them and equipment.

Re: IgniteTV Surround Sound

Square
I'm a Reliable Contributor

My old AVR and now my new soundbar always shows DD 5.1 on Live TV, On demand and the Recordings.  But when I listen to the back surrounds, the Recordings never have any sound coming from them.

Re: IgniteTV Surround Sound

57
Resident Expert
Resident Expert

@Kromtara wrote:

The receiver says it is receiving Dolby D+.  Normally PCM lights up on the receiver if it sees PCM.


I'm guessing that your AVR is receiving "improperly encoded DD5.1", which your AVR interprets as DD+, which contains only the LF & RF speaker signals, as discussed in this and the other thread for Ignite recordings. Your AVR is currently set to decode these signals to provide (synthetic) surround sound (see link below).  Most people who leave their AVRs set up properly for incoming DD5.1 signals end up with only the LF & RF speakers being active for Ignite recordings.

 

You will probably not see PCM unless you change the audio settings in the Ignite box to "other" instead of "expert"?  Changing to "other" is also a workaround to get surround sound by invoking DPLII in the AVR for the incoming 2-channel signal from Ignite recordings.

 

Edit: 

@Kromtara : I see from your other recent post (Item 4 of link below) that you are using a "simulated" surround sound.  This is not true DD5.1.  You would also have sound coming out your surround speakers if you set it to something like "7-ch Stereo", however, again, this is not true DD5.1 and the sound is not being reproduced as intended, even if your surround speakers are active.

 

https://communityforums.rogers.com/t5/Ignite-TV/IgniteTV-Surround-Sound/m-p/452754#M4503

 

I have encountered lots of people during my optimization travels who utilize "7-ch Stereo" (or something similar) because they want to hear sound from all of their speakers, however, this doesn't provide the discrete audio from the various speakers that the director of the original programme intended.  In many cases, like a news programme, the dialogue will/should come out the centre speaker and nowhere else.



Re: IgniteTV Surround Sound

Lott
I'm Here A Lot
Hi @DDave_ca . I have run into the exact same problem as you. I tried calling Rogers tech support as it seems only to be a problem with input coming out if the ignite box. All others seem fine - PlayStation, blue ray disc player, etc. The tech support can’t help me either. Wondering if you got it solved and how?
Community Testing Lab

We’ve got an amazing opportunity to test our upcoming Gateway!

Click here to find out more!

Topic Stats