Remote control buttons are not working well ...

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I've Been Around
Posts: 1

Remote control buttons are not working well ...

Hi,

 

Just wondering if anyone else is having the same problem I am having with the Scientific Atlanta Explorer 1840 cable box with the 1056B03 remote.

 

It all started about two days ago, I would turn on the the tv and box, and when I press the channel up to go to the next channel and stop, it continues scrolling through all the channels until I press the channel button down to stop it. And it also does it when I want to go down channels it automatically starts scrolling all the channels non-stop. Just wondering why this is happening, and if anyone has any information that can help me.

 

Thanks in advance,

 

 

***Edited labels***

I'm a Senior Advisor
Posts: 3,510

Re: Remote control buttons are not working well ...

That looks like a physical problem with the membrane switches under the buttons. The conductive material gets worn out. You can try pressing a different area of the button. Otherwise, the only solution is replacing the remote or opening it up and repairing it with conductive paint, something most people wouldn't want to attempt.


SA8300HD, SA8300SD, DTA50, LG-E410B PayGo. Location: S-W Ontario