On Demand problems

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Resident Expert
Resident Expert
Posts: 13,982

Re: On Demand problems

Well guessing that it will be the way that the TV as a whole, even for ROGERS will be going, in the long run.



I'm a Trusted Contributor
Posts: 667

Re: On Demand problems

Hopefully not during my lifetime.
I'm a Senior Advisor
Posts: 3,522

Re: On Demand problems


@robindp wrote:

Issues like this make me wonder why they don't use an IPTV stream for VOD...the stream would have no issues with a half-decent connection and would probably be easier and cheaper to maintain. 


That would only work if you were also a Rogers internet customer.  I'm not and I suspect half Rogers cable customers aren't.


SA8300HD, SA8300SD, DTA50, LG-E410B PayGo. Location: S-W Ontario
I'm an Advisor
Posts: 764

Re: On Demand problems

Not neccessarily @OLDYELLR, they could use Ethernet via coax to deliver the content via their existing network, or consider offering "zero-rated" internet to the STBs (Bell Fibe has been known to do this for customers who do not want Fibe internet).

I've Been Here Awhile
Posts: 2

Re: On Demand problems

Hi we ordered a movie on rogers on demand and it was horribly pixelated.  We rebooted and still had trouble.  Called rogers and they said it was their server not our box so our movie was credited.  They said they would take note of the movie and create a ticket for it to be fixed in the next 24-48 hours.  Okay.  THEN we ordered a different movie - same thing happened. Tried to watch a tmn movie same thing.  Called again had the movie refunded.  I asked what can we do at this point they said "oh this happens all the time all over ontario our server gets overloaded".  WHY am I paying for this service that doesn't work.  I can't order a movie on a Saturday night with my family.  We have noticed that the new Navigatr system is awful - it freezes we can't even see what number of s series we are picking as the pictures and numbers don't load.

Sorry very very frustrated.  We are really thinking of going to bell for everything. phone, internet, tv.  

 

Retired Moderator RogersHassam
Retired Moderator
Posts: 571

Re: On Demand problems

Hi @staaffe,

 

Welcome to the Community!

 

I can understand the frustration especially when trying to watch a movie and getting pixelation. Have you spoken to technical support and had them run a diagnostic test on your cable lines to ensure your signals were in spec? Do you get pixelation on any other channel? Please let us know. 

 

Thanks, 

RogersHassam 

Highlighted
I Plan to Stick Around
Posts: 40

Re: On Demand problems

This refers to Nextbox without PVR

 

We had this problem when ordering a movie. It looked like it was already played and we couldn't start it from the beginning.  It was stuck in a loop.

 

We called Rogers and while waiting, I remembered when I had issues on my Explorer 1840, I went through the menu to reboot the box. Tried it on the Nextbox and it worked.  I don't know if this is a one of.

 

I don't know if you tried this:

 

Nextbox no PVR

CBL, Settings, Troubleshooting, Reboot Set-Top Box-make sure it's this one, Exit

NOTE: it takes at least 5 minutes and up to 1/2 hour

 

When I have issues it seems the only solution offered is to unplug and wait 10 seconds and plug it back in and it should work or reset digital box from the account. This works some of the times not all.

 

I noticed that when there are account changes or major upgrades the "full/reboot" of digital set-top box remote is needed.

 

Hope this helps because it worked for me.

 

PS

 

This is how I reboot the Scientific Atlanta Explorer 1840

Select: CBL, Guide 2x, Self Service, Need Help?, Up Arrow to confirm, OK Select, C to Close, Exit

 

 

 

 

I Plan to Stick Around
Posts: 99

Re: On Demand problems

I got a refurb Nextbox 3.0 yesterday from Rogers...can't get On Demand to work.  I already own a NB 2 and it works fine on that box.  Had two other Nextbox 3.0's in the past week...On Demand worked on both of those...both had other problems, so had to be swapped for this 3rd one.  Tech support claims they can fix this and said not to swap the box...issued a ticket.

 

I know this had been an ongoing issue for many...has this been fixed, or is this another 6 month wait to get fixed?

I'm wondering about swapping the box again...this would make #4 OR do I keep this one and believe they can fix it SOON?

 

Remaxman...have they fixed yours?

Resident Expert
Resident Expert
Posts: 2,972

Re: On Demand problems

Interestingly I was just talking to Rogers on this issue again when I read your post.  Here is a summary:

 

1. It has been affecting some people since November when they downloaded some problem firmware to allow for OD to work on all STBs in the home, not just the one that ordered the programme.

 

2. It's continuing to affect some people, mostly with 9865 (NB3) STBs.

 

3. It's a known issue (Catalog Error 835MC) that they are "working on" with no ETA for a fix.

 

4. Some people have got it working by swapping the STB.

 

5. Some people have got it working by rebooting and waiting some period of time - Rogers suggests one hour - before trying to get OD.

 

Keep calling in so they don't forget about us.

 

If there's something I absolutely need to catch up on, I do so via the web version of OD since I'm not near my download cap.

 

http://www.rogersondemand.com/OnDemand/TVShows?lang=en



I Plan to Stick Around
Posts: 99

Re: On Demand problems

Hi 57...thanks for the info...that's exactly what I thought.  I just got off the phone with Rogers AGAIN and of course they say it is a known problem, but they are able to fix it in ALL cases within 24 hours...when I referred to you and others on this forum, they of course act surprised and offer many denials that it hasn't been fixed in 100% of the cases.  So I guess you and others on this forum are just my imagination gone wild!

 

They are sending a tech out on Saturday...which I know won't fix the problem...but I'll humour them and let them keep swapping boxes until they find one that works...saves me driving back and forth to the store (as I said earlier, my first 2 boxes had working ROD, but they had other issues).  I imagine it will be another box swap (#4 in a week)...I did tell them if they have to swap 20 boxes to get it to work, then they better do it...if it ain't fixed Saturday, I told them to disconnect my cable, cause I'm done!