No 5.1 audio on HDGLB

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
gman5
I've Been Here Awhile
Posts: 2

Re: No 5.1 audio on HDGLB

Good morning everybody. I have a Sonos beam and two sonos back speakers, so a surround sound system. I'm new to Rogers Ignite TV, just a few weeks. I notice though that the channels don't seem to be broadcasting in 5.1. I was watching Star Trek Picard last night on CTV SCI FI and was surprised to notice this (although Crave broadcasts the show this way). Do any channels on the service broadcast in 5.1? If so, is there a master list? Thanks in advance.

57
Resident Expert
Resident Expert
Posts: 4,016

Re: No 5.1 audio on HDGLB

Looks like your post was moved to this existing thread on the topic, Please read earlier posts:  Here are my comments.

 

1. Most HD channels are DD5.1 on Ignite and on Digital Cable.

2. Global and CTV2 and some others switched to DD2.0 almost a year ago and Rogers, Global, CTV2, etc have been made aware of the problem, however, they have not corrected the issue for some reason.  CP24 is also DD2.0.

3. If you record programmes on Ignite, they will be sent to you as DD5.1, however, it's improperly encoded with only the LF & RF channels active.

4. Here's an FAQ on the topic:

 

https://www.digitalhome.ca/forum/30-57s-home-theatre-faqs/17870-faq-whats-available-dd5-1-a.html

 

5. Since you have a Sonos Beam and not a true DD5.1 system with an AVR, it's unlikely that you'll notice much difference between PCM-2ch, DD2.0 and DD5.1, so I suggest you set the output on the Ignite TV box to "other" instead of surround and in this way you'll get surround sound even for your recordings...  The Rogers box will send PCM (2 channel audio) and the Sonos, if set up properly, will decode this signal to provide you with surround sound.



57
Resident Expert
Resident Expert
Posts: 4,016

Re: No 5.1 audio on HDGLB

Someone posted over on Digital Home that they had contacted the CRTC on this topic. It appears to have born fruit since Global and TSN1 are now properly encoded DD5.1 again.  Only took a couple of years...