I connect the HDMI cable but.....

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I've Been Around
Posts: 1

I connect the HDMI cable but.....

Hi,

I have recently changed my TV to a Panasonic HDTV with 3 HDMI + 1 component + 1 RCA inputs.

In the beginning I hooked up my Rogers (scientific Atlanta) explorer 4250 HD (the HD box) to TV components input. OK.

I've just changed the cable to use HDMI Cable, but none of the HDMI inputs work with HD box. (No signal message on HDTV).

I tried the setting menu in HD box, but it had only the audio output type. I set it to HDMI.

The HDMI cable and HDTV HDMI inputs tested were tested perfectly with other devices. (DVD Player) it doesn’t work only with HD box.

1)      Is there any other setting that I haven’t done? (in setting menu)

2)      I switched to HD channels and regular channels but none of them are displayed on HDTV.

Please help/advice.

Regards, NEWHDTV

 

 

***Edited labels***

I've Been Here Awhile
Posts: 4

Re: I connect the HDMI cable but.....

Hi:

 

Did you set your TV to use the HD port?  I know on my TV, I have to use the TV menu to indicate that the signal I want to watch is via one of the HD ports.  I also have my DVD hooked up to another port.  I use the TV's menu system to switch between the two.

 

Ieuan

Resident Expert
Resident Expert
Posts: 2,465

Re: I connect the HDMI cable but.....

I concur, if you have the rogers cable box going into the TV via the HDMI cable, make sure your tv input is set to HDMI.  you might want to consult your tv owners manual to find out for sure how to do this as they might call it another name? maybe your cycling through the component inputs by mistake?



I'm a Senior Advisor
Posts: 1,299

Re: I connect the HDMI cable but.....

The only menu setting I can think of is the HDMI one you mentioned. You can try doing a HD box setup by pressing the "Info" and "Gudie" buttons on the Rogers digital cable box at the same time while the box is turned off. The "HDTV Setup Wizard" should appear on the TV screen.
I've Been Around
Posts: 1

Re: I connect the HDMI cable but.....

A Rogers TRechnician came to my house plugged a Roger Netbox into my hdmi and fried both HDMI inputs.Dunbarton Radio in Ajax charged me $350.00 to replace the board. Rogers net boxes hdmi's are defective and surge a current strong enough to fry your HDMI inputs. Tryt getting your money back from Rogers, I din't even bother.I jkust cancelled my Rogers services forever !
Resident Expert
Resident Expert
Posts: 13,804

Re: I connect the HDMI cable but.....

While i am sure its possible..  there are a ton on this forum with it, i know 6 family/friends who have them as well, as well as myself, and have not had this.  (i have also had the NB3 on two different TVs which it hasnt done it on).

Any electronic device, there it always a chance of that happening, a surge going across.

Working with computers, wouldnt be the first time i have seen it happen actually when something was UNPLUGED.  Works fine while cable, etc is in... as soon as the connection is broken when unpluging... that is enough to cause the short or complete the short... and as soon as you then try to start it up again.. it doesnt work. 
First thought was to blame the thing pluged in but then worked on other things fine..  so had to be the unpluging that caused it.
(Seen it on video cards including using HDMI, USB ports, power ports)



I've Been Around
Posts: 1

Re: I connect the HDMI cable but.....

i can only get my 4250hd to output pn component video.  Composite is audio only and HDMI no signal?

Highlighted
I'm an Advisor
Posts: 764

Re: I connect the HDMI cable but.....

Hello @kenora,

That is correct, component video output does not include audio. Have a look at the picture below: 

 

image.gif

 

You will need to connect the AUDIO OUT (red and white jacks - #6) to your TV in addition to the component video out (#3). 

I'm an Advisor
Posts: 764

Re: I connect the HDMI cable but.....

Hello @kenora,

Re-read your original post, a few notes:

 

- Component video is output from the red, green and blue jacks (#3). These connections are video only and do not include audio, but can drive high definition video up to 1080i (1080p on newer cable boxes). 

 

- Composite video is output from the yellow video jack (#5). This connection is video only and does not include audio, but can drive standard definition video up to 480i. 

 

- To get audio for either connection, you must connect the red and white "audio out" jacks (#5 or #6) to your TV.

 

- For best audio quality when connecting to a TV, set the cable box to output audio at a FIXED (not variable) output.

 

 

I hope this helps - let us know if you have any questions. 

 

I've Been Here Awhile
Posts: 2

Re: I connect the HDMI cable but.....

I have no idea up to set  everything up so I can us all my appliances with my hand help whatever! I am 70 years old...I need a service person to come to my house and wire it all together so it works and then show me what I must do. I go into the hospital in a couple of weeks and I would appreciate to have this done before I go. I spoke to Bell and they said if I switched to their company that is part of this service, Please let me know if you can help me or for convenience shake I will have to switch.

 

Thank you,