Cisco 8642 HD PVR Not Working?

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I've Been Around
Posts: 1

Cisco 8642 HD PVR Not Working?

Hi all,
I have the Cisco 8642 HD PVR

Thursday morning I was awoken by the sound of the power/electricity flashing off and turning back on instantly... Laying in bed, I notice the time came back on the PVR after a minute or so...

A few minutes later, the power went off again but did not return for a few hours...Upon coming back on, the box would not boot up.

Now when I unplug the box and re-plug it back in, it starts with "65tr"/"bstr"?, then "----", then shows "boot" for half a second before going to "-:-"...
From there, the power icon flashes a few times then turns off.. pressing power does nothing after that..

Is my box fried?

Any help/insight would be much appreciated.

 

 

 

***Edited labels***

Thanks!

Solved! Go to Solution.
Resident Expert
Resident Expert
Posts: 13,822

Re: Cisco 8642 HD PVR Not Working?

Erf. Sounds like it might be Smiley Sad
Try moving it to a different location if you can in he house just incase, and see if it comes up.

Was it purchased or rented?


I'm a Regular
Posts: 214

Re: Cisco 8642 HD PVR Not Working?

The 8642 just has a spinning LED circle.

 

I'm a Reliable Contributor
Posts: 171

Re: Cisco 8642 HD PVR Not Working?

Rogers usually send out software updates to the PVRs around 2am.

 

Lately, they seem to be following a Monday night and Thursday night cycle.

 

Just unplug the power cord, wait 10 seconds, and plug it back in.

 

The box will reboot again.

 

Note: even after the reboot, you may have to wait a few minutes for any downloads ... you may notice a red downloading bar at the bottom of the screen. While downloading, the remote may not respond to commands.

 

 

Resident Expert
Resident Expert
Posts: 13,822

Re: Cisco 8642 HD PVR Not Working?

I think the update last night was a little funny..

When i turned mine on this morning.. The channels initialy, said 'service not available'.  Flipped one or two more, and then they all came in.. like it took a bit first time it started up after the update.

 

I would agree, first thing would be to unplug, leave for a good 20 seconds, then plug back in. Leave it for a good 15+ mins to see if it gets past that part.



I'm a Regular
Posts: 214

Re: Cisco 8642 HD PVR Not Working?

The time comes up but it won't turn on. Then it starts over.

I'm a Regular
Posts: 214

Re: Cisco 8642 HD PVR Not Working?

Now it says Er99, how do I fix it?

I'm a Reliable Contributor
Posts: 147

Re: Cisco 8642 HD PVR Not Working?

Did you call Rogers about this? That is the first thing I would do and if they tell you to replace the PVR, this is one time they might actually be correct!

Resident Expert
Resident Expert
Posts: 13,822

Re: Cisco 8642 HD PVR Not Working?

Last time I saw er99 on here was when there was a semi botched update.
Some people it took a day to get past it (likely another update)

Could try calling and see if they can reset the box from their end.



I'm a Reliable Contributor
Posts: 165

Re: Cisco 8642 HD PVR Not Working?


@Frazzled wrote:

Did you call Rogers about this? That is the first thing I would do and if they tell you to replace the PVR, this is one time they might actually be correct!


I would agree. Sounds like you may need a new box.

 

If you want to try to erase the internal memory and re-pull all the data from the network there is a method to try (won't affect hard drive), but you may need 3 hands for this one!

 

First, press and hold the POWER and SELECT buttons at the same time. 

Then pull the power plug out (this is where you may need the 3rd hand) but KEEP holding the two buttons. Keep holding for about 10 seconds

Get your 3rd hand to re-plug in the box - you should STILL be holding the power and select buttons together.

Once power is restored, keep holding the two buttons for about 10 more seconds and then release.

 

You should see a hex countdown begin shortly on the front of the box.... this will erase the internal memory and re download the OS and all your account info.

 

Hope this helps.