Rogers smart home monitoring touchpad wont work!!

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I've Been Around
Posts: 1

Rogers smart home monitoring touchpad wont work!!

Hey fellow customers!,

 

Well I had the Rogers Smart home monitoring service installed in my house last Sunday, all went well, understood everything that was told to us, i diconnected the power from the touchpad yesterday (done multiple times before) to move it, cause i tried to show my family the cool radio feature. when i tapped on the app it said no internet connection, this is the same with all the other apps except for the security one. When I click settings, it just comes up with the title "settings" on the top of the screen and the rest is black, with nothing. Is there something wrong with the service, or my home exactly?

 

Or can it be that the information on the news was right, about solar radiation knocking down satellite and other wireless connections, but if this was true, would the whole Rogers system be down?? Im completely confused Smiley Frustrated

 

 

 

 

***Edited Labels***

Moderator
Moderator
Posts: 873

Re: Rogers smart home monitoring touchpad wont work!!

Hi and welcome to the Community @jacksonmonroe,

 

I hope you've liked the service so far, despite the recent hiccup. Have you tried to reboot the touchpad at all? You can do so by following the steps listed below: 

 

  1. From the touchpad press Settings.
  2. Enter Master Code.
  3. Select Advanced Settings.
  4. Choose Reboot Touchpad.
  5. Choose Reboot Touchpad again.
  6. Enter Master Code.
  7. The touchpad will shut down and restart.

Also, please view Touchpad Freezing and Unresponsive, this is a helpful article on some additional troubleshooting steps. 

 

 

 

 

RogersZia

Highlighted
Resident Expert
Resident Expert
Posts: 13,942

Re: Rogers smart home monitoring touchpad wont work!!

beyond that.. if you cant get into the setting menu to restart it that way..  the best way, is to pull the battery.

You will need a screwdriver i believe, and pop the back cover off.  The battery should be connected with a pair of wires, pop the connector out of the back of the touchpad.
Pop the battery back in and plug the connector in.. I would then also plug back into the power while its booting back up.

Its possible maybe when you moved it.. that it went to far from its wireless connection?
Though that should then maybe just cause some specific things to stop running which use the full broadband connection.. shouldnt lock the whole unit up itself though.



I've Been Around
Posts: 1

Re: Rogers smart home monitoring touchpad wont work!!

My camera and door alarm are always showing "communication failure" and never work in either my phone or the touchpad. It worked when the tech left but stopped soon after. I've had it kick in intermittently and have tried everything except removing the battery on the touchpad. Forget it. I'm not going to all the trouble.... I'm in a ti y little bungalow and it can't get a signal.... Sucks
Moderator
Moderator
Posts: 222

Re: Rogers smart home monitoring touchpad wont work!!

Hey @Marminty!

 

Welcome to the Community!

 

I can only imagine how stressful having to deal with something as serious as your home security not working must be! We'll definitely want to get this resolved as soon as possible. To verify why this issue is occurring there's a couple of typical causes.

 

Battery Issue: Can you check the battery level on the touchpad? Should the battery level be low you can find the steps to change it "here."
Should the battery change not resolve the connection issue, then you can unpair the door alarm and pair it again. Steps for which can be found "here." Do not unpair the camera however as the setup for this would require a technician on site. 


Wireless Issue: It's also possible that this is just a wireless connectivity issue and if that's the case then it's possible the modem/router may need to be relocated to a more optimal location to provide sufficient wireless signal. Are you having wireless connectivity issues with any other devices in your home? A technician can be scheduled to relocate the modem if needed at no charge.

Have you reached out to support yet regarding this issue? If so, has a technician already been scheduled for you to assess and resolve the concern? Let us know. If not feel free to reach out to support or to us here @CommunityHelps at your convenience and we'll be happy to assist. For more information on our private messaging system you can check our our Blog.

 

@RogersAndy