Weak LTE Signal Recently

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I Plan to Stick Around
Posts: 73

Weak LTE Signal Recently

I live near Eglinton and Chaplin in Toronto.  Recently my LTE signal has gone from 2 bars in the house to 1 or 3G (no LTE).  This only started happening about a month ago after working OK (max 3 bars in the house) for years.  This is with various iPhone 5S devices running IOS 8.3 .

 

Please report this to the network/tower group as it only just happended and appears as if some tower is not broadcasting LTE any longer.  There is construction for the Eglinton subway in the area but I'm not sure if that's related or not.

 

Thanks.

 

 ****Edit labels***

Solved! Go to Solution.
Retired Moderator RogersAliciaG
Retired Moderator
Posts: 235

Re: Weak LTE Signal Recently

 

@ablatt

 

I am sorry to hear of the LTE issues in your area.  Smiley Sad

You did mention that this issue has been reported with various iPhone 5s devices. Have you noticed that this is happening with any other type of device out side of the iPhones? Also have you tried a different/new SIM card?

 

 

RogersAliciaG

I Plan to Stick Around
Posts: 73

Re: Weak LTE Signal Recently

My iPhone 5S works perfectly in many other areas, including my office, where I receive 4 out of 5 bars consistently.  It has only gotten much worse recently.  My signal in Field Test Mode on the iPhone is as low as -126.

 

Some change in Tower signal or interference has occurred.  Can you please report it to your network people?

 

Retired Moderator RogersAsif
Retired Moderator
Posts: 700

Re: Weak LTE Signal Recently

Hello @ablatt

 

I will have a member of our @CommunityHelps team reach out to you so we can have this reported to the Network Team. Please check your inbox on the Community Forums.

 

Thanks,

RogersAsif

I've Been Around
Posts: 1

Re: Weak LTE Signal Recently

Just came back from my three weeks Asia trip, I found the same problem with my iPhone 6 plus. I'm living at high park.
Highlighted
Retired Moderator RogersAsif
Retired Moderator
Posts: 700

Re: Weak LTE Signal Recently

Welcome to the Community @xiongnu

 

Have you completed any troubleshooting such as rebooting the device or resetting the network settings?

 

Have you noticed this everywhere is High Park? or just a specific location such as your house etc?

 

Also, some information regarding if this issue is affecting the peformance of the service would be great aswell(slow browsing etc)

 

RogersAsif