Sony Xperia Z5 cannot connect to LTE

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I've Been Here Awhile
Posts: 2

Sony Xperia Z5 cannot connect to LTE

I recently purchased a Sony Xperia Z5 from overseas for use here.
I have managed to connect up to the 3G network but cannot seem to get on the LTE. 

 

I can see the Rogers LTE network under the service providers in the mobile network menu.  But it says I cannot connect to it and is stuck in 3G only.

Can anyone shed some light on the issue?  I have tried various APN with no success.
The one thing I did find, is that Rogers run on Band 4 and 7, both of which are listed as available on the Z5.

 

Is it an APN issue?

 

Any help is appreciated.

 

 

 

***Edited Labels***

I'm a Trusted Advisor
Posts: 32,019

Re: Sony Xperia Z5 cannot connect to LTE

Hello @kyriian

Did you follow the correct APN? Follow the link below and see.

As this is not a Rogers branded device, there isn't much tech support Rogers can offer other then giving u the APN settings and see if that works.

http://www.rogers.com/web/support/wireless/wireless-network/2169
I've Been Here Awhile
Posts: 2

Re: Sony Xperia Z5 cannot connect to LTE

Thank you
I can see the LTE network under available networks, it just won't let me join it, max I could get is 3G.

I was told the phone might not receive the band that Rogers uses, but if that's the case would I even have been able to see it available on my list of networks? 

Also, I see both a ROGERS, and also a ROGERS-EXT networks available, anyone can shed some light as to what that might be?

I'm a Trusted Advisor
Posts: 32,019

Re: Sony Xperia Z5 cannot connect to LTE

Hello @kyriian

Yes that is possible. The device can show " LTE" as its a LTE phone but not just registering it due to not getting he correct band from Rogers to use LTE on Rogers.

Rogers-EXT means " It’s meant for customers who live within the Rogers network and happen to travel occasionally into Extended Coverage areas outside the Rogers network. ... When you travel outside the Rogers network and connect to Extended Coverage, on most devices you’ll see EXT or a roaming "
I've Been Here Awhile
Posts: 2

Re: Sony Xperia Z5 cannot connect to LTE

I tried to setup with "ltemobile.apn" as following the information on Rogers official website, however it doesn't work either for 3G or LTE. I cannot use mobile network, google or map. I also went to Rogers shop but it was not helpful. How can I do that?

Highlighted
Resident Expert
Resident Expert
Posts: 1,088

Re: Sony Xperia Z5 cannot connect to LTE


@Mina3 wrote:

I tried to setup with "ltemobile.apn" as following the information on Rogers official website, however it doesn't work either for 3G or LTE. I cannot use mobile network, google or map. I also went to Rogers shop but it was not helpful. How can I do that?


@Mina3

Rogers APN: ltemobile.apn

MMSC: http://mms.gprs.rogers.com

MMS proxy: 10.128.1.69

MMS port: 80

MCC: 302

MNC: 720

Read more at MobileSyrup.com: How to use APN settings for Canadian carriers



I've Been Here Awhile
Posts: 2

Re: Sony Xperia Z5 cannot connect to LTE

I set up "access point network" following your direction, however, still not working in LTE, no mobile network, unable to use Google map and browser. My phone is definitely unlocked SIM. I had no trouble to use in Japan and Switzerland. Is there anything I can do?

Resident Expert
Resident Expert
Posts: 1,088

Re: Sony Xperia Z5 cannot connect to LTE

@Mina3

 

Just to confirm, phone calls work, text message works, but no data?

 

Does data work on 3G/HSPA/EDGE? is the data just not working on LTE?

Are you using an LTE SIM card from Rogers?