cancel
Showing results for 
Search instead for 
Did you mean: 

Issues with IKEv2 IPSec VPN on Rogers LTE/3G

JP1204
I'm Here A Lot
This is on an iPhone 7 connected to Rogers LTE or 3G wireless networks. 

I'm having an issue when using IKEv2 IPSec on NordVPN. The VPN connection gets established properly and connections through the VPN appear to work, speedtest works, many sites come up fine, etc. But some websites just never connect (e.g. https://us.opinio.net) through the VPN, others like https://www.reddit.com work 50% of the time. 

Using OpenVPN UDP port 1194 on the same NordVPN server instead of IPSec, there is no issue at all, so it's not a matter of the NordVPN server being blocked by the sites, or itself blocking requests. 

To rule out my phone or NordVPN, I switched the SIM card to TELUS LTE and both VPN modes work just fine, IPSec and OpenVPN. There is also no issues over WiFi.

There really seems to be an issue with Rogers and the connection through IPSec.

Do you guys have an idea what's going on? 

I found a thread where RogersDave suggest switching PDP Type to IPv4 instead of IPv6, but I see no options to do that on an iPhone 7. 

Thank you! 
144 REPLIES 144

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

dawnybabe
I've Been Here Awhile

Re: Issues with Rogers LTE/3G Security Camera Access

 

I have a Lorex system that I used to be able to view on my iPhone using an app and cellular data, but I can only access it via WiFi now. We NEED access to our camera security system ASAP.

I have a Telus mobile device for work and I can access the cameras using cellular data.

What has Rogers changed? Help us regain our Access to IPV4 so we can see our Security system on data network again

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

Hello @dawnybabe

 

Welcome to the Community 🙂 


Having access to your security cameras is important, I can imagine how inconvenient this must be for you. You've come to the right place and we definitely want to do our best to find a solution for you.

 

Could you please confirm if you are subscribing to a Rogers Residential or Business account?

 

Regards,

 

CommunityHelps

RogersAli

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

Jeal
I've Been Here Awhile
Hi Support,
Do you have any update on this issue?
What are you doing to resolve it? It would be great if you can outline the plans Rogers is taking to resolve this client impacting problem. Thanks.

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

I seem to be having this same issue I am  business client. I am currently implementing a L2TP VPN and it's working on everything except on my Rogers phone. I can only assume it's because of the IPV6 implementation.

 

What can we do to resolve this besides making requests for each individual phone? First apple cuts pptp support and now rogers is basically killing l2tp... What the heck is going on here? I would love to implement IPV6 on my network to be able to accommodate this push towards new technology but you can't expect me to do it over night.

 

We need a proper workaround for this please. 

 

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

dawnybabe
I've Been Here Awhile
Rogers Residential account.

Thanks

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

Hello, Community. 

 

Thank you all for your participation in this thread; not able to access certain app over the cellular data can be inconvenient. As discussed by @EhmTeeEhf in the post 105 no native IPv4 support has been causing the apps only supporting IPv4 not to function. We can submit a ticket for residential customers to have a fix deployed; please send us a private message at @CommunityHelps. You can find details about our private messaging in this blog.

 

Thank you for understanding!

 

Cheers,

RogersMoin

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

Also some updated news

 

We can help if the issue is mission critical for your business. I was informed of a work around can be done by our enterprise support team for business accounts.  I don't know about consumer accounts, but I am sure as Moin said, there is a work around for consumer customers.

 

On Business accounts, you can call into tech support and we can escalate a ticket to have your IMEI of your device blacklisted on the back end to prevent this device from accessing IPv6 and forcing IPv4 on the back of the network. This will resolve a lot of issues for now, but remember as the standards change, this work around is only a short term fix, once IPv6 is fully implemented by software makers and cell phone manufacturers, App producers will have to comply. Meaning that eventually the work around won't work anymore and the software providers for most security camera providers and VPN providers will be forced to update by the governing body who controls these standards.

 

So in a nut shell, contact tech support with a list of IMEI's you want to be forced back onto IPv4 and we can escalate to enterprise team to have these devices activated on IPv4 

 

Hope this helps

 

Mike

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

Im having the same issues. Please help. Thanks.

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

Hello @jariel71,

 

Welcome to the Rogers Community Forums! 

 

Thank you for posting your concern in the Community. I can imagine how upsetting it must be losing access to an App that you were accustomed to using via Cellular Data.

 

We'll need to pull up your information on file in order to fully review this matter and try to find a solution. Please send us a Private Message to @CommunityHelps so we can get started on this for you.

 

If you are not familiar with our private messaging system please check out our Blog.

 

RogersTony

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

italstalguy
I've Been Here Awhile

For people with an IKEv2 IPsec VPN on a pfSense server, I've found that enabling MSS clamping at a value of 1300 completely fixes my issue.

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

scansbar
I've Been Here Awhile

Can't browse on VPN on Rogers network.

 

Hello,

I'm a business user and notice that when connected to a VPN. I can't browse web pages. I tested this out with multiple VPN's applications and devices. This started a few days ago and noticed that this has happened in the past as well judging from the posts from other users. Can you please guide me to a prompt resolution. Currently I'm using OpenVPN on my Galaxy S9 Plus. I sent a private message.

Thank you

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

The latest version of the Acrobits voip client for iOS does support ipv6 networks like Rogers and works flawlessly, even if your voip provider is only ipv4. VoIP issues are generally related to the app not supporting ipv6 properly, not a Rogers issue.

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

PVC
I Plan to Stick Around

OpenVPN Has not worked for months

 

Thought I'd post here as I'm at my wits end at this point.  Historically I have set up an OpenVPN server on my router (Netgear and now trying an Asus) so that I could access my NVR through OpenVPN as opposed to the significantly less secure method of port forwarding.

 

Several months ago, for some reason, this method just stopped working. I could authenticate OpenVPN just fine on my phone(s), but I was basically unable to access internet or my NVR.  Sometimes I can get into a local IP while connected via OpenVPN, but it would be pretty slow and after clicking a couple pages, time out.  It times out and gives me a network error with my ivms-4500 app and won't let me see live view with my cameras.

 

I gave up, but recently noticed Russian and Chinese based IP Addresses trying to hack into my NVR through the forwarded port.  So want to go back to using OpenVPN.

 

Tried buying a new Asus 86U router thinking maybe it was my Netgear r7000 implementation of OpenVPN, but I'm having the same issues.

 

Then came across this post, but it seems like OpenVPN presumably wasn't impacted.

 

https://mobilesyrup.com/2018/06/20/rogers-troubleshooting-vpn-over-lte-issue-for-affected-users/

 

Is anyone have success say on an Android phone connecting using OpenVPN (or OpenVPN for Android) into their home networks?  Or has Rogers neutered this ability??

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

PVC
I Plan to Stick Around
Wow, just figured out the resolution to my problem of suddenly not being able to access my cameras through OpenVPN via mobile.

I changed my OpenVPN setting in my router from the standard default UDP to TCP. Exported the OpenVPN profile into my phone, and it works.

This after months of frustration and using a port forwarding routine which was so unsafe.

Maybe it will work for you.

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

pcasavant
I've Been Around
I havé the same problem!

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

davidtai
I've Been Around

Hi I have the exact same problem with vpn/app not working properly. Can someone please pm & help me with it?

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

scansbar
I've Been Here Awhile
Thanks to Corey at Roger's this worked for me and another person.

If it's an Android device, I have a workaround that I can walk you through. You've come to the right place! Please attempt the following:



Step 1 - Access the Device APN Settings Menu

Open the ‘Settings’ App from the App drawer on the home screen
Navigate to Wireless & Networks -> Cellular Networks -> Access Point Names


Step 2 - Modify the APN ‘ltemobile.apn’

Locate the APN settings entry for ‘ltemobile.apn’ and click on it
Locate the setting labelled ‘APN protocol’ and click on it
Modify the setting to “IPv4”
Save the APN settings by clicking the three dots in the upper right corner and clicking ‘Save’


Step 3 – Re-establish Network Connection

Force the device to reconnect to the LTE network by restarting the device


Step 4 – Verify IPv4 Mode Operation

Disable any WiFi connection
Open the ‘Settings’ App from the App drawer on the home screen
Navigate to About Phone -> Status -> IP Information
It is expected to have only an IPv4 address (25.x.x.x) configured
Ignore the link-local IPv6 address starting with “fe80”


Step 5 – Verify VPN Connectivity

Please reattempt their VPN connection and advise if the issue is resolved
Regards,

RogersCorey

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

kaymin
I've Been Around

I can't view camera through LTE, but WiFi is OK, I am using Sricam app on iPhone 7.  I see other people are having problems.  Is there a fix that Roger's can do.  I have tried everything I can, reinstall about 3 times.  Still the loss of connectivity once I am out of wireless range.  Very frustrating.  Going on holiday soon. Would like to take care of this problem first!

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

Hello @kaymin,

 

We appreciate your presence in the Community and congrats on your very first post! 👍

 

I don't blame you for wanting to tie up any loose ends before you start your vacation, I am the same way! As discussed throughout this thread, there is a known issue with certain apps having trouble connecting via mobile data. 

 

If you have a residential account, we may be able to apply a temporary workaround for you to help with this problem. 

 

If possible, please send us a Private Message to @CommunityHelps and we can have a look to see if your device is eligible for the temporary workaround. For more information on how our Private Messaging system works, please CLICK HERE.


If you have a business account type, please call in to report the issue through your appropriate channel of support.

 

Thank you!

RogersLaura

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G

nigelncwong
I Plan to Stick Around
Thanks for the method for Android phone. I'm on iPhone so cannot change it to ipv4.

Any workaround for iPhone? Or better yet when is Rogers fixing this?

I'm using nordvpn and on LTE.

Please help!!!

Re: Issues with IKEv2 IPSec VPN on Rogers LTE/3G


@nigelncwong wrote:
Thanks for the method for Android phone. I'm on iPhone so cannot change it to ipv4.

Any workaround for iPhone? Or better yet when is Rogers fixing this?

I'm using nordvpn and on LTE.

Please help!!!

Send a PM to @CommunityHelps they were in the past loading an ipv4 only profile for iPhones. I am not sure if they are still doing this, or if it's only for corporate accounts. Also this isn't a Rogers only issue, T-Mobile and other advanced networks that support ipv6 on cellular also experience this. The problem is the app should support both ipv4 and ipv6, but a few older apps haven't been upgraded to support ipv6.